-
Posts
13,543 -
Joined
Content Type
Forums
News
20th
EduGeek EDIT Conference
Blogs
Everything posted by Geoff
-
It's probably set to use DHCP, so you'll need to switch it over to whatever static IP you wanted to use.
-
I've put Linux boxes between Exchange and the outside world running postfix+SpamAssassin+Amavisd-new plenty of times. It helps cut out a lot of junk mail. However assuming you have a new(ish) version of Exchange doesn't it do a lot of antispam out of the box?
-
Replicating server DNS zone has no contents.
Geoff replied to dany2010's topic in Windows Server 2008 R2
What happens when you troubleshoot with nslookup? -
I use a PXELinux boot menu. PXELINUX - Syslinux Wiki One of the options being Clonezilla.
-
I do hope the Sky at Night can carry on without him.
-
I don't currently have any invites, but when I get some I'll let you know.
-
Ugh, that's terrible engineering if it's true. You should never design things to fail 'on' you should ensure that if anything goes wrong it all turns off and comes to a complete stop in as carefully a control manner as possible under the circumstances.
-
Is DNS scavenging enabled? Are dynamic DNS updates working?
-
As far as I can discern from the bugzilla the scrolling issue was fixed around two and a half years ago in v6.0.5 or shortly thereafter. Bug 45905 – ipad support for mobile lite client
-
If you think it is SELinux you can temporally put it into permissive mode to check.
-
Well the buttons on the Polycoms all work however I also give them iSyphony. Operator Panel for Asterisk - iSymphony
-
Bandwidth usage - how can I find device causing it
Geoff replied to techie1982's topic in Internet Related/Filtering/Firewall
For general traffic If you have managed switches you can query them via SNMP and ask for their traffic counters. As long as you know what uses which switch port (and you should!) then it'd be fairly obvious (I have a Linux server running Cacti doing this here). Short of that, as above you need to mirror the port and monitor the traffic flows that way. If you main switch doesn't support mirroring then another option is have a machine setup as a layer 3 bridge and run some monitoring software on that (I've done this in the past with ntop on Linux). If it's simply web traffic that's the issue (usually the only internet traffic a school network produces in any quantity due to how locked down LEA networks are) then you should be able to work out the usage from your web proxy logging. -
Make sure the new machine has a GigE nic (I'd be amazed if it doesn't) and you have a GigE port for it somewhere near your network core.
-
Personally I use Ubuntu LTS on my servers. As you say it's perfectly possible to connect up to your AD domain with samba for user authentication. If you struggle setting this up (quite a lot of people do on the first few attempts), there's plenty of help here to get you through it. As for your choice of hardware, it is more than adequate for what you want. As you're using it as a file server then processing power isn't a big deal. It's the amount of ram that is important. More ram means more file caching.
-
Squid/Dansguardian - pages not loading correctly?
Geoff replied to dgsmith's topic in Internet Related/Filtering/Firewall
If the cache_dir is commented out then it's not using the disk for caching. If you want to check if your disks are ok the best thing to use is to install (assuming these are IDE/SATA disks?) smartmontools (that's the package name in Debian based distros anyway) and run: smartctl -a /dev/sda Obviously change the device path for your actual disk drive. You get some output along these lines: smartctl 5.41 2011-06-09 r3365 [x86_64-linux-3.2.0-33-generic] (local build) Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net === START OF INFORMATION SECTION === Model Family: Seagate Barracuda XT Device Model: ST32000641AS Serial Number: 9WM4LA84 LU WWN Device Id: 5 000c50 02e2255f5 Firmware Version: CC13 User Capacity: 2,000,398,934,016 bytes [2.00 TB] Sector Size: 512 bytes logical/physical Device is: In smartctl database [for details use: -P show] ATA Version is: 8 ATA Standard is: ATA-8-ACS revision 4 Local Time is: Thu Dec 6 12:54:26 2012 GMT SMART support is: Available - device has SMART capability. SMART support is: Enabled === START OF READ SMART DATA SECTION === SMART overall-health self-assessment test result: PASSED General SMART Values: Offline data collection status: (0x82) Offline data collection activity was completed without error. Auto Offline Data Collection: Enabled. Self-test execution status: ( 0) The previous self-test routine completed without error or no self-test has ever been run. Total time to complete Offline data collection: ( 609) seconds. Offline data collection capabilities: (0x7b) SMART execute Offline immediate. Auto Offline data collection on/off support. Suspend Offline collection upon new command. Offline surface scan supported. Self-test supported. Conveyance Self-test supported. Selective Self-test supported. SMART capabilities: (0x0003) Saves SMART data before entering power-saving mode. Supports SMART auto save timer. Error logging capability: (0x01) Error logging supported. General Purpose Logging supported. Short self-test routine recommended polling time: ( 1) minutes. Extended self-test routine recommended polling time: ( 255) minutes. Conveyance self-test routine recommended polling time: ( 2) minutes. SMART Attributes Data Structure revision number: 10 Vendor Specific SMART Attributes with Thresholds: ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE 1 Raw_Read_Error_Rate 0x000f 117 099 006 Pre-fail Always - 126542344 3 Spin_Up_Time 0x0003 100 100 000 Pre-fail Always - 0 4 Start_Stop_Count 0x0032 100 100 020 Old_age Always - 51 5 Reallocated_Sector_Ct 0x0033 100 100 036 Pre-fail Always - 0 7 Seek_Error_Rate 0x000f 076 060 030 Pre-fail Always - 47586240 9 Power_On_Hours 0x0032 089 089 000 Old_age Always - 10135 10 Spin_Retry_Count 0x0013 100 100 097 Pre-fail Always - 0 12 Power_Cycle_Count 0x0032 100 100 020 Old_age Always - 31 183 Runtime_Bad_Block 0x0032 100 100 000 Old_age Always - 0 184 End-to-End_Error 0x0032 100 100 099 Old_age Always - 0 187 Reported_Uncorrect 0x0032 100 100 000 Old_age Always - 0 188 Command_Timeout 0x0032 100 099 000 Old_age Always - 13 189 High_Fly_Writes 0x003a 100 100 000 Old_age Always - 0 190 Airflow_Temperature_Cel 0x0022 061 047 045 Old_age Always - 39 (Min/Max 35/48) 191 G-Sense_Error_Rate 0x0032 100 100 000 Old_age Always - 0 192 Power-Off_Retract_Count 0x0032 100 100 000 Old_age Always - 23 193 Load_Cycle_Count 0x0032 100 100 000 Old_age Always - 53 194 Temperature_Celsius 0x0022 039 053 000 Old_age Always - 39 (0 19 0 0) 195 Hardware_ECC_Recovered 0x001a 032 015 000 Old_age Always - 126542344 197 Current_Pending_Sector 0x0012 100 100 000 Old_age Always - 0 198 Offline_Uncorrectable 0x0010 100 100 000 Old_age Offline - 0 199 UDMA_CRC_Error_Count 0x003e 200 200 000 Old_age Always - 0 240 Head_Flying_Hours 0x0000 100 253 000 Old_age Offline - 128063039875029 241 Total_LBAs_Written 0x0000 100 253 000 Old_age Offline - 2275397588 242 Total_LBAs_Read 0x0000 100 253 000 Old_age Offline - 4182057288 SMART Error Log Version: 1 No Errors Logged SMART Self-test log structure revision number 1 No self-tests have been logged. [To run self-tests, use: smartctl -t] SMART Selective self-test log data structure revision number 1 SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS 1 0 0 Not_testing 2 0 0 Not_testing 3 0 0 Not_testing 4 0 0 Not_testing 5 0 0 Not_testing Selective self-test flags (0x0): After scanning selected spans, do NOT read-scan remainder of disk. If Selective self-test is pending on power-up, resume after 0 minute delay. There's also a daemon called 'smartd' you can have running from system startup. It will log to the syslog about bad sectors/etc and also email you if so configured. -
Well if you're not interested in editing config files then the only Admin interfaces that works properly are the FreePBX and Elastix ones.
-
*shrug* most of my asterisk work is command line? Or are you farming out admin access to some users?
-
Squid/Dansguardian - pages not loading correctly?
Geoff replied to dgsmith's topic in Internet Related/Filtering/Firewall
That's the 'default' location for squids cache. If it's been put somewhere else by your distros install then you will have to look at the squid config to find out where. Check what the 'cache_dir' parameter says in 'squid.conf' squid : cache_dir configuration directive It also occurs to me there may be an underlying hardware issue causing all of this. Are your hard drives ok? -
Squid/Dansguardian - pages not loading correctly?
Geoff replied to dgsmith's topic in Internet Related/Filtering/Firewall
Something along the lines of: service squid stop rm -fr /var/lib/squid/cache/* squid -r service squid start Basic idea is to stop squid, delete the entire cache, tell squid to recreate it's cache then start squid up again. -
I think around 1.7?
-
Squid/Dansguardian - pages not loading correctly?
Geoff replied to dgsmith's topic in Internet Related/Filtering/Firewall
It depends if you use different ports for transparent vs non-transparent (which you should, otherwise you get those netfilter errors). -
Squid/Dansguardian - pages not loading correctly?
Geoff replied to dgsmith's topic in Internet Related/Filtering/Firewall
I take it squid is running transparently from the NetFilter errors? What happens if you directly proxy rather than run as an intercept? -
Squid/Dansguardian - pages not loading correctly?
Geoff replied to dgsmith's topic in Internet Related/Filtering/Firewall
Have you ruled out issues with your internet connectivity? -
Death Star Petition On White House Website
-
Are you sure about that? The Russian maffia aren't very nice people.
