Chunks_
Members-
Posts
104 -
Joined
-
Last visited
Content Type
Forums
News
20th
EduGeek EDIT Conference
Blogs
Everything posted by Chunks_
-
Hi, Thanks for the quick reply. Ive had a read through and im pretty sure ldap is up and running on the same server as moodle. So now im starting to second guess myself which is not good at all. Could you confirm what server name do i need to put in the host section in moodle ? the ldap host i.e the moodle server as thats where its configured in the php.ini or the active directory with the Certificate Auth role ? How can i find out what these servers are doing when i run the auth_ldap_sync_users.php ? i cant find anything in any log that says whats going on ... any pointers as to where i might find at least some error codes to look at ? I have this as the phpwin.exe thingy attribute -f C:\inetpub\wwwroot\auth\ldap\auth_ldap_sync_users.php > c:\inetpub\wwwroot\admin\cron.log but nothing seems to appear in the cron.log Cheers for your assistance
-
Hi All, Bit of a novice at this so go easy with. Setup a server 2008 with IIS 7. configured PHP and included the ldap exstension. After tons of issues got moodle installed and its all setup i can access it. Now i cant for the life of me get the ldap to work. Ok so heres the background info for you. mysql version 5.5 php ver 5.3.6 Moodle Ver 1.9 Now i have followed the instructions on the moodle.org website and still struggling. I have created a file called ldap.cong in C:\OpenLDAP\sysconf. inserted the line TLS_REQCERT never in the file. On the 2008 dc server which contains the AD i have installed CA servers. I could not install the enterprise version so had to go with the standalone option. As i have never done this before i have no idea what im doing and whether its done right or not. needless to say when i try and connect using LDP.exe on the dc to my moodle server running the ldap i get this error message: ld = ldap_sslinit("myldapservername", 636, 1); Error 81 = ldap_set_option(hLdap, LDAP_OPT_PROTOCOL_VERSION, 3); Error 81 = ldap_connect(hLdap, NULL); Server error: Error <0x51>: Fail to connect to myldapservername. I have tried using the IP and using port 389. Neither work. I have checked the Phpinfo and the ldap section is there with the following info : LDAP Support enabled RCS Version $Id: ldap.c 306939 2011-01-01 02:19:59Z felipe $ Total Links 0/unlimited API Version 3001 Vendor Name OpenLDAP Vendor Version 20319 SASL Support Enabled Directive Local Value Master Value ldap.max_links Unlimited Unlimited Go easy as like i say ive not done all this before and really trying to get it to work. Really frustrated at this problem as i expect i have not done something simple due to my distinct lack of experience in this area. Cheers for any help
-
Forget it .. i think i have it working now... it was down to an extension in the php.ini me thinks. Now i get. The 'Data Directory' you specified could not be found or created. Either correct the path or create that directory manually. When im running through the moodle installphp. No matter what directory i change it too, it still errors and i cant get past this screen. Its a test platform so doesnt matter if anything gets completely messed up. Any Ideas?
-
Hi, Im looking to bring our moodle "in house" its currently hosted by our local authority. As this is a largish school im trying to set it all up manually. the instructions i found are great if you are trying to set this up on a 2003 server with iis6 but im doing it with 2008 and iis7. I have installed iis 7 got the services up and running. installed mysql .. now onto php. I cant for the life of me get this working. I get the following error when running <?php phpinfo(); ?> in a php file. Module FastCgiModule Notification ExecuteRequestHandler Handler PHP Error Code 0x800736b1 Requested URL http://localhost:80/phpinfo.php Physical Path C:\inetpub\wwwroot\phpinfo.php Logon Method Anonymous Logon User Anonymous The iis 6 version says about Adding and allow the PHP ISAPI Extension to IIS Web Service Extensions: C:\PHP\php5isapi.dll dont know how to do that in iis7 and also Turn on scripting permissions for your websites which i also do not know how to do. Is this essentially whats missing or am i way off the mark. Could really do with some help.... (I had moodle up and running when i used the install package for small sites)
-
I find resetting Internet explorer to its default settings can sometimes fix issues in i.e etc. But to be honest prob best to reinstall the computer if u have the image
-
You can This has been discussed lots before. If you delete the dekstop.ini file from within the user area then it renames it back but the file will keep reappering. Going to server 2008 will not solve as we have recently upgraded to 2008 and it still occurs. Check out this microsoft article In addition you could Run a schedule task to delete the files periodically. or You could also just add an extra column to the view of windows explorer called “Filename” (windows 7 method) right click on title name in explorer window - click more. Then put a tick next to filename. Click ok and it puts a new column with the names in. This has been discussed in more depth here http://www.edugeek.net/forums/windows-server-2008/53755-home-folders-renames-my-documents.html
-
In regards to your second problem ... deleting the desktop.ini file from the user area automatically makes the name correct again. if the stuff in the microsoft article doesnt appeal to you... you can setup a batch file that you setup to run every night through scheduled task to delete any of the desktop.ini files. You can find batch file code for that here.
-
I found this system tools removal guide helpful when i had 2 instances of this occuring. Apparently the london stock exchange was spreading it through an ad at one point.
-
to be honest i just use this code. If you want to remove the proxy from say a laptop when a user takes it home just add it in to the logoff script. and then let the gpo do the rest when its plugged back in.
-
Anyone seen this malware recently
Chunks_ replied to reggiep's topic in Internet Related/Filtering/Firewall
Yeah, Seen this on a couple of machines myself. System tool it was called on my occasion... hijacks the desktop - nasty bugger as it stops you running any programs even task manager. Anyway heres a nice easy link to removal instructions . The other link above wasnt as accurate and made you do things that werent nessacery in my situation. -
Sorry to dredge up this thread again, but i was also wanting to do this and keep syncronization. As i read through the thread i was eagerly awaiting the batch file script that could be scheduled to delete the desktop.ini file. But alas i have got to the end and there was no script so i sorted it. Batch file script to delete desktop.ini file. Thought it would be nice to share with you all. If the link is helpful please thank me
-
Think i may have been a numpty.... although not of my own doing. Last year i went through the process following the notes but my predecessor must have taken steps before he left so when i followed the notes that year it just worked.... this year however i now realised he must have gone through additional step (only briefly mentioned in notes, not guided through) to get the promotion working properly. Never had to do this before because he had kindly done it for me. Dont want to tell you what it was cos you will all point and laugh Thanks for your help peeps
-
Run through that twice ...
-
if i add the column "promotable" to the browser it puts all my schemes under no promotable. Why would that be ? What makes a scheme not promotable...
-
No problem sivadam, thanks for your help. Ive already logged a call ... waiting for reply .. but was hoping someone might go yeah i know what the problem is rather than waiting days for them to get back to be. Thanks again.
-
I have God status, I.e i made a user group that has access to everything ! I completed this process with no problems last year.
-
I have followed the instructions they sent. We have setup the promotion rules and exported the basic band structure. The students all appear in the curriculum assignment and the blocks also appear. Its just the option to run the wizard is greyed out. I have tried resetting up the promotion rules it hasnt worked. I am working in the academic year of 2011 - 12 so in answer to that questions yes (would have been gutted and felt stupid if it was that )
-
Hi All, Wonder if you can help. Im attempting to place students in bands (beautiful tick grids) yet when i try to use the promotion wizard to do this. The button is greyed out!? have i missed a trick here ? Cheers
-
Desktop Redirection using Security Groups - not working as XP :(
Chunks_ replied to kennysarmy's topic in Windows 7
We used the WMi filtering to direct windows 7 policys seperate to windows xp. When we started adding windows 7 PC's we had no filtering. After setting it up i made sure all the original policies were filtered for xp and then made new ones for windows 7 and filtered them to 7 (we skipped vista) This has worked fine for us so hopefully u should be ok too. -
I was trying to do the same thing. I found here you can make the above settings into an adm file so you can import into group policy so its appears as on off radio buttons. Prooved Very useful for me.
