vikpaw Posted July 2, 2012 Posted July 2, 2012 Upgrade instructions are here : https://opsoftware.net/helpdesk/kbDetails.aspx?id=46 Do not forget to upgrade/replace your web.config file as there will have been changes to this as we move most settings into the admin area. What email server/service are you using? Sounds like a permissions error. When you do an SMTP test place a check in the generate log option and once done check the App_Data folder for the text file, this records the entire SMTP handshake and will generally give you lots more information on what may be happening. Make sure you clear the browser cache to ensure the upgraded files are replaced on the local PC that will solve your error. Again clear the browser cache. I basically followed those instructions, based on past experience, except i dropped in a clean OPSD folder, so had to copy in licence file some pics and things. That's probably why i lost the logos. Clearing cache, removed the staff one that was there, but i've put it back now. I already did the logging for email. We use Exchange 2010. It was never an issue before, but like you say, the mechanism your sending by has changed. The change in the way outbound emails has changed in v2.2 is we no longer use the built in .Net email facility and have a custom one now instead, this allows us to be able to provide a much more flexible inbound and outbound email service supporting SSL and custom ports as well as support for GMail and Live@Edu(Office 365 for Education) We have ramped up the error checking and made it more standards compliant so this is why you are now being notified more about permissions. With v2.3 due out in a few weeks this is taken further with each support queue now being email enabled so you can have mulitple mailboxes for different queues. I'm not sure why i now need more permissions, it's probably that the from account has changed. Looking at older notification emails, the reply-to address used to be the same as the email polling address. It is now the distribution group. So before it was coming from the distribution group email but it still said IT helpdesk, and the reply to was set as the ithelpdesk. Now it's coming from the distribution group email and states that, the reply to is the distribution group too. I'm hesitant to change the outbound email address to the ithelpdesk one now, as i think that will alleviate the permissions issue, but i think it will create a loop as each email will be forwarded to itself and then polled as an update. Nice feature on the auto-close, only problem is, it just closed a couple of calls, where the user was the last responder so it doesn't make sense that the user hasn't updated. In fact it just draws attention to the fact that a ticket was not updated by us for two weeks! Will it only operate on open calls, or will On Hold also get actioned?
ICTNUT Posted July 3, 2012 Author Posted July 3, 2012 I'm hesitant to change the outbound email address to the ithelpdesk one now, as i think that will alleviate the permissions issue, but i think it will create a loop as each email will be forwarded to itself and then polled as an update. This is a known "loop" issue with Exchange and as of the next release is removed and set as part of the individual queue email settings. Nice feature on the auto-close, only problem is, it just closed a couple of calls, where the user was the last responder so it doesn't make sense that the user hasn't updated. In fact it just draws attention to the fact that a ticket was not updated by us for two weeks! Will it only operate on open calls, or will On Hold also get actioned? Auto close ONLY affects calls in progress, open and on-hold are not affected. The process is open calls will be affected by any SLA rules you may have in place, in progress calls are affected by SLA and Auto close, on-hold is exepmt from auto close and SLA. There has been a feature request logged with us that auto close be queue specific, we are looking into this to see if this would be of benefit and may add this at a later date.
jamesmay Posted July 3, 2012 Posted July 3, 2012 Ah thats why i received a load of duplicate emails yesterday... Any idea on the release date of 3.3 yet?
vikpaw Posted July 3, 2012 Posted July 3, 2012 Ok, i get it now, just need to put all our calls on hold for a few weeks over the summer. Mobile site finally works - it's pretty awesome. Can someone tell me if it's possible to get the site to work from the ip address, rather than the dns name, as it's a faff with our wireless to have to put in the proxy and get dns working. if we could just browse to ip address/opsd or whatever that would be really useful. Also, i know file downloads are going, but i still can't get my old ones to work. they used to live in a file_downloads folder, but it's asking for them to be in a support_uploads folder, but it doesn't work in either. this is the link: http://ithelpdesk/Staff/getFiles.ashx?opt=1&f=1f1b2fd6-5d08-4e3b-96bc-6518c8b6a1d8.docx&n=Running%20Reports%20in%20SIMS.docx and this is the error: [color=#000000][font=Verdana][b][i]Could not find a part of the path 'C:\inetpub\wwwroot\OPSD\App_Data\file_uploads\support_uploads\'.[/i][/b] [/font][/color][font=Arial][color=#000000][b]Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. [b]Exception Details: System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\inetpub\wwwroot\OPSD\App_Data\file_uploads\support_uploads\'. [b]Source Error: [TABLE="width: 100%"] [TR] [TD]An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.[/TD] [/TR] [/TABLE] [b]Stack Trace: [TABLE="width: 100%"] [TR] [TD][DirectoryNotFoundException: Could not find a part of the path 'C:\inetpub\wwwroot\OPSD\App_Data\file_uploads\support_uploads\'.] System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) +193 System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy) +1162 System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share) +66 System.IO.File.Open(String path, FileMode mode) +58 OPSD.Staff.GetFiles.ProcessRequest(HttpContext context) +237 System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +181 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75[/TD] [/TR] [/TABLE] [hr][b]Version Information: Microsoft .NET Framework Version:2.0.50727.4223; ASP.NET Version:2.0.50727.4223[/b][/b][/b][/b][/b][/color][/font] Are old uploads defunct as of now? Also, it still thinks my chrome browser is AppleMAC-Safari v5.0 I'm pretty sure, Sergey Brin is not going to like that!
ICTNUT Posted July 3, 2012 Author Posted July 3, 2012 Ah thats why i received a load of duplicate emails yesterday... Any idea on the release date of 3.3 yet? End Of July
vikpaw Posted July 3, 2012 Posted July 3, 2012 @ICTNUT - have you had any reports of the links in emails not working? On my setup they are all different depending on type of email. Some with localhost in URL, some without, some with an extra HTTP, others it just dumps the {%% link %%} into the message.
ICTNUT Posted July 3, 2012 Author Posted July 3, 2012 Can someone tell me if it's possible to get the site to work from the ip address, rather than the dns name, as it's a faff with our wireless to have to put in the proxy and get dns working. if we could just browse to ip address/opsd or whatever that would be really useful. Trying to get this in for the v2.3 release so that you can have more that one url you can access the helpdesk by as current licensing locks to the install address so if you try to access via IP you get the unlicensed error message. Also, i know file downloads are going, but i still can't get my old ones to work. they used to live in a file_downloads folder, but it's asking for them to be in a support_uploads folder, but it doesn't work in either. Have you checked that the file_uploads folder exisits within the app_data folder? the error message would suggest not. Create the folder and make sure the support_uploads folder is within it. From v2.3 file uploads have indeed been removed so I would start to prep and move your file uploads over to the knowledge base. Also, it still thinks my chrome browser is AppleMAC-Safari v5.0 I'm pretty sure, Sergey Brin is not going to like that! We'll test and see what is happening there, hehe funny though
jamesmay Posted July 3, 2012 Posted July 3, 2012 cool stuff, can you have a look at my validation file today so can get that sorted. have had to turn all my email stuff off because of the exchange loop, it was polling it and creating new support cases ever 10 minutes
ICTNUT Posted July 3, 2012 Author Posted July 3, 2012 cool stuff, can you have a look at my validation file today so can get that sorted. have had to turn all my email stuff off because of the exchange loop, it was polling it and creating new support cases ever 10 minutes Validating as we speak If it is causing an issue we could possibly get you a pre-release copy in the next few days?
jamesmay Posted July 3, 2012 Posted July 3, 2012 if you could as the email submission and notifications are good aside from having support case replicating themselves every 10 minutes
ICTNUT Posted July 3, 2012 Author Posted July 3, 2012 if you could as the email submission and notifications are good aside from having support case replicating themselves every 10 minutes OK will arrange for an upgrade towards the end of the week for you, and will supply via our helpdesk site.
vikpaw Posted July 3, 2012 Posted July 3, 2012 cool stuff, can you have a look at my validation file today so can get that sorted. have had to turn all my email stuff off because of the exchange loop, it was polling it and creating new support cases ever 10 minutes You've just made me realise, that now, users can't reply to the emails they get! I think... Before, they got an email from itteam group but the reply-to was the ithelpdesk so it would be polled. now they get it from the itteam, so the team will see them but it wont update on the helpdesk anymore. if we use the ithelpdesk as the outbound email it will send to itself and then i guess loop. Can't we just change the reply-to address, that would solve it for us. So there is a send-to address which is a distribution group who get copied on everything. and then a reply to which is the polled address. @ICTNUT - the folder structure is defo there, i created it again. it's the same issue i had last time and logged a support request. I was trying to find it but couldn't log in to site - for some reason this always happens to me! tried password reset but got this: D:\WEBSITES\www.opsoftware.net\helpdesk\App_Data\smtp_out.txt' is denied
ICTNUT Posted July 3, 2012 Author Posted July 3, 2012 Can't we just change the reply-to address, that would solve it for us. So there is a send-to address which is a distribution group who get copied on everything. and then a reply to which is the polled address. That should be OK for you as you have changed the permission in exchange to allow "Send As"
jamesmay Posted July 3, 2012 Posted July 3, 2012 I've generated a new licence file for you to have a look at
ICTNUT Posted July 3, 2012 Author Posted July 3, 2012 I've generated a new licence file for you to have a look at All done and sent back for you.
jamesmay Posted July 3, 2012 Posted July 3, 2012 Magic, thats worked. Looking forward to having emails playing nicely now
ICTNUT Posted July 3, 2012 Author Posted July 3, 2012 Magic, thats worked. Looking forward to having emails playing nicely now Super, i'll drop you an email once we have the pre-release ready for you , ETA Thursday
jamesmay Posted July 3, 2012 Posted July 3, 2012 Trying to get this in for the v2.3 release so that you can have more that one url you can access the helpdesk by as current licensing locks to the install address so if you try to access via IP you get the unlicensed error message. Have you checked that the file_uploads folder exisits within the app_data folder? the error message would suggest not. Create the folder and make sure the support_uploads folder is within it. From v2.3 file uploads have indeed been removed so I would start to prep and move your file uploads over to the knowledge base. We'll test and see what is happening there, hehe funny though As the file upload is going, how will staff attach screen shots etc ?
ICTNUT Posted July 3, 2012 Author Posted July 3, 2012 As the file upload is going, how will staff attach screen shots etc ? I think you misunderstand a little, i will clarify. The was a feature called file downloads where, like a knowledgebase, you could have categories of file downloads. As there was such an overlap between file downloads and the knowledge base the decision was taken to remove file downloads as a whole. This is not to be confused with the ability for user to upload files and such to support requests, this will always be there.
vikpaw Posted July 7, 2012 Posted July 7, 2012 Can someone please remind me where i control which file types can be added to an incident. I've looked in web.config but there are half a dozen places that list extensions and none of them match the list that comes up on a new incident. Also, new incidents and replies don't have control over text size / format which was supposedly an easy fix in the last version. Any news ...?
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now