Jump to content

Recommended Posts

Posted

Morning all,

I'm using Malwarebytes but think its starting to run it's course (blocking google 2 weeks back didn't help its case) so I'm looking around and wondering what you all use or can recommend. I'm looking at Threatlocker but interested to know what is being used around schools. Preferably something lightweight to partner with Defender.

 

Thanks

Posted
We have just had incredibly good pricing for BitDefender from Phoenixs. Cheapest quote on any product by far, and just over half the price of the closest BitDefender quote.
Posted (edited)

We've got (almost) the whole Defender suite with 365 A5. It does the job and integrates with the rest of the security systems in 365 providing almost a "single pane of glass" for the health of the security of your estate. As well as blocking malware, if you fancy learning KQL you can pretty much find out anything that's happened like "who launched Teamviewer this week.

 

 

DeviceNetworkEvents  
| where Timestamp < ago(7d) and InitiatingProcessFileName has ("TeamViewer")
| summarize MachineCount=dcount(DeviceName), MachineNames=makeset(DeviceName, 5) by    InitiatingProcessAccountName
| order by MachineCount desc

Edited by psydii
  • Thanks 1
Posted

We use Windows Defender on Desktops, with IT and SMT users using Defender 365 with A5.

 

On our more critical servers we use Microsoft Defender for Endpoint Server. The portal gives a good overview of security recommendations as well.

 

On Macs we have gone with JAMF Protect, which seems ok.

Posted
We have just had incredibly good pricing for BitDefender from Phoenixs. Cheapest quote on any product by far, and just over half the price of the closest BitDefender quote.

 

We're using BGZ and don't have any complaints. :)

 

We opted not to use the relay deployment and everything has been smooth sailing.

Posted
we use panda/watchguard, not the most lightweight but it works and has stopped a few nasties brought in by the kids for us. We run it in whitelist mode which can be a bit awkward if you run a lot of odd software but after the initial learning period it works ok. We develop our own software so getting a whitelist cert is a must unless you want to hash each of your programs!
Posted
We have Defender P1 for most of our users as part of the M365 A3 package, but buy the step up P2 for SLT and Admin users across the Trust.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...