+ Post New Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 36
Windows Thread, Windows update website wont work on XP SP3 - thinks it hasn't got SP3?! in Technical; This is a rather annoying problem. Been creating a few images, all have gone fine, but the last 2 have ...
  1. #1

    Join Date
    Jul 2006
    Location
    London
    Posts
    2,962
    Thank Post
    159
    Thanked 152 Times in 116 Posts
    Rep Power
    49

    Windows update website wont work on XP SP3 - thinks it hasn't got SP3?!

    This is a rather annoying problem.

    Been creating a few images, all have gone fine, but the last 2 have redirected to this page when I go to windowsupdate.com or microsoftupdate.com

    You may be unable to access the Windows Update website from Windows XP, Windows 2000 or Windows Server 2003 if those versions of Windows are not updated to the latest Service Pack

    The first machine eventually let me use the site after a few attempts but the one I am doing now just will not budge. I've rebooted, tried installing updates through automatic updates first, and installed the latest Windows Update Agent. Makes no difference.

    I've installed off a proper XP SP3 image from the MSVLS site with our EES agreement, so no customised ISO's or anything, I just can't understand it.

    Anyone else had this?

  2. #2

    Join Date
    Aug 2011
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I am having the same problem, I am updating some pc's with the XP SP3 pack and once this is done get them to download updates from windows update. However I get the same error as it thinks they do not have the SP3 pack installed and therefore leads you to go and download that first even though you already have it installed.

    Would appreciate some help soon.

    Thanks

    Wil5on.

  3. #3

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,696
    Thank Post
    335
    Thanked 515 Times in 483 Posts
    Rep Power
    179
    Quote Originally Posted by sidewinder View Post
    This is a rather annoying problem.

    Been creating a few images, all have gone fine, but the last 2 have redirected to this page when I go to windowsupdate.com or microsoftupdate.com

    You may be unable to access the Windows Update website from Windows XP, Windows 2000 or Windows Server 2003 if those versions of Windows are not updated to the latest Service Pack

    The first machine eventually let me use the site after a few attempts but the one I am doing now just will not budge. I've rebooted, tried installing updates through automatic updates first, and installed the latest Windows Update Agent. Makes no difference.

    I've installed off a proper XP SP3 image from the MSVLS site with our EES agreement, so no customised ISO's or anything, I just can't understand it.

    Anyone else had this?
    Try reregistering Wups2.dll with regsvr32, Sometimes it doesn't update so thinks it's an old version stilll

    Steve

  4. #4

    Join Date
    Apr 2011
    Location
    Grimsby
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Is ie8 installed?

  5. #5
    round2it's Avatar
    Join Date
    May 2009
    Location
    UK
    Posts
    999
    Thank Post
    198
    Thanked 144 Times in 102 Posts
    Rep Power
    36
    i just did a machine and i had to install ie 8 for the updates site to work

  6. #6

    creese's Avatar
    Join Date
    Feb 2009
    Location
    -28° 31' 48.89", +28° 25' 37.42" ... if only.
    Posts
    3,253
    Thank Post
    181
    Thanked 375 Times in 304 Posts
    Rep Power
    174
    I had this yesterday. I kept trying and a few reboots. Eventually it ran and is now fully updated. I'm non the wiser why.

  7. #7

    Join Date
    Jul 2006
    Location
    London
    Posts
    2,962
    Thank Post
    159
    Thanked 152 Times in 116 Posts
    Rep Power
    49
    Thanks for the suggestions. I have tried installing IE8 and registering wups2.dll and it still doesnt work, this is ridiculous

  8. #8

    creese's Avatar
    Join Date
    Feb 2009
    Location
    -28° 31' 48.89", +28° 25' 37.42" ... if only.
    Posts
    3,253
    Thank Post
    181
    Thanked 375 Times in 304 Posts
    Rep Power
    174
    Found this:

    Csn&#39t run windows update w/ sp3. - MSFN Forum

    http://download.windowsupdate.com/wi...gent30-x86.exe

  9. 3 Thanks to creese:

    Harlquinth (17th August 2011), mattx (9th August 2011), Sam_Brown (25th August 2011)

  10. #9

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,763
    Thank Post
    3,273
    Thanked 1,053 Times in 974 Posts
    Rep Power
    365
    Code:
    net.exe stop wuauserv
    cd /d %windir%
    rd /s softwaredistribution
    REGSVR32 %windir%\system32\wuapi.dll
    REGSVR32 %windir%\system32\wuaueng1.dll
    REGSVR32 %windir%\system32\wuaueng.dll
    REGSVR32 %windir%\system32\wucltui.dll
    REGSVR32 %windir%\system32\wups.dll
    net.exe start wuauserv
    code from another thread on edugeek basically stopping the automatic update service, re registering dll files relating to the update service etc and then starting the automatic update service again.

    FYI - This is code from a bat ( batch ) file

    User account your are logged in as has local admin rights and is an AD account whether domain admin or normal user account with local admin rights and has the correct proxy settings applied via GPO ?
    Last edited by mac_shinobi; 4th August 2011 at 02:47 PM.

  11. #10

    Join Date
    Jul 2006
    Location
    London
    Posts
    2,962
    Thank Post
    159
    Thanked 152 Times in 116 Posts
    Rep Power
    49
    mac_shinobi I'll try that now

    Quote Originally Posted by creese View Post
    Found this:

    Csn&#39t run windows update w/ sp3. - MSFN Forum

    http://download.windowsupdate.com/wi...gent30-x86.exe
    Yeah tried that one...didnt work either

  12. #11

    Join Date
    Jul 2006
    Location
    London
    Posts
    2,962
    Thank Post
    159
    Thanked 152 Times in 116 Posts
    Rep Power
    49
    Nope, that doesn't work either

    Tried with both a local admin and domain admin account.

    Such a frustrating problem. Going to have to reinstall XP I think and hope it works next time

  13. #12
    RobMongoose's Avatar
    Join Date
    Jul 2010
    Location
    Tyne & Wear, UK
    Posts
    36
    Thank Post
    3
    Thanked 3 Times in 3 Posts
    Blog Entries
    1
    Rep Power
    9
    Same problem here. Have tried all of the above including installing XP w/ SP2 and updating it. Hope this starts working soon. Very annoying...

  14. #13

    Join Date
    Apr 2011
    Location
    Grimsby
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    have you tried stopping the windows update service and deleted everything out of the software distribution folder in the windows folder?

  15. #14
    markcuk's Avatar
    Join Date
    Sep 2005
    Posts
    586
    Thank Post
    29
    Thanked 60 Times in 55 Posts
    Rep Power
    38
    Quote Originally Posted by creese View Post
    Found this:

    Csn&#39t run windows update w/ sp3. - MSFN Forum

    http://download.windowsupdate.com/wi...gent30-x86.exe
    did you run the file with the /wuforce option

    found this also http://www25.brinkster.com/mrfusker/...3updatefix.htm
    Last edited by markcuk; 4th August 2011 at 03:57 PM.

  16. #15
    RobMongoose's Avatar
    Join Date
    Jul 2010
    Location
    Tyne & Wear, UK
    Posts
    36
    Thank Post
    3
    Thanked 3 Times in 3 Posts
    Blog Entries
    1
    Rep Power
    9
    Quote Originally Posted by jolliver View Post
    have you tried stopping the windows update service and deleted everything out of the software distribution folder in the windows folder?
    Just tried - still the same

SHARE:
+ Post New Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 2
    Last Post: 14th December 2010, 09:16 PM
  2. Abacus Evolve Interactive Planner - Wont work on network??
    By jamin100 in forum Educational Software
    Replies: 9
    Last Post: 11th July 2008, 10:22 AM
  3. Removal of images/work on website
    By Anti in forum School ICT Policies
    Replies: 3
    Last Post: 20th July 2007, 12:32 AM
  4. Windows XP SP3 announced
    By john in forum Windows
    Replies: 17
    Last Post: 14th June 2007, 09:40 AM
  5. Windows update won't work on 2000 pro
    By woody in forum Windows
    Replies: 4
    Last Post: 22nd December 2006, 08:59 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •