+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 17
Windows 7 Thread, Proxy setting not applying in Technical; Hey, I've just been given an issue that I just can't work out! I have some Windows 7 clients on ...
  1. #1

    Join Date
    Aug 2009
    Posts
    265
    Thank Post
    20
    Thanked 20 Times in 18 Posts
    Rep Power
    14

    Proxy setting not applying

    Hey,

    I've just been given an issue that I just can't work out!

    I have some Windows 7 clients on our domain and they aren't applying their proxy settings properly.

    I push proxy settings out via GPO and I can confirm using GP Results that they're applying on the problem PCs and there isn't anything in the Event Logs... but I can tell just by trying to browse the internet that there are *no* proxy settings set.

    The users are Standard Users using mandatory profiles (which haven't got any proxy information in them).

    Any ideas?

    Thanks

  2. #2

    Join Date
    Feb 2007
    Location
    Four Oaks
    Posts
    283
    Thank Post
    37
    Thanked 10 Times in 9 Posts
    Rep Power
    21
    Quote Originally Posted by Blue_Cookeh View Post
    Hey,

    I've just been given an issue that I just can't work out!

    I have some Windows 7 clients on our domain and they aren't applying their proxy settings properly.

    I push proxy settings out via GPO and I can confirm using GP Results that they're applying on the problem PCs and there isn't anything in the Event Logs... but I can tell just by trying to browse the internet that there are *no* proxy settings set.

    The users are Standard Users using mandatory profiles (which haven't got any proxy information in them).

    Any ideas?

    Thanks
    Have you set he Proxy on the default Domain GPO? and also lower down? i found if i removed the Proxy settings from the default domain and left it lower down it applyed fine to the win 7 machines.

    on my network the default domain gpo was the only policy i migrated when upgrading to 2008 r2 from 2003 r2. I re-created all other gpo's....i thought i was maybe something to do with that.

  3. Thanks to mtdmitchell from:

    Cools (12th January 2012)

  4. #3

    Join Date
    Aug 2009
    Posts
    265
    Thank Post
    20
    Thanked 20 Times in 18 Posts
    Rep Power
    14
    There used to be some proxy settings set in the Default Domain policy from back before I got here, but I removed those months ago and these Windows 7 machines have a fresh OS on, so I can't see that being the problem.

    We're running a mix 2003R2/2008R2 XP/W7 network here. I'm using new GPOs for Windows 7 clients (selected using WMI filters, also confirmed working with GP Results).

    EDIT: Just found something else. I reenabled the ability to edit proxy information and that isn't even taking effect on the computer... odd.
    Last edited by Blue_Cookeh; 4th January 2012 at 02:20 PM.

  5. #4
    ricki's Avatar
    Join Date
    Jul 2005
    Location
    uk
    Posts
    1,475
    Thank Post
    20
    Thanked 164 Times in 157 Posts
    Rep Power
    52
    Hi

    Have you updated the adm for your version of ie. I you have the wrong adm/admx they dont always apply. Plus it might be worth trying to create another gpo with all your ie settings in and see if that works we had a corrupt policy a bit back.

    Richard

  6. #5

    Join Date
    Aug 2009
    Posts
    265
    Thank Post
    20
    Thanked 20 Times in 18 Posts
    Rep Power
    14
    OK, I made a new OU, created and linked a GPO with our proxy settings in and dropped the user in the new OU.

    All Windows restrictions were taken off (so we know it's not the old GPO being applied) but the proxy settings from the new GPO were not applied. At this point I can only imagine it is the ADM files, but this is happening on both IE8 and IE9, I'm editing the GPOs on my Windows 7 admin machine at the moment... and we do have a 2008R2 DC.

    I was thinking of just creating a logon script to set the proxy if this carries on, but I don't really want to reenable registry editing.

  7. #6

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340
    Have you applied any IE settings using GPP? If yes, I would avoid it as it appears to break IE8 and IE9.

    GPO (recommended method): User Config > Policies > Internet Explorer Maintenance > Connection > Proxy Settings

    GPP (NOT recommended): User Config > Preferences > Control Panel Settings > Internet Settings

  8. #7
    apeo's Avatar
    Join Date
    Sep 2005
    Location
    Lost
    Posts
    1,612
    Thank Post
    95
    Thanked 115 Times in 111 Posts
    Rep Power
    42
    You could try reg hack using GP Preferences.

  9. #8

    Join Date
    Aug 2009
    Posts
    265
    Thank Post
    20
    Thanked 20 Times in 18 Posts
    Rep Power
    14
    Quote Originally Posted by Michael View Post
    Have you applied any IE settings using GPP? If yes, I would avoid it as it appears to break IE8 and IE9.

    GPO (recommended method): User Config > Policies > Internet Explorer Maintenance > Connection > Proxy Settings

    GPP (NOT recommended): User Config > Preferences > Control Panel Settings > Internet Settings
    I'm trying to apply them using a GPO, yeah.

    Quote Originally Posted by apeo View Post
    You could try reg hack using GP Preferences.
    I'll give that a go tomorrow too, it's just odd that it won't do it the "official" way.

    EDIT: I've just installed 2008R2 and W7 in virtual machines on a test domain and proxy settings aren't being pushed out even on that... I must be doing something stupid here
    Last edited by Blue_Cookeh; 4th January 2012 at 09:23 PM.

  10. #9

    Join Date
    Aug 2009
    Posts
    265
    Thank Post
    20
    Thanked 20 Times in 18 Posts
    Rep Power
    14
    Just to add, I think I managed to find out the problem.

    I made a new GPO and OU for the user in question but this time I didn't set the same proxy address for all protocols, instead I set it manually for all of them except Gopher... this time IE8 and IE9 picked it up. It seems they dropped Gopher support after IE7 or something and setting it using GPOs breaks the entire setting.

  11. 2 Thanks to Blue_Cookeh:

    mreardon (9th January 2012), Oaktech (16th March 2012)

  12. #10
    apeo's Avatar
    Join Date
    Sep 2005
    Location
    Lost
    Posts
    1,612
    Thank Post
    95
    Thanked 115 Times in 111 Posts
    Rep Power
    42
    Good catch, will keep that in mind.

  13. #11

    Join Date
    Jan 2012
    Location
    Inuvik, NT
    Posts
    1
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Blue_Cookeh View Post
    Just to add, I think I managed to find out the problem.

    I made a new GPO and OU for the user in question but this time I didn't set the same proxy address for all protocols, instead I set it manually for all of them except Gopher... this time IE8 and IE9 picked it up. It seems they dropped Gopher support after IE7 or something and setting it using GPOs breaks the entire setting.
    Thank you!

    After beating my head against a wall on this issue for the past month, your post described exactly what our problem was. Now I can finally put this issue to rest and watch with excitement all of the DENIED entries in our squid logs tomorrow

  14. #12

    Join Date
    Mar 2012
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Great - thanks. This has been driving us nuts aswell. Thanks again Microsoft.

  15. #13

    Join Date
    Mar 2012
    Location
    oklahoma
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Been banging my head against this all morning too. I have tried just about everything I could think of and that's been suggested on here and other sites. I have a Win 2008 domain controller and am trying to roll out Windows 7. We are currently running XP without any issues. The proxy settings in IE are not being applied for standard users, and all other gpo settings are being applied as normal. I tried creating a domain admin account in the same OU as the affected users so it would have the same group policy settings. When I use that account to log into a Win7 workstation the proxy settings are applied as normal. When I log back in with the standard user acct I get the same symptoms as before (no proxy settings applied). I have verified that my server is up to date on all it's policy stuff and is running IE 9 like the workstations. Also verified that WMI is functioning normally on the workstations. I'm out of ideas here at the moment

    Btw, I tried the gopher fix as well with no luck..

  16. #14

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340
    If you navigate to: HKCU > Software > Microsoft > Windows > CurrentVersion > Internet Settings

    Take an export from here. The three entries you're looking for are:

    ProxyEnable 1
    ProxyOverride (your exceptions)
    ProxyServer eduproxy.whateveryoulike

    Import these using GPP on 2008 R2 and like magic, proxy settings will be applied.

  17. #15
    ricki's Avatar
    Join Date
    Jul 2005
    Location
    uk
    Posts
    1,475
    Thank Post
    20
    Thanked 164 Times in 157 Posts
    Rep Power
    52
    Hi

    Have you run a group policy results from the group policy management.

    Normally the admx are centrally stored in a windows 2008 domain and they can be updated here centrally and all domain controller can pick it up.

    It might also be worth checking the security settings if the computers cannot read the polciy they cannot apply it.

    Lastly have a look at the filters wmi filtering to check that the filter is not stopping it being read.

    Check the time date are synced with the domain as clients will not authenticate with kerberos if they are more than 5 mins out.

    I have had a bad image in the past where all the machines from that image would not apply the settings but other imaged it did.

    Are the computers with 1 gig nic cards. Try updating the driver and have you put in a gproup policy that will wait for the domain and I have to put in a reg setting that makes the computer wait a bit as the nic card is to fast for the domain.

    Group Policy may not install the PolicyMaker Software Update client on a Windows XP Service Pack 2-based computer, and event ID 5719 and event ID 1054 are logged

    I know this will sound a silly question but is the gpo attached to a user ou or a computer ou. If they are user settings it has to be applied to a user ou.

    You can force then in with a registry setting as a log on script for the users

    I used to use

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Internet Settings]
    "ProxyEnable"=dword:00000001
    "ProxyServer"="proxyroxy port no"
    "ProxyOverride"="server name1 ;server name 2;"

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Proxy settings not being applied - GPO - XP
    By j17sparky in forum Windows
    Replies: 20
    Last Post: 10th December 2013, 02:16 PM
  2. Replies: 3
    Last Post: 26th August 2010, 06:09 PM
  3. updated Internet Settings not applying
    By joe90bass in forum Windows
    Replies: 3
    Last Post: 19th March 2009, 02:05 PM
  4. Proxy settings not there on second logon.
    By robinhood in forum Learning Network Manager
    Replies: 7
    Last Post: 6th October 2007, 11:14 AM
  5. Proxy Settings Not Applied
    By dezt in forum Wireless Networks
    Replies: 16
    Last Post: 3rd October 2006, 08:26 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •