Jump to content

Recommended Posts

Posted

Client Access Role Prerequisites
Failed

Error:
Unable to read data from the Metabase. Ensure that Microsoft Internet Information Services is installed.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=a4a4d339-4009-4fb7-b842-ca2ba79f13f0

Error:
Unable to access the 'Default Web Site' on this computer.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=aadc8176-1c47-49b7-83a0-9493a1093af1

Elapsed Time: 00:00:08


Mailbox Role Prerequisites
Failed

Error:
Unable to read data from the Metabase. Ensure that Microsoft Internet Information Services is installed.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=a4a4d339-4009-4fb7-b842-ca2ba79f13f0

Elapsed Time: 00:00:06

 

But IIS is installed and running, http://localhost shows the IIS default page..

 

Is there any other role / service that Ive not enabled? Do I need the metbabase for IIS6 option installed?

Posted (edited)

OK Ive got outlook up and running I think, but when i try to go to http://mail.mydomain.com I get a

 

Server Error
403 - Forbidden: Access is denied.
You do not have permission to view this directory or page using the credentials that you supplied.

 

And when I go to the https:// I get

Secure Connection Failed

    
An error occurred during a connection to www.mydomain.com:1010.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)       


   *   The page you are trying to view can not be shown because the authenticity of the received data could not be verified.

   *   Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

Edited by RabbieBurns
Posted

I think the issue is to do with me changing the defualt IIS website port from 80 to 1010. I cant even open OWA on the localhost now

 

Anyone know what I need to change to get it back running again?

Posted
I think the issue is to do with me changing the defualt IIS website port from 80 to 1010. I cant even open OWA on the localhost now

 

Anyone know what I need to change to get it back running again?

 

no idea on the exchange side but if you are trying to use https and you changed the port to use 443 would that conflict or what ?

 

Also would be good to keep a track of - also the error you are getting regarding the authenticity - I take it you don't have to use certificates or anything like that ?

Posted (edited)
You need to go to https://MAILSERVER/OWA - You'll have to put a redirection on if you want users to just go to https://MAILSERVER/

 

same issue..

 

Secure Connection Failed

 

 

 

 

 

 

 

 

 

 

 

 

 

An error occurred during a connection to http://www.mydomain.com:1010.

 

SSL received a record that exceeded the maximum permissible length.

 

(Error code: ssl_error_rx_record_too_long)

 

 

 

 

 

 

 

 

*

Edited by RabbieBurns
didnt read propertly
Posted

At least you managed to launch the installation :( on my server 2008 R2 install when i launch lpsetupui.exe it just tells me there is a problem and asks me to close the program or search for an issue :( works at home!!

 

Anyone got any ideas?

 

Problem Event Name: CLR20r3

Posted

I managed to resolve my issue.. I only have one static IP, and run apache on a linux box for port 80 which NAT points to. So I was trying to change the IIS default port from 80 to something else. Exchange didnt like that at all. However, I realised that as Exchange is on https, which is port 443, and Im not using that elsewhere, I could forward 443 to the exchange box. And leave IIS on the exchange box running on 80.

 

So now http://mydomain.com goes to port 80 on the linux box, and https://mydomain.com goes to the exchange. And now OWA works.

 

So to summarize, It seems Exchange NEEDS IIS to be on port 80 for it to work.

 

Anyway, got a new problem now :p

 

#550 4.4.7 QUEUE.Expired; message expired in unreachable destination queue. Reason: A matching connector cannot be found to route the external recipient ##

 

Doesnt seem to be sending mails.

 

Also, is there a way to login to OWA without having to specify Domain\Username and just login with Username ?

Posted
I managed to resolve my issue.. I only have one static IP, and run apache on a linux box for port 80 which NAT points to. So I was trying to change the IIS default port from 80 to something else. Exchange didnt like that at all. However, I realised that as Exchange is on https, which is port 443, and Im not using that elsewhere, I could forward 443 to the exchange box. And leave IIS on the exchange box running on 80.

 

So now http://mydomain.com goes to port 80 on the linux box, and https://mydomain.com goes to the exchange. And now OWA works.

 

So to summarize, It seems Exchange NEEDS IIS to be on port 80 for it to work.

 

Anyway, got a new problem now :p

 

 

 

Doesnt seem to be sending mails.

 

Also, is there a way to login to OWA without having to specify Domain\Username and just login with Username ?

 

exchange mmc

 

Microsoft Exchange OWA 2007 | Outlook Web Access

 

How to Configure OWA for Forms-based Authentication

 

By default, forms-based authentication is enabled in Exchange 2007. This is how to check the configuration:

 

Launch the Exchange Management Console.

Open the properties of owa (Default Web Site) on the Outlook Web Access tab.

Set the type of logon prompt. The emphasis on 'Prompt', users can ignore your suggestion if they know any of the other methods. Here are the choices of prompts for forms-based authentication: FullDomain (cp\guy) , PrincipalName ([email protected]), or plain UserName (guy).

Reset IIS as recommended in the warning message.

If necessary, you can adjust the format by configuring the Active Directory directory service and Internet Information Services (IIS). If you do use Active Directory and IIS to set which user name formats users can enter, this is independent of the above OWA forms-based authentication prompt.

 

I know that is for 2007 but should give you a rough guide hopefully

  • Thanks 1

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...