+ Post New Thread
Results 1 to 9 of 9
O/S Deployment Thread, Slow GUI in Technical; Hi guys, Anyone else experiencing FOG running reeallllyyy slow on the GUI interface? Any ideas. Running 0.29. Was fine before ...
  1. #1
    ninjabeaver's Avatar
    Join Date
    Jun 2005
    Location
    Norfolk
    Posts
    1,089
    Thank Post
    182
    Thanked 100 Times in 88 Posts
    Rep Power
    46

    Slow GUI

    Hi guys,

    Anyone else experiencing FOG running reeallllyyy slow on the GUI interface? Any ideas.

    Running 0.29. Was fine before Summer and come to use it now and it's really frustrating.

    Cheers,

    Simon.

  2. #2
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    816
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    40
    If you need to go through a proxy for internet access the interface will run slowly unless you've given the proxy details on the settings page.

  3. #3

    3s-gtech's Avatar
    Join Date
    Mar 2009
    Location
    Wales
    Posts
    2,814
    Thank Post
    146
    Thanked 571 Times in 515 Posts
    Rep Power
    154
    ^^This - plus I find Firefox is really bad at completely ignoring some proxy exceptions for whatever reason. Usually quicker on LAN pages with IE8.

  4. #4
    obijon's Avatar
    Join Date
    Nov 2010
    Location
    SC
    Posts
    13
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I think it is due to the new "Host is up" red/green lights that display beside each host name. Viewing the page source shows that jquery is loaded in the HTML HEAD section. Not sure if it was being loaded with 0.28, though I don't recall any javascript being used before 0.29.

    I see the slowness in IE8, Chrome7, and Firefox3.6, especially listing hosts and editing hosts. The 0.29 web gui is much slower for me than 0.28 was. As much as I like the idea of the "Host is up" feature I'd rather have the quickness of the GUI back. I am on a gigabit LAN with ridiculously well-spec'ed server and web client, so it definitely appears to be a slowdown that was introduced into the latest web admin gui.

    I would like to see an option to disable the javascript portions, assuming that is what is taking so long to load.

  5. #5

    Join Date
    Dec 2008
    Location
    Blackpool
    Posts
    3
    Thank Post
    0
    Thanked 3 Times in 1 Post
    Rep Power
    0

    Smile

    I found the same when listing hosts on 0.29, in FOG Settings try changing FOG_HOST_LOCKUP AND USE_ANIMATION_EFFECTS to 0 and you'll find it's back to being speedy

  6. 3 Thanks to sy2k:

    Chad (9th December 2010), ninjabeaver (17th January 2011), obijon (1st December 2010)

  7. #6
    obijon's Avatar
    Join Date
    Nov 2010
    Location
    SC
    Posts
    13
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks, setting FOG_HOST_LOCKUP to 0 made all the difference!

  8. #7
    Chad's Avatar
    Join Date
    May 2007
    Location
    Elgin
    Posts
    74
    Thank Post
    5
    Thanked 20 Times in 19 Posts
    Rep Power
    18
    Quote Originally Posted by obijon View Post
    Thanks, setting FOG_HOST_LOCKUP to 0 made all the difference!
    I found that setting this breaks the host search feature - nothing happens as you type a hostname in the search box. With the setting back on the search works again.

  9. #8
    ninjabeaver's Avatar
    Join Date
    Jun 2005
    Location
    Norfolk
    Posts
    1,089
    Thank Post
    182
    Thanked 100 Times in 88 Posts
    Rep Power
    46
    Thanks Sy2K. That has worked.

    @Chad Yep, found the same here. Something we can live with for now though.

  10. #9
    Chad's Avatar
    Join Date
    May 2007
    Location
    Elgin
    Posts
    74
    Thank Post
    5
    Thanked 20 Times in 19 Posts
    Rep Power
    18
    Quote Originally Posted by ninjabeaver View Post
    Thanks Sy2K. That has worked.

    @Chad Yep, found the same here. Something we can live with for now though.
    A quick workaround if you want the search facility but don't want the host lookup is to remove the DNS server entries from your /etc/resolv.conf
    I get all hosts instantly marked as "!" now but search works fine with FOG_HOST_LOCKUP still enabled.

    I'll have a look at the code and see if I can see the issue when I get time, I've still to submit my WOL over subnets patch yet though.

SHARE:
+ Post New Thread

Similar Threads

  1. bash to GUI
    By RabbieBurns in forum *nix
    Replies: 17
    Last Post: 27th May 2010, 10:32 AM
  2. Replies: 2
    Last Post: 10th October 2009, 11:12 PM
  3. CLI & GUI
    By Edu-IT in forum General Chat
    Replies: 7
    Last Post: 7th March 2008, 05:17 PM
  4. GUI and some help needed
    By MK-2 in forum Windows
    Replies: 4
    Last Post: 1st March 2007, 05:18 PM
  5. One time runas gui
    By plexer in forum Coding
    Replies: 4
    Last Post: 29th July 2006, 10:36 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •