Jump to content
EduGeek EdSec 2026 is Go! 27th Oct in Derby! Join us for a day of EdTech security focused talks, networking, and an evening social ×

Recommended Posts

Posted
Anyone use this kind of setup? Im trying to get the apache service to start but it keeps terminating. I happens when i include the httpd-ssl.conf file and i cant see anything wrong with it. Even more annoying is that i cant get any errors from it to for me to persue, any idea?
Posted
You need to locate the apache error log file.

 

Well heres the funny thing, as far as i know the logs are in logs and the error.log either doesnt log anything or says:

 

C:/Program Files/Apache Software Foundation/Apache2.2/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?

 

Im guessing this just means it terminated before.

 

@Sysman_MK: Nope, no iis here just apache.

 

Ive run:

 

httpd -k start -n Apache2.2

 

This doesnt come up with any errors but it doesnt start either.

Posted
Ok i now know what causes the service to terminate but im not entirely sure what to do. In my httpd-ssl.conf ive turned SSLEngine on and its is this setting that crashes the service. Do i have a faulty mod? or something screwy with my selfsigned certificates?
Posted

I use apache on windows server for my intranet server, I installed XAMPP which installs apache, mySQL, PHP and filezilla (and a few other bits) all in one package, and sets it all up for you. by far the easiest way I've found of setting up an apache web server.

 

Mike.

Posted

@Geoff: running httpd from the command prompt doesnt throw up any errors but does not start the service either.

 

I would love to install another package but it was already setup when i got to it.

Posted
Woohoo... finally got it working, I needed to replace the executables in the bin folder for ones that will work.
Posted
Ok ive just noticed something when i browse to the site ive setup. In IE when you go to an ssl website you get a lock icon appear at the bottom but when i go to my site it does not show. Is this common behaviour?
Posted

Yes its actually on 443 as thats the port in the config files and the address is:

 

https://my.domain.com

 

As i havent specified the port in the address, then it should go to port 443.

 

It does ask for the certificate if i havent installed it and ive tested it in Firefox, which does show the lock icon.

Posted
Ok i think i might know what going on, it so happens that the site im testing has parts of the page coming from an external source eg banners that actually come from an external site. I think whats happening is that im getting to the site through 443 then when i get to the page, it goes of to a site that is on port 80 so IE shows no Lock Icon.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...