Jump to content
EduGeek EdSec 2026 is Go! 27th Oct in Derby! Join us for a day of EdTech security focused talks, networking, and an evening social ×

Recommended Posts

Posted

Hey Guys,

I've been allocated an install for the SENCO office. They want a Windows SBS 2003 server installed from scratch. I have no experince in this and want to find out what the best physical and logical set up would be.

 

They have a BT business hub with a Dell 2700 Switch. How would a noob go about to tackle this?

 

I've left the server on the Internet IP just for internet connectivity for the while. Once I've set it up i was going to give it a seperate IP range.

 

All comments and advise welcome.

 

Alan

Posted
I've been allocated an install for the SENCO office. They want a Windows SBS 2003 server installed from scratch.

 

Where is this office - somewhere in school, or a small, seperate location by itself someplace? Is it joined to your LAN? Windows SBS is desgined for, well, small buisniesses, and shuts itself off if it finds itself in a domain-controlled environment (i.e. it searches for other domain controllers and turns off if it finds them). You can connect five clients to the SBS machine, then you run out of CALS - CALS are all-in-one and include SQL Server, but this makes them more expensive (er, £100-ish?). You can't use an SBS server as a terminal server. This rendered our SBS server completly useless for all purposes I could think of for it in our school.

 

If SBS is appropriate for your situation then it is very easy to use - just plug the server in, switch it on and away you go.

 

--

David Hicks

  • Thanks 1
Posted

You must set it up as a new domain controller in a new forest, and it must hold the forest master roles. SBS will talk to your other domain(s), but not be a part of them, so you're committing yourself to a whole new seperate forest for the department if you use it. It can share networking with other systems though, such as internet gateway.

 

That said, it's an excellent product if it fits.

  • Thanks 2
Posted
You must set it up as a new domain controller in a new forest, and it must hold the forest master roles. SBS will talk to your other domain(s), but not be a part of them

 

Ah, that sounds a bit more accurate than my explanation - I couldn't convince our SBS server not to keep turning itself off every half hour.

 

--

David Hicks

Posted

SBS Installation is simple enough, it will run through aload of lovely wizards and ask you to pop in about 3 or 4 CD's,

 

need any help PM me.

  • Thanks 1
Posted

Dave,

The Server and network is in an office of it's own. It isn't linked to any other domains.

 

I've gone through the set up wizard and added the components all up to installing the SBS r2. This is where is throws up an error.

 

Anyone with any ideas?

 

A

Posted
The Error is 'Windows Small Business Server Files'. I am able to install the Sharepoint and Exchange but not this one.

 

I think you're going to have to be a bit more specific here - tell us what the whole actual error message is, what you'ev already done and what you're trying to do. I'm guessing that you've set up Sharepoint and Exchange and are trying to set up some file shares, but that's a guess. Maybe post a screenshot of the error message you are getting? How many client machines are you going to connect to this server?

 

--

David Hicks

Posted

When you do the core of the OS install and u get too the desktop the wizard pops up asking if you want to install Exchange\ISA (on Premium version), it should be a matter of popping the CD in...........is the CD damaged.

 

please post SS.

Posted

I don't believe the CD's are but i can always check again.

 

There will be 3 wireless laptops connecting to the server.

Screen shot of error attached.

Picture 1.gif

Posted

The error message in that log looks interesting:

 

Cannot stop SMTPSVC service on computer '.'. ---> System.ComponentModel.Win32Exception: The service has not been started

 

Like it says, it can't stop the SMTP (email sending) service as it hasn't started yet. Is it not starting correctly for a reason - did you perhaps make a typo entering information into the SMTP server setup, or maybe just typed random data intending to come back and set it up properly later?

 

I've left the server on the Internet IP just for internet connectivity for the while.[/quote

 

Does the server have a working network connection, if not would that cause an issue with the SMTP server? Is the SMTP server not starting during the install-and-setup wizard actually a problem, can you simply fix it later? Is everything else working okay and as expected (looks like it might well be, judging from that log file - looks like the wizard got to the end before it reported the error to you)?

 

--

David Hicks

Posted

Do you have one network card or two on the server, this determins how it should be setup. If there is only one it should be on the lan so all of the clients can sontact it internally and use port mapping or virtual servering on the border router to offer internet services. The wizzards are reasonably easy but SBS itself is an uweildly monster if something goes wrong because you have to fix the problem without upsetting the wizzards. Recovery and upgrade options are also terrible.

 

It is probably another bug like the old sharepoint one in SBS 2003. You should probably set up smtp manually and run windows update before the install wizard has its way with the system:

Installing and Configuring SBS 2003

Posted
Did you install any windows updates before installing the additional components? Also I'm pretty sure having IE7 installed will also cause the installation wizard to fail, have you installed this?
Posted

David:

The R2 I've resolved, it was either causedby the incomplete setting in the Internet Configuration or the McAfee firewall on the server.

 

Synack:

I have 2 cards in my server, one is configured to the BT hub and one connecting to our Switch. Yes, agreed, SBS is a bitch when you stray off the wizards.

 

Thanks guys.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...