woreilly Posted March 22, 2023 Posted March 22, 2023 Hi folks, I am having an issue with a 2012 VM whereby the Virtual Disk Service keeps stopping and failing to properly restart. It works again after a reboot but then after an indeterminate amount of time, the service stops and doesn't restart. When we launch disk management, we get the 'Unable to connect to Virtual Disk Service' message at the bottom of the window - no further pop-up dialogues to say there's a problem. When I go to Services, the Virtual Disk Service is stopped. When I start it, it shows as running. However, when I then re-launch disk management, I get the same message as above and once again, the service has stopped. I have thus far been unable to find a permanent fix to this problem. I have tried the hotfix detailed at https://support.microsoft.com/en-us/topic/virtual-disk-service-or-applications-that-use-the-virtual-disk-service-crash-or-freeze-in-windows-server-2012-53bfc3b4-011d-f64f-c927-b4222ab025a8 but this has not fixed the issue. Setting the service startup to both manual & automatic has not made any difference. Any further tips would be gratefully received.
DavonPotter Posted June 20, 2024 Posted June 20, 2024 If you haven't already, consider checking event logs for any specific error messages related to virtual disk service failures. Sometimes these logs can provide clues about what's causing the service to stop. Also, ensure that your VM environment has adequate resources allocated (CPU, memory, disk space) as resource constraints can sometimes lead to service disruptions. If you're still stuck, reaching out to microsoft support or forums dedicated to VM management might yield additional insights from others who have encountered similar issues.
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now