Jump to content
EduGeek EdSec 2026 is Go! 27th Oct in Derby! Join us for a day of EdTech security focused talks, networking, and an evening social ×

Recommended Posts

Posted (edited)

Hi,

 

I've just set up HAP+ 8.4 (with 8.4.1 My Files patch) and set up a couple of mapped drives for use, and thats worked nicely. I can do everything I want with it logged in as the admin user.

 

However when I came to test it as a student login, it logs into the home page fine, but when i click my files, it loads the page, but fails to load the shares, I just get a rotating refresh arrow next to the top level 'My Drives' item in the tree, and a couple of messages below saying "Something is wrong" and that it's been logged. I'm assuming its some permission error given it works as admin but not as a student, but I don't know where logs might tell me.

 

Apologies if this has been asked before but a quick scan of the forum didn't turn anything up.

 

Any ideas?

 

David

 

Edit: I should probably mention its IIS6 on an old 2003R2 server we have.

 

Edit 2: Did a bit of api peeking, on the admin login I get (from /api/MyFiles/Drives):

-

-

Change

../images/icons/netdrive.png

Documents

N\

79.79

 

But logged in as a student I get back JSON (also from /api/MyFiles/Drives):

XML Parsing Error: not well-formed

Location: https://hap.local/api/MyFiles/Drives

Line Number 1, Column 1:{"Message":"Something is wrong","Detail":null,"FaultType":"Exception"}

^

 

hap error.png

Edited by deebee
Additional Info
Posted
anyway round local logon rights dont really want to give kids/staff local logon to a dc esp as its in the suite rather than a server room
Posted

None unfortunately, it's how HAP+ ensures security on your network.

 

It's best to use a member server, usually it's a Terminal/Remote Desktop Server

Posted
None unfortunately, it's how HAP+ ensures security on your network.

 

It's best to use a member server, usually it's a Terminal/Remote Desktop Server

 

ideally yes but the only servers i have are in semi public locations and 2 of 3 are dcs the other has sims on it so there is 0 way im using that one lol

 

hmm might have to look into a vm

Posted
A VM would work. If your servers are 2012 I think you can install Hyper-V

 

ones 2003 and sick lame dying 2 are 2008r2 and have various test vms on them already

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...