Jump to content

Recommended Posts

Posted

Hi all

 

Have googled around but couldnt find anything to fix our issue.

 

Have 3 DCs all running Windows 2008 R2 Server, 2 of the DCs including the Master are working fine but number 3 being our exchange server is failing. Any chances to the Sysvol folders on the 2 working DCs are not replicating over. This issue DC has got exchange 2010 (been installed for a year now) issues must of occurred in the last 6 months which must have something do to with our server upgrades?

 

Have tried the following:

Reboots

Manual replication

Folder Permissions all match

Servers can access each other name/ip no problem

DCDiag looks fine minus an alert 20 (event log is Schannel alert 20 and 10 - quite a few of them).

IP Config /all looks all right

Repl all looks as well - all succeeded

 

I have manually gone in and change the GPO settings on this DC temporarily which has resolved our basic issues.

 

Looking at DNS I can't see no obvious issues, I have noticed that email is appearing in OurDomain-DomainDNSZones/TCP (and Sites TCP) and ForestDNSZOnes TCP (and Sites TCP) even though its not a DNS?

 

Also: An old server which was demoted and now only a member server (till we can transfer the public drive data then its out) is appearing in the msdcs.OurDomain - Domains/TCP and DC/TCP folders. Even though its not a DC just a member server (this is windows 2003 server box which will be scrapped).

 

Not sure what else to add but as you can guess I have tried a few bits and bobs. Any help will be great thank you.

Posted

1. First of all, check the even logs for any errors or warning.

2. Use repadmin /showreps to see what replication issues it's reporting, chances are it will find something.

3. I assume Exch is working as it should?

Posted

repadmin /showreps

 

Showing all successful

 

Only errors Occuring are to do with our Certificate because our external domain has one but internally we dont so it asks users to click continue when the first load outlook. Also the alert 20/10 which I think has to do with the certificate.

 

Other then that nope no other issues, Active Directory/Exchange are working perfectly fine. It really does seem to be just the Sysvol folder and all its contents not syncronizing - can be accessed from each other though using start-run.

 

Cheers

Posted

Step 1 - Stop using your Exchange server as a DC... this is bad!

Step 2 - Check that the previously mentioned server is no longer referenced anywhere as a DC.

Step 3 - Hope that manually changing Sysvol stuff on that server hasn't further screwed replication... this is also bad!

 

BTW - If you have schannel errors, you will almost certainly need to do an schannel reset on that server (from a DC run netdom reset screwedservername) and then reboot the screwed server.

  • Thanks 1
Posted
Step 1 - Stop using your Exchange server as a DC... this is bad!

 

Catch 22: Microsoft do not support changing that Exchange box from a DC to a member server. I don't know if that's because Bad Stuff[tm] will happen or not, but superficially at least "not recommended" seems like a better place to be than "not supported".

  • Thanks 1
Posted

Thanks for taking time to respond guys :)

 

The DC on exchange was something it did and told me to do. I did read about the GC shouldnt really be on exchange though so dont know if your mixing them up?

 

2nd: The replication issue is now fixed and this has solved two of our issues so great thank you on that. Profiles seem to be logging on MUCH better and faster. We have a 3rd issue which fingers crossed will resolve this but only time will tell.

 

As for the Schannel errors thats not going to cause any other problems is it? the reset?

 

I just did a bit of googling on the netdom reset and this does have something to do with the replication between DCs so perhaps the error will go away. I will give the servers a reboot and see how things go. I will drop back if the errors are still occurring if the netdom reset solves the issue or not.

 

Will return, few days! thanks again.

Posted (edited)

Read this sometime: How We Solved Problems With Exchange Running on a Domain Controller in EBS. Bear in mind that's three years ago talking about Exchange 2007 and some aspects might have changed. The DR point snagged my attention in an "oh.. ughh" way, but I don't know whether that's still the case with E2K10 and likewise for them saying that if it is a DC it will benefit from being a GC.

 

Update - MS Quote (from a context that does encompass E2K10): If Exchange Server is running on a domain controller, you must also make that domain controller a global catalog server.

Edited by PiqueABoo
Posted

Typical microsoft that is, one page says one thing and another page says another.

 

Anyway: the replication problem is 100% fixed and still no issues on that front. The Schannel error is still appearing though, I know we have an internal certificate issue (because it has the external link in its list and not internal). I will try and get that resolved but I dont think this will give the Schannel issue.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...