SYNACK Posted April 12, 2011 Posted April 12, 2011 Skipping to the point, Office 2010 is not rearmed for activation when running a sysprep and so if you just image your stations and Office has been run on the image before it keeps the same ID. As KMS activation requests are requested and counted by the IDs it means that your KMS server will never hit the 5 limit to allow activation. There is a nice easy fix which I grabbed from here that you can run as a startup script which will rearm the installs on your stations to get KMS going right. 0xC004F038 The software Licensing Service reported that the computer could not be activated. The count reported by your Key Management Service (KMS) is insufficient. Please contact your system administrator. - Office Deployment Support Team Blog - Si Office2010Rearm.bat @echo off :OSPP reg query HKLM\Software\Microsoft\Office\14.0\Common\OSPPREARM if %errorlevel%==1 (goto RUN) else (goto END) :RUN set ProgramFilesPath=%ProgramFiles% "%ProgramFilesPath%\Common Files\microsoft shared\OfficeSoftwareProtectionPlatform\OSPPREARM.EXE" C:\Windows\system32\cscript.exe "%ProgramFilesPath%\Microsoft Office\Office14\ospp.vbs" /act set ProgramFilesPath=%ProgramFiles(x86)% "%ProgramFilesPath%\Common Files\microsoft shared\OfficeSoftwareProtectionPlatform\OSPPREARM.EXE" C:\Windows\system32\cscript.exe "%ProgramFilesPath%\Microsoft Office\Office14\ospp.vbs" /act REG ADD "HKLM\Software\Microsoft\Office\14.0\Common\OSPPREARM" :END Exit This caught me by suprise and was getting quite irritating to track as I could not remember the activation threashold. Office 2010 is also nice and quiet about its need to activate till the 25 day timer runs out and it gets angry prompting the user to activate and giving the titlebar of any Office app a nice angry red background colour. Volume Activation Tips and Tricks - Microsoft Office 2010 Engineering - Site Home - TechNet Blogs The uncopyable error (come on MS, its a undecypherable error code, of course it needs to be copied and searched for) at the bottom of the activate now window gives the 0xC004F038 error which translates to the server says no as you don't have enough. To figure out how many different activation requests you actually have you can run this on your KMS server with an admin elevated prompt: [b]cscript slmgr.vbs /dlv bfe7a195-4f8f-4f0b-a622-cf13c7d16864[/b] You can also look at the KMS event logs on the server just to see if there are multiple stations requesting activation with the same ID. At any rate this whole thing made me feel a tad silly for missing it especially as I had read about it before here http://www.edugeek.net/forums/windows-server-2008-r2/67364-kms-activation-problems.html#post601899 but I was a tad distracted trying to string together a network infrastructure possibly older than I am into something a little more reliable. Hope that this can help someone even if only to just remind everyone again so that it does not catch anyone else out. 1
FN-GM Posted August 4, 2011 Posted August 4, 2011 Thanks thats just sorted that issue out for us. Would you say its ok to set this a startup script please?
SYNACK Posted August 4, 2011 Author Posted August 4, 2011 Been running here at one site since I posted this with no issues so I'd say go for it. The script only runs if it does not detect the reg key so its nice and quick. 1
gshaw Posted August 4, 2011 Posted August 4, 2011 Yup works fine as a startup script, for some reason the client ID didn't reset even though we ran the rearm process but all activating OK now
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now