Gatt Posted November 26, 2010 Posted November 26, 2010 Running into an odd problem with getting RemoteApps working externally.. I have an external SSL from GoDaddy which is working fine, and the RDS server also has an internal SSL created via AD's CA I have successfully published RDWeb via TMG2010 with SSL (GoDaddy) and can login and see all the published RemoteApps, but when I click on an app and enter my login details, it says that the certificate is from an uncertified source. The SSL in question is from the TMG Server which is not assigned to anything! If I continue the app throws an error sayings its not in the list of authorised programs Internally, everything works fine.. I have no idea why it is using this TMG SSl and not the External or RDS SSL...
EduTech Posted November 26, 2010 Posted November 26, 2010 Running into an odd problem with getting RemoteApps working externally.. I have an external SSL from GoDaddy which is working fine, and the RDS server also has an internal SSL created via AD's CA I have successfully published RDWeb via TMG2010 with SSL (GoDaddy) and can login and see all the published RemoteApps, but when I click on an app and enter my login details, it says that the certificate is from an uncertified source. The SSL in question is from the TMG Server which is not assigned to anything! If I continue the app throws an error sayings its not in the list of authorised programs Internally, everything works fine.. I have no idea why it is using this TMG SSl and not the External or RDS SSL... Ok, When you create the secure published rule in TMG you have to provide an SSL Certificate don't you? Is that the one it is bringing forward when you try it externally? If so is this one different to the one you have got for the RDS Server? James.
strawberry Posted November 26, 2010 Posted November 26, 2010 are you using w7?. rd web has issues with external certs in w7 without service pack. xp and w7sp1 will both be fine. ironically a selfsigned cert would be fine.
EduTech Posted November 26, 2010 Posted November 26, 2010 are you using w7?. rd web has issues with external certs in w7 without service pack. xp and w7sp1 will both be fine. ironically a selfsigned cert would be fine. Weird, I have many people running Windows 7 without the Service Pack and have not had any issues being brought up. What kind of problems you expirienced? My machine at home don't have SP1 as well just aint got round to do it, and i connect to about 5 different RDS Configurations. (it shouldn't really give you a problem, aslong as the RD Client is to the latest version or/ you have enabled your RDS Server to accept connections from the older RD Client). J
Gatt Posted November 26, 2010 Author Posted November 26, 2010 Think I've narrowed it down Its something to do with the RDS services on the TMG server.. Or a lack of them.. Waiting on it rebooting SSL Sorted now but keep getting the following error "Windows cannot start the RemoteApp program. The following RemoteApp program is not in the list of authorized programs: Calc For assistance, contact your system administrator"
strawberry Posted November 26, 2010 Posted November 26, 2010 My machine at home don't have SP1 as well just aint got round to do it, and i connect to about 5 different RDS Configurations. (it shouldn't really give you a problem, aslong as the RD Client is to the latest version or/ you have enabled your RDS Server to accept connections from the older RD Client). J Stuff about the online check failing , its documented here, not sure what the differencing factor is, suspect its my cheapo cert but it works fine in xp and 7 with sp1. Certificate revocation check from external network.
EduTech Posted November 26, 2010 Posted November 26, 2010 Stuff about the online check failing , its documented here, not sure what the differencing factor is, suspect its my cheapo cert but it works fine in xp and 7 with sp1. Certificate revocation check from external network. Oh right, could possibly be i guess as the certs i use are all from RapidSSL. @ GATT This error may be caused by missing Host Records of the TS servers on the local DNS, To fix this issue, please add the Host Records of the Terminal Servers into the local DNS and test it again.
Gatt Posted November 26, 2010 Author Posted November 26, 2010 yeah came across that, its already in it.. will double check tho...
EduTech Posted November 26, 2010 Posted November 26, 2010 (edited) yeah came across that, its already in it.. will double check tho... Yeah I have had it happen before for someone, and looking on the web it appears to have cropped up a few times. I am just logging into one of my RDS Servers see if i can grab some settings for you to look at see if they match up. RDS either goes through swimmingly! or a problem crops up and it does your head in! lmao Have you Digitally Signed the .rdp Files? Edited November 26, 2010 by EduTech
Gatt Posted November 29, 2010 Author Posted November 29, 2010 Ok I'm getting a little confused as to what to put where: The TMG rule appears sound. DO I ned to configure RDS, etc on the TMG server - if so what with? What do I configure on the RDS Server that will be hosting the apps? User > Web > TMG -> RDS should be the path Internally its all fine Externally the SSLs are now sorted and working What do I configure for the RD Session Host, the RD Gateway on both the TMG and the RDS servers?
Gatt Posted November 29, 2010 Author Posted November 29, 2010 Ok finally got it working... removed almost everything from TMG and put the external IP address in and its working - thought not internally Not too bothered as its really gonna be used externally....
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now