Jump to content

Recommended Posts

Posted

I have been troubleshooting what now appears to have been a corrupted backup job on our BackupExec server, and after having re-built it from scratch, I am now getting the following error on running:

 

Backup- \\app1.sch4290.somerset.gov.uk\E: NAS2

V-79-57344-34110 - AOFO: Initialization failure on: "\\app1.sch4290.somerset.gov.uk\System?State". Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS).

Snapshot provider error (0xE000FED1): A failure occurred querying the Writer status.

Check the Windows Event Viewer for details.

Writer Name: Registry, Writer ID: {AFBAB4A2-367D-4D15-A586-71DBB18F8485}, Last error: The VSS Writer failed. The operation cannot be retried (0x800423f4), State: Failed during prepare snapshot operation (8).

 

The job is very simple, it backs up a bunch of directories, and the 'System State' object. I am not using AOFO.

 

Any ideas as to why this error is occurring?

  • 2 months later...
Posted

I've had this error before, usually solved by re-booting whatever server is reporting the fault. Never worked out what causes it. Only happened twice to me, so it doesn't really worry me enough to spend hours looking for a solution to it.

 

Mike.

Posted

I had to do the following:

 

1. Remove the client from the server completely.

2. Delete the job on the server

3. Reinstall the client

4. Recreate the job from scratch

 

Since doing that, I've not had any issues.

Posted
I had to do the following:

 

1. Remove the client from the server completely.

2. Delete the job on the server

3. Reinstall the client

4. Recreate the job from scratch

 

Since doing that, I've not had any issues.

Okay, so would this be the remote agent on the Exchange or BackupExec in general?

 

Do you think a 'repair' would do it?

Posted
Okay, so would this be the remote agent on the Exchange or BackupExec in general?

 

Do you think a 'repair' would do it?

 

That'd be the agent. And I found that a repair didn't do anything.

 

I suspect this is the cause?

 

That may well be... It doesn't look good anyway!

Posted

Indeed. So this would suggest that BackupExec is working, but it's something else.

 

AOFO: Initialization failure on: "\\SR-003\Microsoft Information Store\Public Folders Storage Group". Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS).

Snapshot provider error (0xE000FED1): A failure occurred querying the Writer status.

Check the Windows Event Viewer for details.

Writer Name: Exchange Server, Writer ID: {76FE1AC4-15F7-4BCD-987E-8E1ACB462FB7}, Last error: The VSS Writer failed, but the operation can be retried (0x800423f3), State: Failed during freeze operation (9).

Posted

I've run into this error, it normally follows a recent windows update when it breaks the VSS service. You'll need to re-register all the VSS .dll files and reboot on the server/s your backing up from.

 

Win+R

 

CMD

 

Net stop vss

Net stop swprv

regsvr32 ole32.dll

regsvr32 vss_ps.dll

Vssvc /Register

regsvr32 /i swprv.dll

regsvr32 /i eventcls.dll

regsvr32 es.dll

regsvr32 stdprov.dll

regsvr32 vssui.dll

regsvr32 msxml.dll

regsvr32 msxml3.dll

regsvr32 msxml4.dll

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...