I just remembered the last time I tried this the documentation hadn't been updated to match the syslinux downloaded files. If you go through the notes there you will probably find the PXE client fails to boot and will say "could not find file abc.xyz" (a bunch of C32 something something files if I recall correctly), and possibly a path too.
Unzip the download, search for the file that the client says is missing and copy the version of the file for the correct architecture for your PXE boot, and to the equivalent path. For example:
32bit PXE client wants "abc.xyz", copy syslinux\....\x86\....\abc.xyz to ....\Boot\x86\ on your WDS server.
64bit PXE client wants "123\abc.xyz", copy syslinux\...\x64\...\abc.xyz to ....\Boot\x64\123\ on your WDS server.
Repeat as necessary, I think I needed 3 reboots to find the paths and names of the files that were missing.