Jump to content

Recommended Posts

Posted

I am trying to install WSUS on Windows Server 2003 R2, however when I try and intall from the add roles menu, Application Server (IIS) which WSUS needs to work it says that it cannot comple install and fails its doing me head in as I have got IIS 6 installed and it works however if I uninstall it the add role will still not work and does not install it and I took me a whole day to recove IIS last time. Any ideas.

 

Thanks

Posted

From an elevated PowerShell prompt, could you try the following commands...

 

Import-Module ServerManager
Get-WindowsFeature OOB-WSUS | Select -exp DependsOn | Add-WindowsFeature

Posted

When WSUS fails to install, they'll be a link to a log. If you post it, we should be able to see what the issue is.

 

I've had one 2008 R2 server do something similar and I ended up re-installing it due to WID (Windows Internal Database) being at fault.

Posted

The Server Configuration Report shows this error;

 

(7/3/2012 9:06:41 AM)

Configurations for an Application Server

IIS could not be installed on this server.

To install IIS, try running the Configure Your Server Wizard again, or use Add or Remove Programs.

 

There is this error 4 times everytime I run the installer ;

 

Event provider attempted to register query "select * from SnmpNotification" whose target class "SnmpNotification" does not exist. The query will be ignored.

 

For more information, see Help and Support Center at Events and Errors Message Center: Basic Search.

 

Any sorry about the spelling when I set the post up orginally I had been working on this for 14 hours straight!

Posted
Are you running a 2003 x64 edition? A Microsoft KB link here says the error can be ignored. If that's the case you'll need the x64 version of WSUS 3.0 SP2 (recommended).
Posted
That's only available with Windows Server 2012 Bacon Edition

 

lol or Windows Server 2012 BBQ edition.

 

Optional rolls, sausages, bacon, burgers. Leave the salad roll switched off :D

Posted
I have got Powershell 1.0 installed on the server as its 2003 R2

Ignore the PowerShell post above. I mistakenly thought this was the 2008 R2 forum. :o :o

Posted

Any sugesstions then? It seems really strange that I have managed to get IIS installed but when I run the add server role which only needs to install IIS and then enable COM+ it failes everytime.

 

Anyone got any suggestions how to resolve this, it is a DC for hald of our networked PC's so I cant afford to rebuild it or take it down for a long time however I really need to make WSUS work so all the PC's can be updated.

 

Thank you

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...