Jump to content

Recommended Posts

Posted

Only my second week and already a huge problem :|

 

There are four DCs here, two on each campus. The replication of the SYSVOL and NETLOGON shares works across three of them but not on the fourth. This of course means that new login scripts and group policy objects do not appear on the fourth server if they are created on one of the other three and visa versa.

 

The server which isn't replicating holds all of the FSMO roles apart from the schema master role. The server is generating an error in its event log, pasted below:

 

The File Replication Service has detected that the replica set "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR. 

Replica set name is    : "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" 
Replica root path is   : "c:\windows\sysvol\domain" 
Replica root volume is : "\\.\C:" 
A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to read from the NTFS USN journal is not found.  This can occur because of one of the following reasons. 

[1] Volume "\\.\C:" has been formatted. 
[2] The NTFS USN journal on volume "\\.\C:" has been deleted. 
[3] The NTFS USN journal on volume "\\.\C:" has been truncated. Chkdsk can truncate the journal if it finds corrupt entries at the end of the journal. 
[4] File Replication Service was not running on this computer for a long time. 
[5] File Replication Service could not keep up with the rate of Disk IO activity on "\\.\C:". 
Setting the "Enable Journal Wrap Automatic Restore" registry parameter to 1 will cause the following recovery steps to be taken to automatically recover from this error state. 
[1] At the first poll, which will occur in 5 minutes, this computer will be deleted from the replica set. If you do not want to wait 5 minutes, then run "net stop ntfrs" followed by "net start ntfrs" to restart the File Replication Service. 
[2] At the poll following the deletion this computer will be re-added to the replica set. The re-addition will trigger a full tree sync for the replica set. 

WARNING: During the recovery process data in the replica tree may be unavailable. You should reset the registry parameter described above to 0 to prevent automatic recovery from making the data unexpectedly unavailable if this error condition occurs again. 

To change this registry parameter, run regedit. 

Click on Start, Run and type regedit. 

Expand HKEY_LOCAL_MACHINE. 
Click down the key path: 
  "System\CurrentControlSet\Services\NtFrs\Parameters" 
Double click on the value name 
  "Enable Journal Wrap Automatic Restore" 
and update the value. 

If the value name is not present you may add it with the New->DWORD Value function under the Edit Menu item. Type the value name exactly as shown above.

 

I've read on MS's website here that enabling journal wrap automatic restore on versions of Windows above 2000 SP3 is not recommended so I'd rather not do that if necessary.

 

I've checked repmon, the servers seem to be replicating all of their AD objects properly. I've checked everything suggested http://support.microsoft.com/kb/257338]here, everything seems to check out. DNS works, DCDIAG reports that replication is working on directory objects. I'm out of ideas. Any suggestions?

 

Cheers,

 

Norphy

Posted

The easiest thing to do is probably to DCPROMO the faulty machine down and up again. This is essentially non-destructive and shouldn't take more than about 30 minutes. If you need to make sure users can keep working while you do this than transfer any FSMO roles off the machine with a problem.

 

When you bring the machine back up, make sure you make it a global catalog server otherwise it won't process logons.

Posted

You not the only one with this issue.

I have this as well on my server 2003 machine.

 

I only have one server on the network. It does everythink.

DHCP,DNS, FSMO ROLES etc

 

Why would i get this error if my server doesn't have anythink to replicate with?

 

Is there a way to turn off FRS, would that fix the issue.

 

If any ones got a solution for a one server setup please post here.

Posted

Yes, but:

 

They shouldn't happen - as goodhead says, why would you get replication errors when there's only 1 server?

 

You really don't want to have only 1 server - if it ever fails you've got a big job to repair things. Put a second server in as a DC; that way you've got some redundancy and have to worry less if things ever go wrong!

Posted
Any suggestions?

 

You could read KB290762 and everything else you can find on "burflags".

 

Doesn't sound entirely the same problem, but I successfully used that on a W2K SP4 forest root (all FSMOs) a little while ago that had some event log entry saying it wouldn't act as a DC because of journal wrap. Only took 5 minutes once I'd finally convinced myself I understood what I was doing (sorry don't have value I used to hand).

Posted
Yes, but:

 

They shouldn't happen - as goodhead says, why would you get replication errors when there's only 1 server?

 

You really don't want to have only 1 server - if it ever fails you've got a big job to repair things. Put a second server in as a DC; that way you've got some redundancy and have to worry less if things ever go wrong!

 

the server i'm talking about is my home dc. we have 3 dcs at the school :)

Posted
You can safely ignore these errors in a single server enviroment.

Geoff, thats great to know i can ignore them. How ever i hate having errors in the event logs. Even if i pretend they not there, at the back of my mind they are still there. I want get rid.

 

There must be a way to tell the server not to replicate with any think.

Posted

EDIT: I reread your original post as see you have multiple DCs, I'm really not sure what I would do there as things can get unplesant,

 

For future referance for people with one DC:

 

I saw this problem today on a single DC domain. I tried this http://www.jigsawboys.com/category/windows-2k3-server

 

Now I'm not saying you should do this, but the service started again sucessfully after I did it. As always its a question of risk etc.

 

Edit the Edit

 

http://support.microsoft.com/kb/315457 has some info

Posted
EDIT: I reread your original post as see you have multiple DCs, I'm really not sure what I would do there as things can get unplesant,

 

For future referance for people with one DC:

 

I saw this problem today on a single DC domain. I tried this http://www.jigsawboys.com/category/windows-2k3-server

 

Now I'm not saying you should do this, but the service started again sucessfully after I did it. As always its a question of risk etc.

 

Edit the Edit

 

http://support.microsoft.com/kb/315457 has some info

 

thanks, i'll have a go with the jigsawboys site tonight.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...