Jump to content
EduGeek EdSec 2026 is Go! 27th Oct in Derby! Join us for a day of EdTech security focused talks, networking, and an evening social ×

Recommended Posts

Posted

I'm scratching my head over this one

 

Users have roaming user profiles, located in \\fps1\staff_profiles$\username

 

They also have a home area, \\fps1\staff$\username

 

On random machines and at random points a user will attempt to log on and receive a blank desktop with an error message:

 

7error.JPG

 

Their Desktop folder is redirected to a Desktop folder in their home area.

 

The bizarre thing is, they also seem to then have no access to their H:\ drive which is specified in the login script to map to their home area directory, however they can access G:\ and I:\ drives which are shared directorys on the same fps1 server?!

 

As soon as they log out and log back in to the same machine things seem back to normal.

 

Like I mentioned, totally random!

 

Any ideas?

Posted
Sounds daft but are the machines they go to randomly dropping the network connection ? if they log off and back on again do they get the correct settings ? All I'm thinking is maybe the switch has STP or there is some kind of timeout on the NIC, which means if you login you may not pull down profiles correctly. The new HP machines we have have got whats called Green Ethernet and it means when the computer goes to sleep once you wake it back up it takes A minute or so for the power to the NIC to be resumed which also explained why our wake-on-lan didn't work.
Posted
Spanning Tree Protocol...We do have that turned on and have noticed it is being funny with the DHCP but didn't know if we could turn it off without buggering anything else up?!
Posted
If Spanning Tree isn't setup properly, you will get loopbacks and this is why you would in theory have problems with DHCP. As a result, this would appear why you're losing connectivity with your server(s).
Posted

Hi

 

Can I ask some questions?

 

This message to me means the computer cannot contact the server now this can happen for many reasons like the machine has not received a dhcp address so cannot find the network, the dns is not working correctly so cannot find the server.

 

Are your ip addresses set by dhcp?

If they are does this only happen when a machine is newly turned on? Sometimes a computer can start too fast for the network and people can log on before the ip address is received so people can log on and do not receive a profile as the computer cannot contact the network. This can be helped by changing a group policy to wait for network and a registry setting to wait for wait time while policy settings are received. I am sorry I cannot remember this setting off the top of my head as I am not at work. A lot of the time this can happen if a lot of network traffic is on the network. Use a traffic sniffer to capture some traffic on the server and analyis it to see if you have corrupt packets or a broken nic or lots of 2012 errors on windows 2008 and windows 2007 r2 servers. Have a look for a lot of arp requests for machines that do not respond like gpos that have old paths that do not exist.

 

Does this happen if a machine has been on for a while and not been used? We had a problem where eco settings on the nic cards turned them off under powersavings. We also had this problem is say a 1 gig network card in a client was plugged into a 10/100 switch and the nic had problems negotiating a connection speed.

 

Have you turned tree spanning on you switches this can stop loops which can cause a lot of traffic and arp requests.

 

Have a see if all the computers connect to the same switch and see if they have the same problem if you move them to another area of the school to see if you have a bottle neck on the network. We had to upgrade a main feed to a switch cabinet to fibre when we updated machines as they needed traffic quicker then the network could supply.

 

These are only ideas.

 

Richard

Posted
Not related to your error, but its always a bad idea to map drives to a $ share as they are ment for admin use only. This could have an issues on the error your getting.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...