sarchs Posted September 22, 2010 Posted September 22, 2010 Hi Just having a problem setting up Joomla on the lancsngfl servers. I have transfered all the joomla files to the server and the webmaster has setup Mysql for me and i have access to the database. When using the joomla web installer i get to step 4 and cannot proceed without the error "Unable to connect to the database:Could not connect to MySQL" Any suggestions or help from people who have setup joomla hosted by lancs would be greatly appreciated
rush_tech Posted September 22, 2010 Posted September 22, 2010 Sounds to me as if the database username and password are wrong
sarchs Posted September 22, 2010 Author Posted September 22, 2010 The username and password are correct as i can log into mysql with the same username and password
Devontechie Posted September 22, 2010 Posted September 22, 2010 "Unable to connect to the database:Could not connect to MySQL" Have you got the right MySQL name?
sarchs Posted September 22, 2010 Author Posted September 22, 2010 Under hostname i have put 'localhost' under username i have put 'mysqlusername' under password i have put 'mysqlpassword' under databasename i have put 'mysqldatabasename' Do these seem correct?
Devontechie Posted September 22, 2010 Posted September 22, 2010 Under hostname i have put 'localhost' under username i have put 'mysqlusername' under password i have put 'mysqlpassword' under databasename i have put 'mysqldatabasename' Do these seem correct? I don't know anything about the lancsngfl webserver but you might want to check that the hostname is localhost. I know with my hosting the hostname isn't localhost.
krisd32 Posted September 22, 2010 Posted September 22, 2010 on my install its down 127.0.0.1 (which i know is local host) but you could try inputting the ip instead of localhost. worth a try. 1
sarchs Posted September 22, 2010 Author Posted September 22, 2010 I have tried lots of different hostnames and checked with the webmaster.
SimpleSi Posted September 23, 2010 Posted September 23, 2010 Sorry - just found this Hostname needs to be 127.0.0.1 not localhost regards Simon 1
SimpleSi Posted September 23, 2010 Posted September 23, 2010 What version of Joomla are you trying to install and I'll do one of the same just to make sure intalls have not been borked by recent webserver changes (I;m still getting occasional errors with mine so things are still not right somewhere ) regards Simon
sarchs Posted September 23, 2010 Author Posted September 23, 2010 Thanks for that Kris and Simon. It worked as soon as i put in the loopback address.
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now