mb2k01 Posted November 4, 2009 Posted November 4, 2009 Hi All, I found a couple of similar posts on here but none that helped. Hopefully someone can give my tired brain a hand! Summary: Exchange 2003 server. Previously working until issues which occured yesterday (with no apparent cause... no one using the server, no patches / updates applied, event log clear etc). Exchange was set with an SMTP Virtual Server and an SMTP Connector pointing to the schools external SMTP feed (Smart Host SMTP with RM/SWGfL). No major configuration changes for x-amount of months, worked perfectly! Issue: SMTP became corrupt. Worked through MS KB Article 938673 which looked like a perfect fit. The hotfix cured the event log errors but eventually led to me having to uninstall SMTP via control panel and re-install, which in turn eventuall led me to having to reinstall exchange and service packs (as in disk in and reinstall over the top to fix errors etc). Current state of play is that I can't send or receive email at all. I'm getting MTA and x.400 event log errors (9318 and 290) cycling through the event log, yet I can't find anything obvious wrong with the installation. 290: A non-delivery report (reason code unable-to-transfer and diagnostic code unrecognised-OR-name) is being generated for message C=us;A= ;P=My School;L=MSEX010911041721140715. It was originally destined for C=us;A= ;P=MySchool;O=Exchange;DDA:SMTP=me(a)myschool.la.sch.uk; (recipient number 1), and was to be redirected to . [MTA DISP:RESULT 16 136] (12) 9318: An RPC communications error occurred. Unable to bind over RPC. Locality Table (LTAB) index: 6, Windows 2000/MTA error code: 1722. Comms error 1722, Bind error 0, Remote Server Name MS2K04 [MAIN BASE 1 500 %10] (14) I've tried creating new SMTP Virtual Server and Connectors with no joy. The Exchange BA and Troobleshooter don't kick up anything that looks immediately related. There are decent backups available to start a proper disaster recovery / full server reinstall, but it's frustrating - I don't want to reinstall a whole server just for what looks like a transport issue? Does anyone have any ideas?
mb2k01 Posted November 4, 2009 Author Posted November 4, 2009 Oddly event id 9318 and 290 both seem to have lots of references to enviroments who have moved from Exchange 5.5 - that doesn't apply here. The first ever Exchange server was 2000 but Exchange 2003 has been run happily for at least 3 or 4 years.
DrPerceptron Posted November 4, 2009 Posted November 4, 2009 Have you enabled message tracking logs and checked through those (they're not pretty I don't think) to see if anything else jumps out at you? What about Anti-Virus and other bits of software that aren't really important, can they be turned off to see if you still have the problem?
mb2k01 Posted November 4, 2009 Author Posted November 4, 2009 I've never been a fan of the tracking but yeah, turned it back on half way through the day to see if I could find anything. Well, it took me until about 10pm (at work!) but I think I managed to sort it. It was a combination of a lot of suggestions posted on the Internet and in MS KB's - one of which shouldn't even apply to us but I took an educated guess! I won't tempt fate too much by saying it's fixed and detailing it here now, but if it's still up and working in the morning I'll post back so future Googlers can see what I did!
m25man Posted November 4, 2009 Posted November 4, 2009 Have you tried deleting the connector? Unless you specifically need an Exchange connector you should be able to manage well enough with just the smtp virtual server. Corrupted connectors can cause the problems you have described.
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now