PaulFuller Posted July 11, 2013 Posted July 11, 2013 Dear All, I'm trying out Fog for the first time and have run into problems. The PC I am trying to take an image of doesn't start up when I start the upload task from the Fog Management screen. If I boot it into XP, then run the task, the PC shuts down after a long delay (which might be expected as I have set it to do so on task completetion). However, nothing else seems to happen. A placeholder for the image has been prepared, the PC has been registered and associated with the image. I can make the PC start if I have Fog send a wake up message to it, so wake up on LAN is set correctly but it doesn't wake up when the upload task is started. I've also tried "forcing" the task to run. If I start the upload task and then switch on the PC, the PC appears to start the upload. However, the task then fails and displays the following information on the PC's screen: Mounting File System... Done Checking mounted file system... An error has been detected! Fatal Error: Failed to mount NFS volume Computer will reboot in 1 minute Additional information is that from the start I set Fog up to use a second internal hard drive for image storage (using the instructions from Fog Project's site). If I type "mount" into a terminal session, amongst other things I now get: /dev/sdb1 on /images type ext3 (rw) I gather Fog uses /images for storage and as Fog management shows the right amount of free space it does appear to be using sdb1 which is what I want. I reset permissions so that the fog user could read and write etc. then tried allowing all users the same access rights. None of this has changed things it seems. The server is Fog version 0.32 on Ubuntu 12.04 LTS desktop. The PC I'm trying to image is Windows XP Pro. Any help/checks etc. would be gratefully received. Many thanks, Paul.
cscc Posted July 12, 2013 Posted July 12, 2013 (edited) I had real problems with FOG running on 12.04 LTS – reverted back to 10.04.4 LTS and all my problems went away! Not a great solution but I had similar problems to you. Edit: Before doing that you could try a different kernel, in the main menu go to "Other Information", "Kernel Updates" and select one that has KS in the name. This may be of some use: http://fogproject.org/wiki/index.php?title=Image_Upload:_Error_Checking_Mount Edited July 12, 2013 by cscc
PaulFuller Posted July 12, 2013 Author Posted July 12, 2013 Great stuff. Sure enough the /images/dev folder didn't have the .mntcheck file. Once created everything worked. I've taken two large images and they completed faster than I'm used to. Thanks, Paul.
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now