+ Post New Thread
Results 1 to 8 of 8
Windows 7 Thread, C:\Users\username\Application Data on Windows 7 and Vista got access denied in Technical; Hi All, how can I access the following folder in WIndows 7 and Vista: C:\Users\username\Application Data i got access denied ...
  1. #1

    Join Date
    May 2009
    Location
    Sydney
    Posts
    282
    Thank Post
    322
    Thanked 3 Times in 3 Posts
    Rep Power
    12

    Question C:\Users\username\Application Data on Windows 7 and Vista got access denied

    Hi All,

    how can I access the following folder in WIndows 7 and Vista:

    C:\Users\username\Application Data


    i got access denied when I'm an administrator ?
    Edit/Delete Message

  2. #2

    Join Date
    May 2009
    Location
    Sydney
    Posts
    282
    Thank Post
    322
    Thanked 3 Times in 3 Posts
    Rep Power
    12

    Thumbs up

    ok got it

    I've tried this as the solution:
    1. Right click on the Sallie folder located in C:/Users/username then go to properties
    2. Click the security tab
    3. Click advanced
    4. Click the owner tab
    5. Click edit
    6. Highlight your user name and check the replace owner on subcontainers and objects checkbox, click apply then ok. Then press ok on all of the other windows to exit out of them.
    Last edited by albertwt; 18th March 2010 at 01:12 AM.

  3. #3

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,271
    Thank Post
    884
    Thanked 2,749 Times in 2,322 Posts
    Blog Entries
    11
    Rep Power
    785
    It is like this by default, all user personal documents only have NTFS permissions for themselves and the system.

    If you try to open the \users\username folder it should prompt you to allow admin access which will take ownership of the folders and files, add read write permissions and set the owner back to the original user.

    You can do this manually by right clicking on the folder, selecting properties, security tab, advanced button, owner tab, edit button, select yourself as the new owner and click the apply to subfolders and files checkbox and click ok.

    This will make you the owner and have full permissions, you then tweak the permissions as required to allow both you and the user access and if you wish set the owner back to the original user.

    Edit: Beat me to it, remember to make sure that the original user still has rights as well otherwise this can cause havoc

  4. Thanks to SYNACK from:

    albertwt (18th March 2010)

  5. #4

    Join Date
    May 2009
    Location
    Sydney
    Posts
    282
    Thank Post
    322
    Thanked 3 Times in 3 Posts
    Rep Power
    12

    Wink

    Thanks for the explanation mate,

    I was confused and don't udnerstand why this could be happens :-|

  6. #5
    p858snake's Avatar
    Join Date
    Dec 2008
    Location
    Queensland
    Posts
    1,491
    Thank Post
    37
    Thanked 175 Times in 151 Posts
    Blog Entries
    2
    Rep Power
    52
    Quote Originally Posted by albertwt View Post
    Thanks for the explanation mate,

    I was confused and don't udnerstand why this could be happens :-|
    Do you have the GP set to add administrators to the list to allow them to view it? by default user profiles are restricted to just themselves.

  7. Thanks to p858snake from:

    albertwt (18th March 2010)

  8. #6

    Join Date
    May 2009
    Location
    Sydney
    Posts
    282
    Thank Post
    322
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    no the only GPO that is active in my domain is for WSUS and proxy only.

    since this is just adhoc once off request, i guess i shouldn't apply the GPO from my DC.

    Cheers.

  9. #7

    Join Date
    Aug 2005
    Location
    London
    Posts
    3,159
    Thank Post
    116
    Thanked 529 Times in 452 Posts
    Blog Entries
    2
    Rep Power
    125
    It's all part of user access control.

    If you open a command prompt and try to change into that folder you'll get "access denied" as you've seen. If you right click on the command prompt icon and choose "run as administrator" then you'll be able to change into that folder - you're now using your admin rights and it all works as expected

  10. #8


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    9,809
    Thank Post
    262
    Thanked 2,969 Times in 2,183 Posts
    Rep Power
    847
    Quote Originally Posted by albertwt View Post
    C:\Users\username\Application Data[/B]

    i got access denied when I'm an administrator?
    You should be going to C:\Users\Username\AppData instead. The "Application Data" folder is only there for backwards compatibility reasons i.e. pre-Vista applications. Unless you have a good reason to do so, the default permissions shouldn't be changed.

    The website linked below has a good overview of junction points (which is what the old-style paths are) and how they relate to profiles in Vista and 7.

    http://www.svrops.com/svrops/articles/jpoints.htm

    Code:
    Old Path (2000/XP)                                                  New Path (Vista/7)
    
    \Documents and Settings	                                            \Users
    
    \Documents and Settings\Default User or                             \Users\Default or
    %LOGONSERVER%\NETLOGON\Default User                                 %LOGONSERVER%\NETLOGON\Default
    
    \Documents and Settings\<user>\My Documents                         \Users\<user>\Documents
    
    \Documents and Settings\<user>\My Documents\My Pictures             \Users\<user>\Pictures
    
    \Documents and Settings\<user>\My Documents\My Music                \Users\<user>\Music
    
    \Documents and Settings\<user>\Favorites                            \Users\<user>\Favorites
    
    \Documents and Settings\<user>\Application Data                     \Users\<user>\AppData\Roaming
    
    \Documents and Settings\<user>\Local Settings\Application Data      \Users\<user>\AppData\Local
    
    \Documents and Settings\<user>\Start Menu                           \Users\<user>\AppData\Roaming\Microsoft\Windows\Start Menu
    
    \Documents and Settings\All Users                                   \Users\Public
    
    \Documents and Settings\All Users\Start Menu                        \ProgramData\Microsoft\Windows\Start Menu
    
    \Documents and Settings\All Users\Desktop                           \Users\Public\Desktop
    Last edited by Arthur; 19th March 2010 at 01:54 AM.



SHARE:
+ Post New Thread

Similar Threads

  1. Windows Vista Login Screen / Users
    By DaveMurphy in forum Windows
    Replies: 1
    Last Post: 9th December 2009, 11:51 PM
  2. Cups 1.3.7 access denied on a Windows domain
    By clodhopper in forum *nix
    Replies: 9
    Last Post: 10th June 2009, 12:10 PM
  3. Remote Control Users By Username
    By mmoseley in forum Network and Classroom Management
    Replies: 15
    Last Post: 11th July 2007, 09:50 AM
  4. Access Denied from Admin Network
    By MrDylan in forum ICT KS3 SATS Tests
    Replies: 9
    Last Post: 25th April 2006, 01:09 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •