zag Posted April 26, 2007 Posted April 26, 2007 Just installing Sharepoint Learning Kit on my new sharepoint server and have got to the configuration bit. When trying to create a new database I get: An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) More information has been written to the server event log. Tried to go into the sql server config and open named pipes but no joy, any ideas?
NBC_Sys_C-ord Posted April 26, 2007 Posted April 26, 2007 Go to, Start >> Programs >> Microsoft SQL Server 2005 >> Configuration Tools >> SQL Server 2005 Surface Area Configuration >> Surface Area Configuration for Services and connections. Within this check whether "Local and remote connections" is choosen. If not choose it Solution 2: Check this URL http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=192622&SiteID=1
zag Posted April 26, 2007 Author Posted April 26, 2007 This was a bit of a red herring, but to answer my own question: In the SLK configuration instead of just putting the server name, you need to enter OFFICESERVERS as well. Servername\OFFICESERVERS Only worked that out after looking at the settings so thanks You only need to open the named pipes thing if its on a different server as by default local connections are fine.
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now