Jobos Posted September 24, 2010 Posted September 24, 2010 Right, this question has been bugging me for a while. We've got a 4 year old server that's running 2003 and is fitted with 3GB of memory. It has 2 SATA HD's (not RAID) and is networked with a 1Gb link. From my machine if I copy a large file say 2GB, to one of the server drives, it copies ok but if I copy the same file to the other server drive the progress bar moves very quickly at first then stops with the server HD light lit solid. It will stay like this for a few minutes with the server unresponsive then my machine will report an error and the server will come back to life. For information the server swap file set at 4977 MB and is on the second drive. Any ideas?
DMcCoy Posted September 24, 2010 Posted September 24, 2010 Probably a dead drive. Check the event log for disk errors.
ICT_GUY Posted September 24, 2010 Posted September 24, 2010 Very obvious stab in the dark, the problem drive is not Fat32 by any chance?
Jobos Posted September 24, 2010 Author Posted September 24, 2010 The drive is using NTFS and smaller files copy ok. I've tested it with 1GB files and they copy but the server freezes but comes back to life before any errors. The event log gives these errors at the time I copied the 2GB file. NTDS (420) NTDSA: A request to read from the file "C:\WINDOWS\NTDS\ntds.dit" at offset 1466368 (0x0000000000166000) for 8192 (0x00002000) bytes succeeded, but took an abnormally long time (60 seconds) to be serviced by the OS. This problem is likely due to faulty hardware. Please contact your hardware vendor for further assistance diagnosing the problem. NTDS (420) NTDSA: A request to write to the file "C:\WINDOWS\NTDS\edb.log" at offset 339456 (0x0000000000052e00) for 512 (0x00000200) bytes succeeded, but took an abnormally long time (85 seconds) to be serviced by the OS. This problem is likely due to faulty hardware. Please contact your hardware vendor for further assistance diagnosing the problem.
Jobos Posted September 24, 2010 Author Posted September 24, 2010 Try using Robocopy with the restart switch. Robocopy Robocopy took 17 minutes but it worked.
SYNACK Posted September 24, 2010 Posted September 24, 2010 The drive is using NTFS and smaller files copy ok. I've tested it with 1GB files and they copy but the server freezes but comes back to life before any errors. The event log gives these errors at the time I copied the 2GB file. The drive or sata cable are toast or at the very least massivly overloaded. I would be looking at backing up hurridly and looking at the warrenty status along with running the manufacturers drive test tools like seatools (seagate) which can be run from inside windows.
p858snake Posted September 25, 2010 Posted September 25, 2010 What format are the drives in? NTFS or a Fat version, Because Fat doesn't like 4gb and it could be handling it bad.
Jobos Posted September 25, 2010 Author Posted September 25, 2010 What format are the drives in? NTFS or a Fat version, Because Fat doesn't like 4gb and it could be handling it bad. It's NTFS.
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now