Jump to content
EduGeek EdSec 2026 is Go! 27th Oct in Derby! Join us for a day of EdTech security focused talks, networking, and an evening social ×

Joining any windows clients onto domain issue


Recommended Posts

Posted

Hi

 

Got an issue since we have upgraded our Active Directory DC's, DNS and DHCP to windows 2008. I think the problem is to do with DNS but want a second opinion and more importantly how to fix it.

 

Previously when we had 2003 servers, when we wanted to join a XP, vista client to the domain we could just type in the domainname when joining the computer, our domain name is queensbridge but it now seems we have to type in the alternative domain name that was given to us when the domain was created which is queensbridge.pri. When we type in queensbridge and press return we receive the following error message:

 

"The following error occured when DNS was queried for the service location (SRV) resource record used to locate a domain controller for domain queensbridge:

 

The error was "DNS name does not exist"

RCODE_NAME_ERROR

 

I have also included an attachment of the error message.

 

It seems like a DNS issue but am not sure how to resolve it. Do I just need to register the DNS SRV record for it to work?

 

Have other members seen this problem before and provide any tips on how to sort

 

Any tips would be greatly appreciated.

 

Thanks

dcdiag.txt

Posted

Hi,

 

Searching using Google for the error:

 

0x0000232B

 

Yields this page:

 

DNS error 0x0000232b when trying to join the domain. - Server DNS

 

as the top result.

 

Summary of the advice:

 

First, try simply running a netdiag /fix on all DCs. This should correct any missing or invalid SRV records in DNS for the new

addresses. [ How to use the Network Diagnostics Tool (Netdiag.exe) in Windows 2000 ]

 

If that doesn't do it, post back with the errors you get from netdiag and dcdiag.

 

Source: TechArena Community

 

Have you tried running netdiag /fix at all of your domain controllers?

 

Reply to suggested solution on TechArena Community:

 

...thanks so much for your help. I ended up running ipconfig /registerdns

on all dns servers and that resolved it. Thanks for confirming it was a dns

issue.

 

Hope this helps.

  • Thanks 1

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...