Jump to content
EduGeek EdSec 2026 is Go! 27th Oct in Derby! Join us for a day of EdTech security focused talks, networking, and an evening social ×

Recommended Posts

Posted

Hello,

 

I'm trying to get the classroom booking system by by @webman up and running but think I am missing something with the config.

 

It's a new 2019 server with IIS and mysql. I have modified the config file with my site name. When browsing to the site to start the install I get this displayed on the page "No input file specified." and the url changes itself so the ending of it is index.php/install

 

The latest entries in the log file displays this....

 

INFO - 2019-09-04 12:40:13 --> Config Class InitializedINFO - 2019-09-04 12:40:13 --> Hooks Class InitializedDEBUG - 2019-09-04 12:40:13 --> UTF-8 Support EnabledINFO - 2019-09-04 12:40:13 --> Utf8 Class InitializedINFO - 2019-09-04 12:40:13 --> URI Class InitializedDEBUG - 2019-09-04 12:40:13 --> No URI present. Default controller set.INFO - 2019-09-04 12:40:13 --> Router Class InitializedINFO - 2019-09-04 12:40:13 --> Output Class InitializedINFO - 2019-09-04 12:40:13 --> Security Class InitializedDEBUG - 2019-09-04 12:40:13 --> Global POST, GET and COOKIE data sanitizedINFO - 2019-09-04 12:40:13 --> Input Class InitializedINFO - 2019-09-04 12:40:13 --> Language Class InitializedINFO - 2019-09-04 12:40:13 --> Loader Class InitializedINFO - 2019-09-04 12:40:13 --> Helper loaded: url_helperINFO - 2019-09-04 12:40:13 --> Helper loaded: form_helperINFO - 2019-09-04 12:40:13 --> Helper loaded: date_helperINFO - 2019-09-04 12:40:13 --> Helper loaded: cookie_helperINFO - 2019-09-04 12:40:13 --> Helper loaded: directory_helperINFO - 2019-09-04 12:40:13 --> Helper loaded: text_helperINFO - 2019-09-04 12:40:13 --> Helper loaded: html_helperINFO - 2019-09-04 12:40:13 --> Helper loaded: array_helperINFO - 2019-09-04 12:40:13 --> Helper loaded: crbs_helperINFO - 2019-09-04 12:40:13 --> Language file loaded: language/english/crbs_lang.phpINFO - 2019-09-04 12:40:13 --> Model "Settings_model" initializedINFO - 2019-09-04 12:40:13 --> Controller Class InitializedINFO - 2019-09-04 12:40:13 --> Session: Class initialized using 'files' driver.INFO - 2019-09-04 12:40:13 --> Form Validation Class Initialized

 

 

If anyone could point me in the right direction it would help me massively, Thanks

Posted

Hi Techie-v2! Thanks for trying out classroombookings.

 

Please bear in mind that IIS isn't officially supported, and I don't have much experience with modern IIS, but I'll try to help get it running!

 

"I have modified the config file with my site name." - is this the IIS config, or one of the classroombookings ones?

 

Anyway; the error you're getting is because it can't detect the URL format that IIS is passing. To get this to work could be a bit of trial and error, trying a few different possible config values.

 

The installation process usually writes your configuration file at the end of the process, but to fix this problme you have, you'll need to do this by hand.

 

Create the file "local/config.php" and add this contents:

 

defined('BASEPATH') OR exit('No direct script access allowed');

return array(

'config' => array(
	'base_url' => 'http://server/classroombookings/',
	'log_threshold' => 1,
	'index_page' => 'index.php',
	'uri_protocol' => 'QUERY_STRING',
),

'database' => array(
	'dsn' => 'mysql:host=127.0.0.1;dbname=classroombookings',
	'hostname' => '',
	'username' => 'USER',
	'password' => 'PASS',
	'database' => '',
	'dbdriver' => 'pdo',
),

);

 

Try to load classroombookings again. If it still doesn't work, change the bit that says 'QUERY_STRING' to 'PATH_INFO', and try accessing it again.

 

You will also need to add your database details in there as well - the host (if different from localhost), database name, username, and password.

 

 

Let me know how you get on!

Posted

Hi, thanks for responding.

 

The config file I mentioned is the one in the application/config folder. I modified the database file as well with no luck.

 

I have created the config file in the /local folder as you mentioned and input the details but I still get the same result I'm afraid.

 

Also changing QUERY_STRING to PATH_INFO also made no change.

 

I did have it up and running on a dev server last year and remember I had a similar issue setting it up but managed to work it out, no luck this time round, and I dont have acess to the old server.

 

Thanks for your suggestions.

Posted

Hi!

 

Can you try updating the "local/config.php" file again with these values:

 

'index_page' => 'index.php?',
'uri_protocol' => 'QUERY_STRING',

 

Adding a question mark to index.php might help. If not, again, please try the other suggested values in my previous post for the "uri_protocol" setting.

Posted
Hi!

 

Can you try updating the "local/config.php" file again with these values:

 

'index_page' => 'index.php?',
'uri_protocol' => 'QUERY_STRING',

 

Adding a question mark to index.php might help. If not, again, please try the other suggested values in my previous post for the "uri_protocol" setting.

Ideal, adding the "?" sorted it and got me to the configure database page. Thank you so much. I've changed the uri_protocol back to query_string as well and it still works.

 

Thanks again. Great product [emoji108]

Posted

Spoke too soon [emoji25]

 

Got to the checks page, green ticks on everything. Press the install button and it goes straight to a http 500 error.

 

Any ideas, thought we had it cracked?

Posted
Spoke too soon [emoji25]

 

Got to the checks page, green ticks on everything. Press the install button and it goes straight to a http 500 error.

 

Any ideas, thought we had it cracked?

Thought as soon as I'd posted to look at the log again,

 

The last bit says

 

ERROR - 2019-09-06 20:35:52 --> Unable to connect to the database

ERROR - 2019-09-06 20:35:52 --> Unable to connect to the database

ERROR - 2019-09-06 20:35:52 --> Severity: error --> Exception: Call to a member function errorInfo() on bool D:\inetpub\wwwremote\services\bookings\application\vendor\codeigniter\framework\system\database\drivers\pdo\pdo_driver.php 295

 

Puzzled that it's a database error when it passed the checks?

Posted
I have checked that extension=php_pdo.dll is in the php ini and it's there.
Cancel that, apparently that one is included with the current version of php, the mysql one is there and in commented and if I run phpinfo its shows mysql under the pdo extension
Posted

Great! :)

 

Are the database details definitely correct in local/config.php? Have you tried both 127.0.0.1 and localhost for the hostname bit, if MySQL is on the same server? Does the user exist, and have access to the classroombookings database?

 

Also, which version of MySQ are you using?

Posted
Great! :)

 

Are the database details definitely correct in local/config.php? Have you tried both 127.0.0.1 and localhost for the hostname bit, if MySQL is on the same server? Does the user exist, and have access to the classroombookings database?

 

Also, which version of MySQ are you using?

Yeah database details are good. I can log in to workbench and query browser. They were wrong to start with and the first config page crbs landed on said check database details so I fixed that and it continued the setup pages past the admin login to the checks screen.

 

Changed the config file to use the root user and password and it seems to be working.

 

I'll have to do some fiddling so see why the other user wasnt working before it goes into production.

 

Thanks for all your help. I didn't realise the toner inventory system was made by you as well!

 

Thanks again.

Posted

Brilliant, glad it's sorted! :)

 

Some issues I've had with access for MySQL users is down to which host they're granted access from as well as which one you use to connect to the server; sometimes 127.0.0.1 is treated differently from localhost.

 

Yes that's mine too, albeit also a bit old now!

Posted
Brilliant, glad it's sorted! :)

Spoke too soon, again!

I'm going through putting our timetable in and am getting an error when booking rooms. I've done 2 of our rooms for both weeks of the timetable, but when coming to do the third room, sometimes I'm getting a "There is already a booking for that date, period and room" message.

I have checked the database and there is no such booking, and the "book" hyperlink comes up on the booking sheet still, but after entering the details I get that message. It's not every time, but for most of the ones I try and do.

I can enter the details for the recurring booking directly in the database and the booking then shows up in the system.

The booking I'm trying to make is a recurring one, if I try and make a single one, using the same week, day, room, period and teacher it lets me do it, as soon as I try and make it a recurring one it errors as above but there are no bookings for the room/period/week combination?

 

All the rooms have different ID's in the database obviously.

 

Gratefull for any help you can offer with this?

 

Thanks

Posted

OK, I think I can see where the problem with this is.

 

Can you try making the same recurring bookings by following these steps please:

 

  • View the bookings page for the day/room you want to book.
  • Tick the boxes for the booking (or bookings!) you want to make.
  • Enter the details for Notes and User at the bottom of the table.
  • Click Make Recurring Booking button.

 

Does that work?

  • Thanks 1
Posted
Yes, the code that checks for duplicates (there is a little issue with it checking recurring ones) doesn't acutally run when you make multiple bookings by ticking the boxes :)
Posted

Ah right, makes sense!

 

One more thing, not that I'm moaning about a free product, but I seem to be seeing a lot of speed issues, so much so I've had to increase the max execution time in php. I have 11 rooms, about 130 staff and so far I've made about 200 bookings. It's taking anywhere up to 40 seconds to open a calendar page or save a booking. Have you noticed this behaviour before or is it likely to be my server setup?

 

Thanks

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...