mikkydoos Posted February 14, 2019 Posted February 14, 2019 (edited) Hi all, I have an issue whereby new installs fail to activate Windows 10 2016 LTSB after renewing our Microsoft licensing. I'm missing something here but not sure what ? Our MS licensing renewed last week. I've been activating with ADBA on a 2012 server which has been working fine activating Windows and Office 2016 with KMS keys upon domain join which occurs during setup. A couple of days ago I built a couple of machines from an image installed from WDS. They didn't AD activate.... Error = 0xc004c003 license key invalid. Office had activated but not Windows. I replaced the KMS keys on the ADBA server with the ones generated from the latest MS agreement and I've also added the MAK and CSLV keys in VAMT - both windows and Office for manual activations. I re-installed the image - No Windows activation. The client is showing it has a key. This is the MAK key that was used when the image was created. I'll call this the old key. The image is sysprepped (OOBE) which should scrub out the key completely right ?. Also this old MAK key was used in our unattended .xml - which I've since changed to a new key and re-installed my tests - but the client still won't activate and stills shows the old key and an error. To test I fired up a vanilla VM with no unattended.xml. This activated but not with one of my keys ?.. or is this a GVLK key that will expire? Day 2: _____ Another test of the same image in a VM this morning and it activates... but with the old key... note this key isn't added to ADBA, VAMT or in my unattended.xml, but it is the key that I used when creating the image. Same test on a physical machine....same image, same AD, same unattended.xml.... fails with error in the first picture! What ???? 1. Where the hell is that old key coming from ? 2. Why has Windows suddenly stopped activating after I renew our licensing - or is this a massive coincidence. 3. Where has that random key come from in the vanilla install ? 4. Why will a VM activate and a physical machine not? Mightily confused :mmph::mmph::mmph::mmph::mmph: Cheers in advance Edited February 14, 2019 by mikkydoos
ThatBoringBloke Posted March 1, 2019 Posted March 1, 2019 (edited) I'm pleased someone else is experiencing similar, though we haven't changed our licensing recently. Our 1809 LTSC machines (which I have just started rolling out) seem to work fine when first deployed and added to the domain (ADBA). They seem to come up as activated straight away and all is well, or so I thought. Rolling out the February Cumulative update onto the machines seems to deactivate the licence and we are getting similar issues as you are. Our 2016 LTSB machines seem to be fine. EDIT: Our 1607 machines are KMS activated not ADBA. Edited March 1, 2019 by ThatBoringBloke
mikkydoos Posted March 1, 2019 Author Posted March 1, 2019 (edited) I discovered where I had gone wrong. I must have used a MAK key and not a GVLK key when I was creating my fat image.... this deployment isn't being done with a thin image and MDT. Sysprep doesn't strip out the license key as I assumed so when activating before I renewed it was activating online with the MAK key. When I renewed our licensing the MAK key was expired and couldn't activate. slmgr.exe and cscript are now my best friends - check your keys are all GVLK for the correct versions. For Office key management use cscript ... https://docs.microsoft.com/en-us/deployoffice/vlactivation/tools-to-manage-volume-activation-of-office Hadn't seen it before. Handy As soon as I used the GVLK key for Windows and Office they both activated perfectly from ADBA. Doh! Edited March 1, 2019 by mikkydoos 1
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now