Jump to content
EduGeek EdSec 2026 is Go! 27th Oct in Derby! Join us for a day of EdTech security focused talks, networking, and an evening social ×

Recommended Posts

Posted

Hi we use Squid proxy in our school. Something that was setup by my predessor and i am not aware of how to change things at an advanced level so am wondering if anyone might be able to shed some light on an issue we are having.

 

The benefit we find with Squid is that as a school we can instantly block and unblock sites.

 

We normally have a log file on the server which we edit (found in etc/squidguiard/lists/lbl and we normally enter the domain of a website and hey presto after a few minutes the site is usually blocked.

 

I remember my predesssor telling me if I want to permantly unblock a site there is another file in there (etc/squidguard/lists/always) and if i pop in a domain name into there it will make the site always available.

 

So in the past we had google gmail blocked for our students but we want to make it available, so I went into the LBL file to find the domain and remove ita and also popped it into the always list so it will ALWAYS be available but I am still getting the standard error message that the site is blocked.

 

Filter List Rejection Page

The requested URL has been blocked by category filtering

 

While trying to retrieve the URL: http://mail.google.com/mail/

 

The following error was encountered:

 

Access Denied.

Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.

 

If I bypass the proxy though, I can access the website so I know its a problem with Squid. Does anyone know what could be causing this.

 

Squid is running on our Gentoo Linux server and I am not very experienced with linux. I know that we can access the server via a web interface at https:{servername}:10000, and under the squid proxy server tab there is an option to Clear and rebuild Cache I was thinking of trying this incase there was some sort of corruption.

 

Could this fix it?

 

Your help is appreciated.

Posted
Ok, thanks for sending me the conf. Can you check the contents of '/etc/squid/block.url' I think gmail is listed in there.
Posted

Thanks Geoff that worked.

 

Myself and my colleague were asking why an entry was in that folder.

 

I have been told that if i go to squidguard that would allow me to block sites and allow sites.

 

Is that something that could have been used before my time?

 

The last time it had been edited was 2005!

 

Thanks again.

Posted

It seems to pre-date the squidguard installation. My suggestion for the history of the system is that that list was being used, then at some point the more advanced features of squidguard were requried. I guess whoever did the squidguard installation either forgot to move the urls over, or didn't want to touch something that was working fine.

 

My suggestion would be to move all the urls listed in that file over to the squidguard based lists, then remove the line that references the file in the squid.conf.

Posted

Don't know a lot about squid but I always get it to re-read the config file when I make changes to it. In Windows you do that with

squid -k reconfigure -n squidnt

(last bit just the name of the instance); it's something similar in Unix. Might be worth trying that?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...