TwistedHelixis Posted May 20, 2016 Posted May 20, 2016 Well I could not sleep last night thinking about this issue. Recently had to rebuild our primary schools file server and I thought all was fine as staff have been using it for about a week now, but I just went to a main shared folder and tried to do the following, replace all child object permissions with inheritable permissions from this object and received the following error on some folders and files Error Applying Security An error occurred while applying security information to D:\Office\FOLDER\FILE Failed to enumerate objects in the container BTW I am logged on with someone in the domain admins group Looking this up on Google seems to be an issue with the Owner in the Advance folder security settings. Some of the folders seem to have my domain admin as the owner and some as the user who created the folder within the shared area. Not sure how to proceed?
TwistedHelixis Posted May 20, 2016 Author Posted May 20, 2016 Some more info My domain account is listed with Full control in the security tab Most folders seem to have my domain acc as the owner of the folder in advanced security, but not all. Could someone check a shared folder on their file server and let me know whats listed in, security, advanced security and let me know what they have as the owner please.
TwistedHelixis Posted May 20, 2016 Author Posted May 20, 2016 Some more info Just found a shared folder that my domain user was not listed in security but domain admins was so I added my domain user with full control and hit apply and it cam back with the same error as above and did not add me to the security of the folder. What on earth is going on.
TwistedHelixis Posted May 20, 2016 Author Posted May 20, 2016 Can you take ownership of the all the folders? Yes that has worked Thanks - never realized that when you clicked on take ownership it then displayed a box to do the same on all sub folders, doh. Whats to stop users creating more folders that a not created with my user as the owner?
TwistedHelixis Posted May 20, 2016 Author Posted May 20, 2016 (edited) Also, can I take ownership of the home folders as I have just noticed my domain acc is not listed in the security or will this bork the home folder AD system. Edited May 20, 2016 by TwistedHelixis
TwistedHelixis Posted May 20, 2016 Author Posted May 20, 2016 OK the plot thickens. I tried to add my domain admin acc to the folder security on any of the shared folders it was missing but got the enumerate objects error, so I created a new domain admin acc and was able to add my other domain admin acc to all the folders. Does that mean my original domain admin account is faulty in some way? why would one domain admin acc get blocked and yet another be fine???? Think if I can answer this I will be much clearer about all the other issues
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now