Gongalong Posted July 4, 2013 Posted July 4, 2013 Hi folks, (Hopefully this is the right forum as it does start with "Internet Related...") Among my many random requests I have been asked about setting up WordPress for students to use. I have zero knowledge about WordPress. I've asked a few IT friends and was mostly pointed towards Microsoft Web Platform as a simple place to start (short of building LAMP servers etc.) I've installed it on a Win 7 PC, but can't seem to configure it remotely - I've pointed to the server from another machine using the IP address, the relevant port, and /wp-admin (which is working as localhost). Can anyone advise what I'm doing wrong from a remote access POV, or recommend a guide? My long term plan is to install it on a dedicated VM which the students can trash, and I'll then just return to an earlier snapshot. TIA
soveryapt Posted July 4, 2013 Posted July 4, 2013 Howdo My first recommendation would be (especially if you're going to VM it anyway) to use a *nix distro (I use Ubuntu for all things like that). If you use the server edition, then you can pretty much get it to set up out of the box by telling it you want the webserver and MySQL etc. In terms of guides for using it, Main Page « WordPress Codex is a great place to start. Getting to the remote access point, I assume that the machine you've installed on has port 80 open on it for accessing the webserver and such? If it does, are you accessing it using an IP address or domain name? If domain name, does your DNS have the pointers in place to make sure it gets to the right machine etc? 1
Gongalong Posted July 5, 2013 Author Posted July 5, 2013 Yes, firewall's disabled on the Windows PC. I tried accessing only by IP address. I installed on two PCs, and oddly the port was different on both machines. Not sure whether that's symptomatic of something?
Devontechie Posted July 5, 2013 Posted July 5, 2013 Microsoft Web platform using a different port for each install of wordpress or anything else that you use from the list of programs. I am not sure if you can change the port it uses - I'll have a look on my laptop in abit and see if you can 1
Gongalong Posted July 5, 2013 Author Posted July 5, 2013 Oddly the address I was using yesterday doesn't work at all today - page not found - but I haven't had much time to look into it yet.
Devontechie Posted July 5, 2013 Posted July 5, 2013 When you open up Microsoft Web Platform, select the site (which Opens up Microsoft WebMatrix). From there you can select Site > Settings. On this screen you change the address (I haven't tried changing it before), also the port number is in here as well 1
Gongalong Posted July 5, 2013 Author Posted July 5, 2013 Thanks, that's got me access back. Curiously I was using the right address, so no different, yet it worked via the Matrix link (!). Odd though that I still can't access remotely. I'm not quite sure where to start from a troubleshooting perspective.
Gongalong Posted July 5, 2013 Author Posted July 5, 2013 I get a 400 error remotely: This error (HTTP 400 Bad Request) means that Internet Explorer was able to connect to the web server, but the webpage could not be found because of a problem with the address. For more information about HTTP errors, see Help.
Devontechie Posted July 5, 2013 Posted July 5, 2013 WebMatrix has ti be running for you to access the site. When I get back in office (I'm currently out visiting clients and using mobile) I'll have a look at the settings and see if I can workout how to access it from another machine. What happens if you change localhost to the ip address of the machine, can you access the site from another machine then? 1
Gongalong Posted July 5, 2013 Author Posted July 5, 2013 What happens if you change localhost to the ip address of the machine, can you access the site from another machine then? Then I get a "connection refused" error, which is from our upstream county council proxy. Having checked our local firewall it's giving a 503 error for the favicon.ico. Odd! Perhaps there's a routing issue?
Gongalong Posted July 5, 2013 Author Posted July 5, 2013 When I switch the hosting PC to the county council proxy (not using our local proxy) - essentially our upstream proxy - I get a 400 error.
Devontechie Posted July 5, 2013 Posted July 5, 2013 Then I get a "connection refused" error, which is from our upstream county council proxy. Having checked our local firewall it's giving a 503 error for the favicon.ico. Odd! Perhaps there's a routing issue? I'm guessing it shouldn't be using the proxy for a local ip address... have got bypass proxy for local addresses ticked in ie? What happens if you remove the proxy address?
Gongalong Posted July 5, 2013 Author Posted July 5, 2013 If I use the upstream proxy it allows me to ignore for local addresses, which is enabled with the correct scope. I do have some other local resources e.g. network hardware, which do seem to resolve correctly.
Gongalong Posted July 5, 2013 Author Posted July 5, 2013 Under settings I can actually define the access address (!). It was set to EduGeek.net - The I.T. Professionals' life line so I change it to the IP address of the PC with the same port. I can now access the PC locally via IP address, but it still doesn't work remotely. The requests button does show when the machine is accessing itself, but doesn't show anything when trying to access remotely. Again though it looks like a routing issue, as the local firewall is showing the remote PC getting a 503 error. I've changed the proxy to the upstream again, and now it's working remotely. So the Settings page fixed it!
Gongalong Posted July 5, 2013 Author Posted July 5, 2013 I spoke too soon. That's broken the ability to login to the admin page (:17351/wp-admin). It's doing some odd redirect, and trying to go to localhost:17351/wp-login.php?redirect_to=http%3A%2F%2F10.121.245.115%3A17351%2Fwp-admin%2F&reauth=1
Gongalong Posted July 5, 2013 Author Posted July 5, 2013 Hum. Could it be because the site has not been published? (I've just spotted the Publish button)
soveryapt Posted July 8, 2013 Posted July 8, 2013 (edited) I spoke too soon. That's broken the ability to login to the admin page (:17351/wp-admin). It's doing some odd redirect, and trying to go to localhost:17351/wp-login.php?redirect_to=http%3A%2F%2F10.121.245.115%3A17351%2Fwp-admin%2F&reauth=1 That link to me says that you're trying to access it on a different address to that which is registered in the /wp-admin/options-general.php (or /wp-admin/options.php) page. The site address should be set to being exactly as you need to access it, including any ports required. So, if you want to access it via localhost:17351 then it should be set to http://localhost:17351, if via the IP address that's showing there http://10.121.245.115:17351 (which looks like it is probably already set with http://localhost:17351). To me, it would suggest that you should be using the localhost to access it as if not, Wordpress will try to redirect you to localhost (which if you're on a remote machine is useless obviously) then it will try and direct you back to the IP address you accessed it with. If you struggle to change it via the interface remotely, you might have to do it from the server it is served on because of the localhost thing, otherwise you could change it in the SQL. Edited July 8, 2013 by soveryapt 1
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now