adamf Posted May 4, 2011 Posted May 4, 2011 Really struggling with the cluster validation as part of the process of setting up failover clustering for use with HyperV. I am consistantly getting 1 of 2 errors every time I run the storage tests - every other set of tests pass. I either get: Failed to attach disk with ID {de6d1f59-01e2-4864-af26-8f044f78e41b} from node servername (error Incorrect function. ). Please retry after restarting servername. or Disk with id {de6d1f59-01e2-4864-af26-8f044f78e41b} is only visible from one node. This disk is not eligible for cluster validation. I'm pretty sure i've got the iSCSI settings correct as I can see the disk in Disk Managment, offline ready for the validation to test it, but it still fails. Despite following the instructions to restart the server and try again I am still having the issue. In the storage array (Dell PV MD3200i) i've got 2 controllers and while the tests are being carried on I have observed the virtual disk moving backwards and forwards between controllers - I'm sure this has something to do with it but I don't know why... Can anybody point me in the right direction
SkreeM1980 Posted May 11, 2011 Posted May 11, 2011 Have you got the Volume on the storage configured to allow multiple iSCSI connections? Also how are you connecting to if from the guest OS, it it mapped through hyper-v as a physical disk or using a windows inbuilt iSCSI connection? Skr
cogrady84 Posted September 29, 2011 Posted September 29, 2011 Do you have multiple iSCSI sessions configured from each host for MPIO? Incorrect function usually occurs when the virtual disk is on the non-preferred controller (part of failover testing) and the host doesnt have a path to the disk, either physically or through iSCSI sessions.
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now