talksr Posted July 30, 2018 Posted July 30, 2018 Hi there, I keep getting the following errors on any policy when viewing settings tab: An error has occurred while collecting data for Administrative Templates. The following errors were encountered: Resource '$(string.Win7Only)' referenced in attribute displayName could not be found. File \\server\SysVol\stm.internal\Policies\PolicyDefinitions\SearchOCR.admx, line 12, column 69 Namespace 'Microsoft.Policies.WindowsStore' is already defined as the target namespace for another file in the store. File \\server\SysVol\stm.internal\Policies\PolicyDefinitions\WinStoreUI.admx, line 4, column 80 Can anyone tell me how to fix this? I have copied the same file from working servers, but they are all 2016 ones. I do not have any 2012 servers to copy one from. I can't remember what the latest central store version to be updated was.
Steve21 Posted July 30, 2018 Posted July 30, 2018 (edited) -Edit - Ignore that skim read That's the 1803 error not the older one isn't it. There's a thread on here about editing the policy to resolve the issue, but don't think an official fix was released yet. If I remember right you needed to change the searchocr adml back from the 1511 one to override the 1803 one as it's missing one of the definitions Steve Edited July 30, 2018 by Steve21 1
talksr Posted July 30, 2018 Author Posted July 30, 2018 -Edit - Ignore that skim read That's the 1803 error not the older one isn't it. There's a thread on here about editing the policy to resolve the issue, but don't think an official fix was released yet. If I remember right you needed to change the searchocr adml back from the 1511 one to override the 1803 one as it's missing one of the definitions Steve Ah right ok. I don't think I have the backups any longer. I literally cleared everything out this morning, and then found the fault was there in group policy. Unfortunately, server had 19mb of space on C drive so I had to take drastic action. It turned out there was almost 195gb of temp files. But alas, I no longer have the old adml files. Can't believe MS have not released a fix for this yet. I am sure this is not the first time this has come up. Presumably, it means that some policies will not be functioning.
Steve21 Posted July 30, 2018 Posted July 30, 2018 You could try these two, they're 2013 versions on ours, haven't done the 1803 GPOS yet so think these should work for you, but obviously backup and whatnot searchocr.zip Steve
talksr Posted July 30, 2018 Author Posted July 30, 2018 You could try these two, they're 2013 versions on ours, haven't done the 1803 GPOS yet so think these should work for you, but obviously backup and whatnot [ATTACH]49860[/ATTACH] Steve Thanks very much Steve. Just to clarify, you think it is the searchocr adml that needs changing back to the old version? I am just backing up the whole Policies Definitions folder.
Steve21 Posted July 30, 2018 Posted July 30, 2018 Yeah it's something to do with there was a Win7 and later flag that was put into it, but removed after 1511 as they assumed no-one needed it, which than causes problems as it recognises the newer OS etc. "File \\server\SysVol\stm.internal\Policies\PolicyDefini tions\SearchOCR.admx" It's the admx and adml that needed changing, but should only be that one to resolve this issue Steve 1
talksr Posted July 30, 2018 Author Posted July 30, 2018 Yeah it's something to do with there was a Win7 and later flag that was put into it, but removed after 1511 as they assumed no-one needed it, which than causes problems as it recognises the newer OS etc. "File \\server\SysVol\stm.internal\Policies\PolicyDefini tions\SearchOCR.admx" It's the admx and adml that needed changing, but should only be that one to resolve this issue Steve Thanks Steve, have replaced, but getting exactly the same error as before. My server version is Server 2012 R2 build 9600 if that helps?
Steve21 Posted July 30, 2018 Posted July 30, 2018 When you say the same error which one as you listed two. The WinstoreUI one is normally when you have the winstoreui admx and the newer windowsstore.admx at the same time (The old one winstoreui needs deleting, same with the adml) Steve
talksr Posted July 30, 2018 Author Posted July 30, 2018 When you say the same error which one as you listed two. The WinstoreUI one is normally when you have the winstoreui admx and the newer windowsstore.admx at the same time (The old one winstoreui needs deleting, same with the adml) Steve Ok Steve, thanks for your help. I have just deleted and that error has now gone. We are getting there with this, but at headache. Still getting the SearchOCR error.
Steve21 Posted July 30, 2018 Posted July 30, 2018 Your adml's should be in a subfolder with their languages, I'm not sure that'll even work like that :s Or aren't you using central store? Don't you have an (in this example) en-us folder with the admls inside? Steve
talksr Posted July 30, 2018 Author Posted July 30, 2018 Your adml's should be in a subfolder with their languages, I'm not sure that'll even work like that :s Or aren't you using central store? Don't you have an (in this example) en-us folder with the admls inside? Steve Interesting, I gave the Group Policy another restart and now it seems fine. How odd. I think this issue is now rectified. Will keep an eye on it, but seems ok for now. Thanks again for your help.
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now