Jump to content
EduGeek EdSec 2026 is Go! 27th Oct in Derby! Join us for a day of EdTech security focused talks, networking, and an evening social ×

Recommended Posts

Posted

This possibly should be two threads but I found one as a consequence of the other.

 

The end goal is to enable credential guard which requires certificate based authentication.

 

I setup ADCS and have issued certs to all of my machines.

I have added smart card / other certificate to the default connection policy using my NPS computer cert. The peap option is still using a valid public cert.

I have enabled credential guard on my machine.

I created a GPO to use smart card / other cert and ticked all the cert options, also computer only.

 

I have gone back and forth several times on settings, as of now it just doesn't connect. At one point I got an error about it not being compatible, and another the logs showed cert revocation errors.

 

I have reissued the cert to fix the revocation chain, but as of now I'm not seeing anything in event log for my machine.

 

This brings me to my next issue, NPS is a pain to troubleshoot. Any good log viewers? When I bring up NPS logs in event viewer the CPU goes to 100 and clients fail to authenticate until it settles down or I kill the process. I stopped the VM today and gave it more CPUs, that has helped.

I came across this blog but it isn't working.

I used to have ACS which had a nice log in troubleshooting interface.

 

I can post screen shots later.

 

Thanks,

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...