mdench Posted April 16, 2013 Posted April 16, 2013 Now that we have moved all our data on a samba based storage we keep getting this error in syslog Apr 16 07:56:29 trinity smbd[4888]: [2013/04/16 07:56:29.132674, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:56:29 trinity smbd[4888]: Failed to init inotify - Too many open files Apr 16 07:56:30 trinity smbd[4888]: [2013/04/16 07:56:30.250249, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:56:30 trinity smbd[4888]: Failed to init inotify - Too many open files Apr 16 07:56:30 trinity smbd[4888]: [2013/04/16 07:56:30.812052, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:56:30 trinity smbd[4888]: Failed to init inotify - Too many open files Apr 16 07:56:33 trinity smbd[4888]: [2013/04/16 07:56:33.652638, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:56:33 trinity smbd[4888]: Failed to init inotify - Too many open files Apr 16 07:56:38 trinity smbd[4888]: [2013/04/16 07:56:38.573648, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:56:38 trinity smbd[4888]: Failed to init inotify - Too many open files Apr 16 07:56:44 trinity smbd[4891]: [2013/04/16 07:56:44.348012, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:56:44 trinity smbd[4891]: Failed to init inotify - Too many open files Apr 16 07:56:44 trinity smbd[4891]: [2013/04/16 07:56:44.426425, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:56:44 trinity smbd[4891]: Failed to init inotify - Too many open files Apr 16 07:56:45 trinity smbd[4895]: [2013/04/16 07:56:45.682939, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:56:45 trinity smbd[4895]: Failed to init inotify - Too many open files Apr 16 07:56:47 trinity smbd[4895]: [2013/04/16 07:56:47.281783, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:56:47 trinity smbd[4895]: Failed to init inotify - Too many open files Apr 16 07:57:00 trinity smbd[4891]: [2013/04/16 07:57:00.727050, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:57:00 trinity smbd[4891]: Failed to init inotify - Too many open files Apr 16 07:57:02 trinity smbd[4895]: [2013/04/16 07:57:02.311698, 0] smbd/notify_inotify.c:297(inotify_setup) Apr 16 07:57:02 trinity smbd[4895]: Failed to init inotify - Too many open files From what I've read on the interweb it's to do with the kernel notifying applications that a file has been changed somewhere on the file system and that we should change the values located in max_queued_events, max_user_instances, max_user_watches but so far haven't had any luck. Does any one else have any ideas that we could try?
CyberNerd Posted April 16, 2013 Posted April 16, 2013 This is from the Redhat support portal: https://access.redhat.com/site/solutions/21601 Resolution It looks like the well known max filedescriptors limit has reached. This can be changed with the fs.file-max sysctl tunable. Increasing the numbers in the following control files should resolve the issue. /proc/sys/fs/inotify/max_user_instances /proc/sys/fs/inotify/max_user_watches *man inotify* ===== /proc/sys/fs/inotify/max_user_instances This specifies an upper limit on the number of inotify instances that can be created per real user ID. /proc/sys/fs/inotify/max_user_watches This specifies an upper limit on the number of watches that can be created per real user ID. ===== Add the following line to /etc/sysctl.conf. fs.inotify.max_user_instances = Run the command below. # sysctl -p In one of the case, increasing fs.file-max tunable with syctl does not resolved the issue. Root Cause One of the following limits has been reached: /proc/sys/fs/inotify/max_user_instances /proc/sys/fs/inotify/max_user_watches
mdench Posted April 16, 2013 Author Posted April 16, 2013 Cheers for that will Up the number in instances as we have watches set to 1048576 and see how we get on
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now