Migrate Edugeek Joomla 1.X to 1.5

From Wiki

Revision as of 13:54, 27 April 2009 by Mossj (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to:navigation, search

How to migrate an existing egJP 1.0 site to 1.5.3

VERY IMPORTANT

  • This is not necessary to do if your site is working fine with egJP 1.0.
  • This procedure is not endorsed in anyway by the egJP project leaders.
  • It is not suitable for exisiting complex sites

ejJP 1.x is a very stable and well supported product and if you've got a lot of content and you've invested time and effort on tweaking your install then its really really not worth any effort in trying migrating to 1.5 and according to project leaders, it will probably break your site.

However.... If, like me, you installed a 1.0 site last month and your now building other 1.5 sites and you want your first site to be the same as the new ones then read on.

Easy method - just needs a bit of manual graft

http://docs.joomla.org/Migration - A additional useful resource

This method only automatically copies across content - no menus, templates or docs/media files.

This ensures that nothing gets fouled up as the migration tool does a 100% job of getting the content but has to make compromises on things like menus.

However, copying these other files is easy to do via FTP, so its not worth looking at doing it another way.

The only painful bit is re-editing the standard menus again to get back your customised ones and re-customising your modules back to where you want them. if you haven't done much customisation of your 1.0 site then there isn't much to do for this.

However, its not rocket science and just requires a bit of time :)

Enough waffle - on with instructions.

IF YOUR ISP/RBC ONLY GIVES YOU ONE SQL DATABASE - MAKE SURE YOU ALTER PREFIX NAME IN ADVANCED SETTINGS OTHERWISE YOU WILL BE STUFFED.

Create a new egJP 1.5.3 install in a sub-directory of your site (I used one called j153)

IF YOUR ISP ONLY GAVE YOU ONE DATABASE - MAKE SURE YOU DID ALTER PREFIX NAME IN ADVANCED SETTINGS OTHERWISE YOU ARE NOW ACTUALLY STUFFED!

Install mtwMigrator.

Delete all Articles (and then emptied the article trash)

Make sure you've really deleted everything.

Delete all Categories Delete all Sections.

Select mtwMigrator from the Components Menu

Edit Global Conguration with you OLD site information.

If your sharing one SQL database then the prefix is your OLD site prefix.

On the right-hand side just select backup,sections,categories and content to migrate NOTHING -I MEAN NOTHING ELSE (JUST DON'T EVEN TRY IT!)

Save and Start Migration

Its never taken long with me (30 secs or so) to transfer my sites but YMMV. Volia.

You now need to look at your site normally and start restoring the look and feel of your old one.

Its easy to find your old modifed headers and copy them across.

DONT JUST COPY WHOLE TEMPLATES OTHERWISE BAD THINGS WILL HAPPEN (I think)

If you modified css files - modify them again in new site.

Use FTP/Docman/Media Manager to transfer all your old files across.

Once your happy with new site - its easy to move it down to root - check out edugeek forums for instructions until I get them on the wiki.