Does the version matter if we buy iLO2 advanced licenses for all our servers? or do we need to buy iLO licenses for the servers that dont say there iLO2?

looking to go down the route of getting rid of the mass of cables behind our server rack and replace that ugly 8way KVM with some simple network cables, seeing as all our new servers are HPs and theres 5 old Dell servers left which are slowly being phased out

so can i buy aload of iLO2 licenses or do i have to buy both iLO and iLO2 ones depending on the version the server states it uses?

cheers