+ Post New Thread
Results 1 to 15 of 15
Wireless Networks Thread, WOL not working across entire LAN in Technical; This one has me stumped. Some weeks back it came to my attention that machines across the school were failing ...
  1. #1
    gybe78's Avatar
    Join Date
    May 2008
    Location
    Aylesbury
    Posts
    140
    Thank Post
    24
    Thanked 29 Times in 19 Posts
    Rep Power
    16

    WOL not working across entire LAN

    This one has me stumped.

    Some weeks back it came to my attention that machines across the school were failing to wake up in the morning before school. No changes had been made on the network that I can think of.

    On investigation I find that, if I run a WOL Packet Sniffer within Windows on a client machine and send a WOL magic packet to it from another PC/server, the packet is received successfully.

    However, if I shut down the client and and then send the magic packet again, the client fails to wake up although WOL is enabled in the BIOS. This behaviour is replicated across all machines on the network.

    I can only assume that a setting in our core switch is causing this but I don't understand how a WOL magic packet can be successfully delivered when a client is switched on, but not when it's off.

    All our switches are HP Procurve and the core is a 5406zl model.

    Any ideas gratefully received!

  2. #2
    gybe78's Avatar
    Join Date
    May 2008
    Location
    Aylesbury
    Posts
    140
    Thank Post
    24
    Thanked 29 Times in 19 Posts
    Rep Power
    16
    bump...

  3. #3

    Join Date
    Sep 2006
    Location
    West Midlands
    Posts
    408
    Thank Post
    70
    Thanked 75 Times in 58 Posts
    Rep Power
    43
    Have you tried WOLing a client on the same physical network segment to make sure that it works? Maybe just use a hub rather than a switch.

    If it does work (from switched off), move the client further away to try to determine what is gobbling up the packets.

    mb

  4. #4

    Join Date
    Jan 2008
    Location
    Cheshire, UK
    Posts
    331
    Thank Post
    63
    Thanked 59 Times in 41 Posts
    Rep Power
    47
    Quote Originally Posted by gybe78 View Post
    On investigation I find that, if I run a WOL Packet Sniffer within Windows on a client machine and send a WOL magic packet to it from another PC/server, the packet is received successfully.
    Try properties of "Local Area Connection" and click "Configure..." for the controller.
    On the advanced tab see if there wake on LAN settings here that are disabled. On my machine here I have "Wake on Magic packet", "Wake on pattern" and "WakeOnLAN from PowerOff".

  5. #5

    ZeroHour's Avatar
    Join Date
    Dec 2005
    Location
    Edinburgh, Scotland
    Posts
    5,569
    Thank Post
    868
    Thanked 1,293 Times in 786 Posts
    Blog Entries
    1
    Rep Power
    436
    Quote Originally Posted by sjatkn View Post
    Try properties of "Local Area Connection" and click "Configure..." for the controller.
    On the advanced tab see if there wake on LAN settings here that are disabled. On my machine here I have "Wake on Magic packet", "Wake on pattern" and "WakeOnLAN from PowerOff".
    Yeh check the nic settings as xp can need to have wake enabled but I believe that only affects wakes from standby/hibernate etc though so I would have thought it would have worked.
    When the pc is off I assume the nic lights on the back are still on/active?

  6. #6
    gybe78's Avatar
    Join Date
    May 2008
    Location
    Aylesbury
    Posts
    140
    Thank Post
    24
    Thanked 29 Times in 19 Posts
    Rep Power
    16
    Hi all

    Thanks for the suggestions.

    Yes, NIC settings have WOL enabled and when clients are shutdown the NIC lights remain active.

    I will try connecting devices to a simple hub and see if the behaviour changes.

  7. #7
    apeo's Avatar
    Join Date
    Sep 2005
    Location
    Lost
    Posts
    1,612
    Thank Post
    95
    Thanked 115 Times in 111 Posts
    Rep Power
    41
    Not that i think this is happening at your site but we have had some computers refuse to WOL and it usually came down to either PSU or Motherboard being the issue. As you seem to have a problem with all your computers i cant see it being a hardware issue with your computers.

  8. #8
    gybe78's Avatar
    Join Date
    May 2008
    Location
    Aylesbury
    Posts
    140
    Thank Post
    24
    Thanked 29 Times in 19 Posts
    Rep Power
    16
    So it would seem that the WOL issue on my network is being caused by the Intel NIC drivers installed on 99% of our machines. On driver version 9.12.18.0 WOL worked successfully but since changing to version 9.13.41.0 (required for new hardware) WOL is not working despite it being enabled in the BIOS and within the NIC properties. A couple of forums suggest that registry hacks are required to get it working but I can't find any documentation about this.

    Has anyone else seen this issue?

  9. #9
    gybe78's Avatar
    Join Date
    May 2008
    Location
    Aylesbury
    Posts
    140
    Thank Post
    24
    Thanked 29 Times in 19 Posts
    Rep Power
    16
    bump...

  10. #10
    Heebeejeebee's Avatar
    Join Date
    Nov 2006
    Location
    Intergalactic Cruise
    Posts
    1,036
    Thank Post
    68
    Thanked 74 Times in 58 Posts
    Rep Power
    34
    Registry hack? Surely Windows is not running if you want to WOL!

    HBJB

  11. #11
    gybe78's Avatar
    Join Date
    May 2008
    Location
    Aylesbury
    Posts
    140
    Thank Post
    24
    Thanked 29 Times in 19 Posts
    Rep Power
    16
    I would tend to agree but RM have suggested it has been required in order for it to work on the older driver...

    The driver we released for this mainboard has a registry update that enables WOL and this is run from a script as part of the build process
    Below are the regkeys which get merged. You could try added them but you will need to ensure the correct class is modified but as the driver has not been released by us but from intel I cannot help with this and cannot guarantee whether it will work.

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Cl ass\(4D36E972-E325-11CE-BFC1-08002bE10318)\0001]
    "WakeOn"="6"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\(4D36E972-E325-11CE-BFC1-08002bE10318)\0001]
    "WakeOn"="6"
    I have tried this on the newer driver but predictably it doesn't work.

  12. #12

    Join Date
    Sep 2006
    Location
    West Midlands
    Posts
    408
    Thank Post
    70
    Thanked 75 Times in 58 Posts
    Rep Power
    43
    Quote Originally Posted by Heebeejeebee View Post
    Registry hack? Surely Windows is not running if you want to WOL!

    HBJB
    I have seen Windows do this. I think that it loads stuff/settings into the volaitile memory on the NIC which remains when the computer is switched off but still plugged in. You need to unplug the mains cable for several seconds to reset things, which is not an ideal thing to do in a room full of PCs.

    mb

  13. Thanks to Martin from:

    gybe78 (18th May 2010)

  14. #13
    gybe78's Avatar
    Join Date
    May 2008
    Location
    Aylesbury
    Posts
    140
    Thank Post
    24
    Thanked 29 Times in 19 Posts
    Rep Power
    16
    No, not ideal at all - you're not wrong!

  15. #14
    Heebeejeebee's Avatar
    Join Date
    Nov 2006
    Location
    Intergalactic Cruise
    Posts
    1,036
    Thank Post
    68
    Thanked 74 Times in 58 Posts
    Rep Power
    34
    Quote Originally Posted by Martin View Post
    I have seen Windows do this. I think that it loads stuff/settings into the volaitile memory on the NIC which remains when the computer is switched off but still plugged in. You need to unplug the mains cable for several seconds to reset things, which is not an ideal thing to do in a room full of PCs.

    mb
    I see. Actually that explains a few little issues we have occasionally where we have to unplug the machines to get any network at all sometimes.

    HBJB

  16. #15

    Join Date
    Jul 2013
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I recently solved this issue and wrote a procedure for my IT team on this, related to Windows power management of the NIC's. Setting the BIOS to accept magic packets is one thing, for sure, but preventing Windows from putting the NIC to sleep is often overlooked, and it is easy to deal with, as follows:

    Steps to Disable NIC Power-Saving Features to Keep the NIC Awake
    by Dan Reams

    These steps are based on my experience and not by any one article read in the MS Knowledge Base or on the forums.


    • Explore the power-saving properties of the NIC’s via their driver controllers (properties tabs) and de-select “Allow this computer to turn off this device”. You may have to hunt for this, in Windows XP, via right-clicking on the NIC, in Device Manager, or navigating to the NIC properties via the Network control. In Windows 7, there is often a “Power Management” tab associated with the NIC upon right-clicking the NIC’s properties via Device Manager. Related:

    o Disable “Allow computer to turn off this device to save power”
    o Windows 7 shuts off my network adapter when i the computer goes into - Microsoft Community


    • Implement a catch-all registry setting value to over-ride any hidden “on” state of the power-saving feature. One can certainly navigate to the registry and create or edit keys, but I prefer to create registry files (.reg), for each NIC, and simply double-click them. This both avoids real-time typing mistakes and is much faster. In the below example, the 0001 represents NIC #1 in the system. If the system has multiple NIC’s, you should also create a .reg file with a value of 0002 in the same position.

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0001]
    "PnPCapabilities"=dword:00000038

    Simply copy and paste the text above, to a text file, save it, and rename the file from .txt to .reg, then run it on the target PC’s. Again, if the PC has two NIC’s, create a version of the file that replaces 0001 with 0002 and run that as well.

SHARE:
+ Post New Thread

Similar Threads

  1. WOL Not working on older machines...
    By _techie_ in forum Windows
    Replies: 6
    Last Post: 19th August 2009, 12:13 PM
  2. HP dx2450 Wake on lan (WOL) problems
    By Craggus2000 in forum Hardware
    Replies: 5
    Last Post: 13th August 2009, 09:20 PM
  3. Replies: 0
    Last Post: 2nd November 2008, 08:59 PM
  4. youtube not working on LAN
    By Steven in forum Wireless Networks
    Replies: 0
    Last Post: 5th September 2008, 11:47 PM
  5. Wake on LAN stopped working
    By enjay in forum Hardware
    Replies: 8
    Last Post: 17th June 2008, 03:42 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •