+ Post New Thread
Results 1 to 4 of 4
Wireless Networks Thread, Captive Portal redirect FAIL on BlueSecure BSC-2100 in Technical; I need to set up the captive portal on my BlueSocket gear. I've never needed it before because I've previously ...
  1. #1

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,592
    Thank Post
    109
    Thanked 770 Times in 598 Posts
    Rep Power
    183

    Captive Portal redirect FAIL on BlueSecure BSC-2100

    I need to set up the captive portal on my BlueSocket gear. I've never needed it before because I've previously used transparent authentication.

    I've read through all the documentation and Googled my heart out and everything seems to suggest that you should connect to the wireless network, attempt to go to a web page and then get diverted. This doesn't happen.

    DNS and ICMP are both working correctly and I can see my test clients are currently in the 'un-registered' role. These clients can access the web login page if I type the IP address into the address bar. Authentication works fine from there too. It's just that this is more of a 'portal' than a 'captive portal'

    The clients don't even seem to be getting re-directed to the IP address... they just sit looking for the originally requested webpage.

    If anyone can help I'd be very grateful... this is the ONLY job I have to do today!
    Last edited by Ric_; 16th February 2010 at 11:44 AM.

  2. #2
    ICTNUT's Avatar
    Join Date
    Jul 2005
    Location
    Hereford
    Posts
    1,419
    Thank Post
    196
    Thanked 249 Times in 122 Posts
    Rep Power
    62
    And this is exactly what we have been trying to do and are in exactly the same boat.

    Client will connect, access the portal, authenticate and then just sit there.

  3. #3

    Join Date
    Feb 2010
    Posts
    11
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    What debugging have your tried?

    I dont have any experience with BlueSocket, but I do have lots with Trapeze and they also use a captive portal. So it should be a similar process.

    Is there a spare port on the wireless controller? If so, set the port to use the same VLAN that would be used for your captive portal. Plug a laptop into it and see what happens. Can you access the Internet? Do you get DHCP?

  4. #4

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,592
    Thank Post
    109
    Thanked 770 Times in 598 Posts
    Rep Power
    183
    Get in!

    After trying everything, I wondered if the config was knackered since it had been in place all the way from v4.x (current version is v6.5.0.8 I think). I backed-up the config and performed a factory reset. After some basic setup, the captive portal then seemed to work but nothing else did despite it all being the same as before

    I thought, why not try reverting, at least I'll have working wireless again. Restored the config and remembered that I'd changed the 'Port of web direction for user logins' to '8081' to get it working on the clean box. This setting is under 'General'->'HTTP'.

    Bish, bash, bosh it now all works. Now I just have to worry about client certificates and encryption for the 'roaming'# users and it's all gravy!

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 8
    Last Post: 7th March 2011, 04:06 PM
  2. Birmingham UK, BSc(Hons)
    By aaltaf in forum Educational IT Jobs
    Replies: 16
    Last Post: 23rd February 2010, 11:29 PM
  3. [Pics] Fail Blog Post Says It All: Fire Prevention Fail
    By DaveP in forum Jokes/Interweb Things
    Replies: 0
    Last Post: 18th August 2009, 05:57 PM
  4. Captive Portal
    By azrael78 in forum Internet Related/Filtering/Firewall
    Replies: 7
    Last Post: 1st June 2009, 03:34 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •