+ Post New Thread
Results 1 to 5 of 5
Wireless Networks Thread, Procurve vlan dhcp problem in Technical; Hi, been researching this but tried everything to no avail- my brain hurts so i am appealing for help! Got ...
  1. #1
    maark's Avatar
    Join Date
    Feb 2006
    Location
    leicester
    Posts
    483
    Thank Post
    90
    Thanked 78 Times in 69 Posts
    Rep Power
    39

    Procurve vlan dhcp problem

    Hi,
    been researching this but tried everything to no avail- my brain hurts so i am appealing for help!
    Got HP 5412zl core switch and testing vlans for use in the summer when i am going to create seperate vlans/subnets.
    Setup a new vlan called printers on 192.168.2.* range with IP address of 192.168.2.1 - setup new scope with 192.168.2.0 range - 192.168.2.1 is the default gateway for this scope - authorised and running.
    IP helper address of 10.56.132.8 (our dhcp server) is set in this vlan but it will not issue any addresses.
    I had this working before issuing addresses ok but had incorrectly set IP addresses for the new vlans on the other switches not realising they only need to be set on the core switch so deleted vlans and set up new ones. I do not know what has changed to stop it working - if I set a fixed address to laptop e.g. 192.168.2.2 with gateway of 192.168.2.1 then can connect from 192 to 10.56 network ok including dhcp server - so IP routing working ok.
    Any ideas wlecome! - do not know whether there is a problem in scope - but worked ok before and no error messages in event log or dhcp trffic not being forwarded - but why?
    Config of switch (have been trying with laptop connected to port D16 untagged to vlan 2)

    Running configuration:

    ; J8698A Configuration Editor; Created on release #K.13.25

    hostname "ProCurve Switch 5412zl"
    snmp-server location "Server room rack"
    web-management management-url ""
    time daylight-time-rule Western-Europe
    module 1 type J8702A
    module 2 type J8702A
    module 3 type J8702A
    module 4 type J8702A
    module 5 type J8702A
    module 6 type J8706A
    interface A23
    lacp Active
    exit
    interface A24
    lacp Active
    exit
    interface C23
    speed-duplex auto-1000
    exit
    interface D1
    lacp Active
    exit
    interface D2
    lacp Active
    exit
    interface D3
    lacp Active
    exit
    interface D4
    lacp Active
    exit
    interface D23
    lacp Active
    exit
    interface D24
    lacp Active
    exit


    ip default-gateway 10.56.132.1
    ip routing
    timesync sntp
    sntp unicast
    snmp-server community "public" Unrestricted
    snmp-server host 10.56.132.86 "public"
    snmp-server host 10.56.133.207 "public"
    snmp-server host 10.56.132.17 "public"
    snmp-server host 10.56.132.162 "public"
    snmp-server host 10.56.133.1 "public"
    snmp-server host 10.56.132.13 "public"
    vlan 1
    name "DEFAULT_VLAN"
    untagged A1-A24,B1-B24,C1-C24,D1-D12,D14-D24,E1-E24,F1-F24
    ip helper-address 10.56.132.8
    ip address 10.56.132.32 255.255.252.0
    no untagged D13
    exit
    vlan 2
    name "printers"
    untagged D13
    ip helper-address 10.56.132.8
    ip address 192.168.2.1 255.255.255.0
    tagged E14
    exit
    fault-finder bad-driver sensitivity high
    fault-finder bad-transceiver sensitivity high
    fault-finder bad-cable sensitivity high
    fault-finder too-long-cable sensitivity high
    fault-finder over-bandwidth sensitivity high
    fault-finder broadcast-storm sensitivity high
    fault-finder loss-of-link sensitivity high
    fault-finder duplex-mismatch-HDx sensitivity high
    fault-finder duplex-mismatch-FDx sensitivity high
    mirror 1 port A1
    sntp server priority 1 10.56.132.8
    no ip ssh
    ip route 0.0.0.0 0.0.0.0 10.56.132.1
    interface B6
    monitor all Both mirror 1
    exit
    spanning-tree
    password manager

    Cheers Mark

  2. #2

    Join Date
    May 2009
    Location
    Sheffield
    Posts
    34
    Thank Post
    0
    Thanked 6 Times in 6 Posts
    Rep Power
    15
    You have an IP helper address set on both VLANs including the VLAN the DHCP server is in, it should just be enabled on the other i.e. VLAN 2 - try removing it on VLAN 1 and see what happens. Also port D16 is untagged in VLAN 1 in that config although I'm assuming you've changed it since for testing

    I'll assume you're not putting that switch in to a production network with an unrestricted SNMP community of 'public' and no operator password yeah?

  3. Thanks to funkymunky from:

    maark (5th June 2009)

  4. #3
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    429
    Thank Post
    7
    Thanked 94 Times in 75 Posts
    Rep Power
    43
    I had an issue a bit like yours. After adding in vlans dhcp wouldn't give addresses out. I restart the switch and it worked! Worth a try.

  5. Thanks to andyrite from:

    maark (5th June 2009)

  6. #4
    maark's Avatar
    Join Date
    Feb 2006
    Location
    leicester
    Posts
    483
    Thank Post
    90
    Thanked 78 Times in 69 Posts
    Rep Power
    39
    Thanks for advice - I will restart switch when I get chance.
    Will have to look into snmp as well.
    Will post results,
    Mark

  7. #5
    maark's Avatar
    Join Date
    Feb 2006
    Location
    leicester
    Posts
    483
    Thank Post
    90
    Thanked 78 Times in 69 Posts
    Rep Power
    39
    Restarted switch and it works! So my config was ok after all - B*@*"y H**l - nothing mentioned about a restart required in HP documentation.
    Thanks for help on this



SHARE:
+ Post New Thread

Similar Threads

  1. MAC Based vlan allocation with procurve switches (11x)
    By AlexB in forum Wireless Networks
    Replies: 25
    Last Post: 21st September 2008, 06:56 PM
  2. Procurve VLAN help
    By meastaugh1 in forum Wireless Networks
    Replies: 8
    Last Post: 4th September 2008, 09:29 PM
  3. vlan and dhcp
    By Uraken in forum Wireless Networks
    Replies: 2
    Last Post: 17th March 2008, 12:18 PM
  4. Adding vLAN not working on HP Procurve
    By mrforgetful in forum Wireless Networks
    Replies: 21
    Last Post: 2nd March 2007, 12:53 PM
  5. VLAN's And DHCP
    By barryfl in forum Wireless Networks
    Replies: 1
    Last Post: 7th December 2006, 12:08 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •