+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16
Wireless Networks Thread, WSUS 3.0 in Technical; Hi I have just installed WSUS 3.0 on our Windows 2003 box, and the install has gone well, the server ...
  1. #1
    frognet1970's Avatar
    Join Date
    Nov 2008
    Location
    Norwich
    Posts
    20
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    WSUS 3.0

    Hi

    I have just installed WSUS 3.0 on our Windows 2003 box, and the install has gone well, the server is available functioning and syncing quite happily with Microsoft Update.

    I have followed the deployment instructions by linking a new GPO object to the domain and have checked that the clients are receiving the correct GPO when logging on. If I check the local registry it tells me that the clients are pointed to our WSUS server to receive updates.

    However I cannot see any client computers in the WSUS computer group on the server, so it reports its got nothing to push the updates to.

    Thanks in advance




    Kevin

  2. #2
    Messa's Avatar
    Join Date
    Dec 2006
    Location
    Wolverhampton
    Posts
    301
    Thank Post
    67
    Thanked 29 Times in 25 Posts
    Rep Power
    20
    If you have literally only just set this up, they will take some time to synchronize, there may also be an 'add in from active directory?'

  3. #3


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,657
    Thank Post
    350
    Thanked 789 Times in 710 Posts
    Rep Power
    344
    Hi Kevin,

    It takes a little while for them to turn up fella, often a day or so.

    I found that sitting there running "wuauclt /detectnow" on the client workstation a couple of times with reboots sped the process up. (Or it felt like it did!)

  4. #4

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,855
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    181
    Give it a couple of days, then see. WSUS is notorius for just needing to take its time over things, they'll show up soon

  5. #5

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,855
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    181
    Quote Originally Posted by Messa View Post
    there may also be an 'add in from active directory?'
    No, they just appear once they start to sync.

  6. #6

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    12,968
    Thank Post
    587
    Thanked 1,495 Times in 1,341 Posts
    Rep Power
    398
    You could force a sync from the client.

    How to really force WSUS client to sync with WSUS server - Weblog

    Ben

  7. Thanks to plexer from:

    tosh74 (9th March 2009)

  8. #7
    Messa's Avatar
    Join Date
    Dec 2006
    Location
    Wolverhampton
    Posts
    301
    Thank Post
    67
    Thanked 29 Times in 25 Posts
    Rep Power
    20
    Quote Originally Posted by powdarrmonkey View Post
    No, they just appear once they start to sync.
    Fair enough, been ages since I set ours up ;P

  9. #8

    Join Date
    Oct 2008
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Messa View Post
    If you have literally only just set this up, they will take some time to synchronize, there may also be an 'add in from active directory?'
    addin from active directory? tell me more!

  10. #9

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,855
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    181
    Quote Originally Posted by spall View Post
    addin from active directory? tell me more!
    See above, it doesn't exist.

  11. #10
    Messa's Avatar
    Join Date
    Dec 2006
    Location
    Wolverhampton
    Posts
    301
    Thank Post
    67
    Thanked 29 Times in 25 Posts
    Rep Power
    20
    Quote Originally Posted by spall View Post
    addin from active directory? tell me more!
    My Bad!!, Stop bullying me :P

  12. #11

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,390
    Thank Post
    797
    Thanked 1,588 Times in 1,391 Posts
    Blog Entries
    10
    Rep Power
    427
    Have all your clients been syspreped?

  13. #12
    Crispin's Avatar
    Join Date
    Dec 2008
    Location
    Essex
    Posts
    361
    Thank Post
    76
    Thanked 28 Times in 25 Posts
    Rep Power
    19
    Have all your clients been syspreped?
    This is a good point to make. A few of our images must have had GPO's applied to them, so when deploying, they all had the same wsus ID.
    If you have used computer groups for the different rooms, and are finding that only 1 PC is showing up or none at all, try deleting the windows update registry entry.
    From memory I think it's: localmachine/software/microsoft/windows/windowsupdate

    Then you can use: "wuauclt.exe /detectnow /resetauthorization" in the run box.

    This will give all your machines new IDs. Worked a treat for me.

  14. #13

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,476
    Thank Post
    1,305
    Thanked 469 Times in 306 Posts
    Blog Entries
    6
    Rep Power
    198
    When I set up wsus, the clients had a bad dns setup, and were unable to resolve the WSUS server by name. As soon as I sorted that, they all started appearing.

    Make sure you can resolve the WSUS server, ping it by name etc.

  15. #14

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,390
    Thank Post
    797
    Thanked 1,588 Times in 1,391 Posts
    Blog Entries
    10
    Rep Power
    427
    Quote Originally Posted by Crispin View Post
    This is a good point to make. A few of our images must have had GPO's applied to them, so when deploying, they all had the same wsus ID.
    If you have used computer groups for the different rooms, and are finding that only 1 PC is showing up or none at all, try deleting the windows update registry entry.
    From memory I think it's: localmachine/software/microsoft/windows/windowsupdate

    Then you can use: "wuauclt.exe /detectnow /resetauthorization" in the run box.

    This will give all your machines new IDs. Worked a treat for me.
    To sort that problem out put this into a batch file and run it on the machines

    Code:
    reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Win dowsUpdate /v AccountDomainSid /f
    reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Win dowsUpdate /v PingID /f
    reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Win dowsUpdate /v SusClientId /f
    cls
    @echo Triggering detection after resetting WSUS client identity
    net stop wuauserv
    net start wuauserv
    wuauclt /resetauthorization /detectnow

  16. Thanks to FN-GM from:

    Crispin (10th March 2009)

  17. #15

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    However I cannot see any client computers in the WSUS computer group on the server, so it reports its got nothing to push the updates to.
    As already mentioned, it can take considerable time to download WSUS updates depending on what product(s) you specified, but also what types of updates you specified too.

    So long as you've configured your GPOs correctly, clients should start appearing in the next day or so. If you see clients appearing then disappearing, this is a typical symptom of machines using the same WSUS SID. The Windows and WSUS SIDs are two separate entries for your reference.

    As for 'add in from active directory?' this isn't as daft as it sounds. You did have to upload a WSUS ADM template on Windows 2000 Server all those years ago. Thankfully Windows Server 2003/2008 is much more up-to-date.

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 3
    Last Post: 21st February 2008, 08:50 AM
  2. WSUS
    By DSapseid in forum Windows
    Replies: 10
    Last Post: 22nd June 2007, 12:05 PM
  3. WSUS on DC
    By johnkay21 in forum Windows
    Replies: 6
    Last Post: 24th May 2007, 08:23 AM
  4. WSUS ?
    By mac_shinobi in forum General Chat
    Replies: 19
    Last Post: 20th April 2007, 09:42 AM
  5. Replies: 1
    Last Post: 8th November 2006, 09:57 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •