+ Post New Thread
Results 1 to 9 of 9
Wireless Networks Thread, RDP stops working after XP sp3 in Technical; Having just used RDP to update a handful of machines from home Installed Xp SP3 and did recommended restart now ...
  1. #1

    Join Date
    May 2008
    Location
    York
    Posts
    515
    Thank Post
    22
    Thanked 49 Times in 46 Posts
    Rep Power
    24

    RDP stops working after XP sp3

    Having just used RDP to update a handful of machines from home
    Installed Xp SP3 and did recommended restart now cant get rdp to them again.

    Looks like it turns firewall back on again (goggled the error)

    Any ideas that don't involve driving 30 miles to work would be gratefully received

  2. #2

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,572 Times in 1,252 Posts
    Rep Power
    340
    You have two choices really. Either by create a firewall exception or disable the firewall altogether. Generally speaking if all your workstations are on a large network, then chances are they're behind a router too (which is a firewall in itself).

    Computer Config > Admin Templates > Network > Network Connections > Firewall > Domain Profile

    Windows Firewall: Protect all network connections - Disable

    On a few machines try running the following command from the Run menu:

    Code:
    gpupdate /force
    If you'd rather make an exception (which is a little more complex, let me know).

  3. #3

    Join Date
    May 2008
    Location
    York
    Posts
    515
    Thank Post
    22
    Thanked 49 Times in 46 Posts
    Rep Power
    24

    firewall

    We have a group policy that disables the firewall
    I think sp3 has over written this setting
    cant do gpupdate without driving 30 miles (was hopping the gpupdate would have happened in the 90min timeframe)

  4. #4

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,572 Times in 1,252 Posts
    Rep Power
    340
    Are you sure Remote Desktop is enabled by GPO too?

    Computer Config > Admin Templates > Windows Components > Terminal Services

    Allow users to connect remotely using Terminal Services - Enable

    When updating GPOs it's recommended machines are restarted to take effect. I presume you can still RDP into your server?

  5. #5

    Join Date
    May 2008
    Location
    York
    Posts
    515
    Thank Post
    22
    Thanked 49 Times in 46 Posts
    Rep Power
    24

    rdp

    The Windows policy that allows you to disable the Internet Connection Firewall for all users including administrators is at the following location in the Windows policy tree:
    Local Computer Policy/Computer Configuration/Administrative Templates/Network/Network Connections

    On the right hand side, you will see "Prohibit use of Internet Connection Firewall on your DNS Domain." That's where you get to play with it and the of course run the GPUPDATE /FORCE""

    I previously had only the GP set at "Computer Configuration/Administrative Templates/Network/Network Connections/Windows Firewall/Domain Profile/Windows Firewall: Protect all network connections" as disabled, which worked fine with Service Pack 2, but apparently Service Pack 3 ignores this setting.
    so did an upgrade to sp3 ran the gpupdate before restarting and its worked on that one

    Will wait and see if the others become available after the group policy is updated.

    will report back results later

  6. #6
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,966
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46
    SP3 is just rolled up patches, the firewall is enabled if you upgrade from SP1, or earlier, invoking SP2's party trick.

    Doesn't help with your problem but just thought i'd mention it!

  7. #7

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,225
    Thank Post
    874
    Thanked 2,717 Times in 2,302 Posts
    Blog Entries
    11
    Rep Power
    780
    You can restart the machines remotely which will help apply the policies that you have reconfigured to allow access. It should also help the machines 'clear their heads' as sometimes they are a little screwy after the first reboot from a SP install.

    cmd: shutdown -r -f -m \\computername

    From a different machine that is logged in as a domain admin ie a server.

  8. #8

    Join Date
    May 2008
    Location
    York
    Posts
    515
    Thank Post
    22
    Thanked 49 Times in 46 Posts
    Rep Power
    24

    cant shutdown

    You cant shutdown as with the firewall on you cant do anything
    no ping
    no rdp
    no remote registry

    Google throws up a couple of possibilities one is Nvidia driver problem
    suggestion roll back to previous version of driver.

    and the

    I previously had only the GP set at "Computer Configuration/Administrative Templates/Network/Network Connections/Windows Firewall/Domain Profile/Windows Firewall: Protect all network connections" as disabled, which worked fine with Service Pack 2, but apparently Service Pack 3 ignores this setting.
    so did an upgrade to sp3 ran the gpupdate before restarting and its worked on that one

    after i realized problem the second fix and a gpupdate /force before the restart at end of sp3 install has kept the 4 machines i did later on working so that seams to be the fix

    I thought the broken ones would now be ok as a gpupdate happens evry Min's maximum but they are still not working on rdp.

    Just had a call from work and the owners of the afected mahines have logged on ok but still got firewall on.
    I will get them to do a resart at lunch time se if that fixes it

  9. #9
    GlennT's Avatar
    Join Date
    Sep 2006
    Location
    Zummmerzet!
    Posts
    249
    Thank Post
    19
    Thanked 17 Times in 16 Posts
    Rep Power
    20
    Would SpecOps work Specops Gpupdate - Remote gpupdate / Wake on lan (WOL) / restart / shutdown ?
    We use it to force a gpupdate rather than manually logging onto each machine.

SHARE:
+ Post New Thread

Similar Threads

  1. RDP shortcuts not working
    By firefighting in forum Wireless Networks
    Replies: 5
    Last Post: 4th June 2008, 06:15 PM
  2. Metro electro and Logo not working with XP SP3
    By maschenazi in forum Windows
    Replies: 2
    Last Post: 22nd May 2008, 02:27 PM
  3. RDP to a win2003 server not working
    By FatBoy in forum Windows
    Replies: 11
    Last Post: 6th February 2008, 10:38 AM
  4. Tip: Flash app' stops and won't continue
    By contink in forum Windows
    Replies: 0
    Last Post: 19th January 2008, 05:52 PM
  5. Laser cutter stops when computer is locked
    By meastaugh1 in forum Windows
    Replies: 5
    Last Post: 3rd October 2007, 09:07 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •