+ Post New Thread
Results 1 to 10 of 10
Wireless Networks Thread, Zero One Helpdesk in Technical; Hi I am having a lot of fun trying to sort out LDAP authentication. I think I have managed to ...
  1. #1
    Scotmk's Avatar
    Join Date
    May 2007
    Location
    Milton Keynes
    Posts
    277
    Thank Post
    1
    Thanked 4 Times in 3 Posts
    Rep Power
    16

    Zero One Helpdesk

    Hi

    I am having a lot of fun trying to sort out LDAP authentication. I think I have managed to get the program to see the server, but I get an error with the user account. The error is:

    Warning: ldap_search() [function.ldap-search]: Search: No such object in D:\www\st-helpdesk\common\common.php on line 167
    I am not totally sure where to llok for this one, I downloaded the ldp tool thing, and I cannot see the info.

    Can anyone shed any light?.

    My LDAP settings are:

    ldap_host = "myserverip"
    ldap_domain = "mydomain"
    ldap_binddn = "administrator@mydomain"
    ldap_bindpwd = "adminpassword"
    ldap_rootdn = "CN=ogs,DC=mydomain,DC=internal"
    ldap_searchattr = "DC=mydomain,DC=internal"
    ldap_fname = "givenname"
    ldap_lname = "sn"
    ldap_uname = "samaccountName"
    ldap_email_add = "mail"
    ldap_office = "l"
    ldap_phone = "telephonenumber"
    ldap_context = "DC=mydomain,DC=internal"
    Thanks

    Scot

  2. #2

    Hightower's Avatar
    Join Date
    Jun 2008
    Location
    Cloud 9
    Posts
    4,920
    Thank Post
    494
    Thanked 690 Times in 444 Posts
    Rep Power
    241
    Did you figure this? I'm having some problems setting up ldap on this.

    Thanks,

  3. #3

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,675
    Thank Post
    861
    Thanked 650 Times in 431 Posts
    Rep Power
    499
    This is my LDAP Config..

    auth_method = "AD"
    ldap_host = "my_domain_controller.school.internal"
    ldap_domain = "school.internal"
    ldap_binddn = "administrator@school.internal"
    ldap_bindpwd = "admin_password"
    ldap_rootdn = "OU=school_OU,DC=school,DC=internal"
    ldap_searchattr = "sAMAccountName"
    ldap_fname = "givenname"
    ldap_lname = "sn"
    ldap_uname = "samaccountname"
    ldap_email_add = "mail"
    ldap_office = "physicaldeliveryofficename"
    ldap_phone = "telephonenumber"
    ldap_context = "sAMAccountName"

    Note the highlighted section!

  4. Thanks to Gatt from:

    Hightower (22nd October 2008)

  5. #4

    Hightower's Avatar
    Join Date
    Jun 2008
    Location
    Cloud 9
    Posts
    4,920
    Thank Post
    494
    Thanked 690 Times in 444 Posts
    Rep Power
    241
    Looks like it worked. Now I get this though:

    Cannot create new user! ... This user does not have an 'Email' LDAP value or check 'LDAP Email Attribute' in the OneOrZero Task Management System Server Settings

    Changed the email value to 'givenname' to test and now can log in. But why would I get this error? The email value is filled in within active directory

  6. #5

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,804
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    Are you using Exchange? I don't think the AD LDAP field for your Exchange email address is the same as the 'mail' field.

  7. #6

    Hightower's Avatar
    Join Date
    Jun 2008
    Location
    Cloud 9
    Posts
    4,920
    Thank Post
    494
    Thanked 690 Times in 444 Posts
    Rep Power
    241
    No - our email system is external. Another thing: Is it possible to add two locations to ldap_rootdn because otherwise the students will have access which I don't want.

    I've tried OU=Location1,DC=school,DC=internal;OU=Location2,DC=school,DC=internal

    but that doesn't work.

    Thanks for the help

  8. #7

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,675
    Thank Post
    861
    Thanked 650 Times in 431 Posts
    Rep Power
    499
    I think email is a required field - you need the email field populated in the user's AD properties
    As for 2 locations - i think you can by seperating them with Semi-Colons but not sure..
    If Staff and Pupils are in same AD, then easiest was is to create OU's for staff and pupils then set the STAFF OU as the rootdn
    Last edited by Gatt; 22nd October 2008 at 09:57 AM.

  9. #8

    Hightower's Avatar
    Join Date
    Jun 2008
    Location
    Cloud 9
    Posts
    4,920
    Thank Post
    494
    Thanked 690 Times in 444 Posts
    Rep Power
    241
    It's a CC3 network so we have OU's for Non-teaching, teaching, system admins and students. If I add the OU above it opens up access to the students as everyone falls under the TCS OU

    I need to add the non-teaching and teaching - semi-colon didn't work.

  10. #9

    Hightower's Avatar
    Join Date
    Jun 2008
    Location
    Cloud 9
    Posts
    4,920
    Thank Post
    494
    Thanked 690 Times in 444 Posts
    Rep Power
    241
    The mail part is working now - Just need to figure out how to add two OU's.

    I've tried adding a group like CN=Group name,OU=Location,DC=School,DC=Internal but this didn't work either.

  11. #10

    Join Date
    Jan 2009
    Location
    Cramlington
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    One Or Zero Ldap Problems

    I have fully installed One Or Zero with no problems but im having some problems with LDAP, I have successfully got LDAP to work but I need a way to add multiple OUs like in Moodle. As we need to have several ou`s across domain and A sub domain.

    below is a list of the OU's I have need to add how would i do it?

    OU=Admin Users,DC=nsnet,DC=net
    OU=S Teachers,DC=nsnet,DC=net
    OU=Teachers,DC=nsnet,DC=net
    OU=Students,DC=nsnet,DC=net
    OU=S Teachers,DC=Juniorschool,DC=nsnet,DC=net
    OU=Teachers,DC=Juniorschool,DC=nsnet,DC=net
    OU=Students,DC=Juniorschool,DC=nsnet,DC=net

    chris

SHARE:
+ Post New Thread

Similar Threads

  1. What do you look for in a helpdesk?
    By bizzel in forum Coding
    Replies: 19
    Last Post: 23rd March 2011, 04:41 PM
  2. My Little Helpdesk help needed
    By Grommit in forum Network and Classroom Management
    Replies: 6
    Last Post: 21st April 2008, 03:39 PM
  3. My Little Helpdesk v0.9.6b
    By pmassingham in forum Downloads
    Replies: 5
    Last Post: 8th April 2008, 03:00 PM
  4. One or Zero Helpdesk
    By wesleyw in forum How do you do....it?
    Replies: 8
    Last Post: 18th October 2006, 08:30 AM
  5. helpdesk show
    By russdev in forum General Chat
    Replies: 9
    Last Post: 23rd March 2006, 01:05 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •