+ Post New Thread
Results 1 to 10 of 10
Wireless Networks Thread, Cisco WLAN Controller not pushing out DHCP addresses, what else could it be? in Technical; On our Cisco WLAN Controller web interfaces, in Controller > Interfaces, I have made a new interface with these settings: ...
  1. #1

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Cisco WLAN Controller not pushing out DHCP addresses, what else could it be?

    On our Cisco WLAN Controller web interfaces, in Controller > Interfaces, I have made a new interface with these settings:

    VLAN Identifier 202
    IP Address 172.16.202.1
    Netmask 255.255.255.0
    Gateway 172.16.202.254
    Primary DHCP Server 172.16.100.3
    Secondary DHCP Server 172.16.100.2
    Port: LAG

    I've also made a new WLAN and assigned it to the above interface. I have saved changes. But our wireless devices, although they seem to authenticate with the WLAN fine, they always get stuck on "obtaining DHCP address", so it seems the WLAN Controller isn't pushing out DHCP addresses to our devices.

    We do have a DHCP scope for the above in Windows Server 2008 R2 and everything there seems fine.

    If I connect a device with a static address (e.g. 172.16.202.10), it will connect. Stuck on what to do
    Last edited by nLinked; 29th November 2012 at 09:25 AM.

  2. #2

    Join Date
    Dec 2009
    Location
    Woking
    Posts
    94
    Thank Post
    0
    Thanked 17 Times in 17 Posts
    Rep Power
    11
    you will need to add an ip-helper address to VLAN202 on whichever devices is doing the routing in your network. As it stands VLAN202 has no way of sending the DHCP requests to a server in the other VLAN.

  3. #3

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Thanks for your reply. We do seem to have that in our config below:

    interface Vlan202
    description WIRELESS_TABLETS
    ip address 172.16.202.253 255.255.255.0
    ip helper-address 172.16.100.1
    ip helper-address 172.16.100.2
    ip helper-address 172.16.100.3
    ip helper-address 172.16.100.40
    ip helper-address 172.16.100.44
    ip pim dense-mode
    standby priority 110
    standby name WIRELESS_TABLETS
    standby 202 ip 172.16.202.254
    standby 202 priority 105
    standby 202 preempt





    We also have:

    interface GigabitEthernet11/5
    description ***WiSM_1_WLC1***
    switchport
    switchport trunk encapsulation dot1q
    switchport mode trunk
    no ip address
    no snmp trap link-status
    no cdp enable
    channel-group 202 mode on
    !
    interface GigabitEthernet11/6
    description ***WiSM_1_WLC1***
    switchport
    switchport trunk encapsulation dot1q
    switchport mode trunk
    no ip address
    no snmp trap link-status
    no cdp enable
    channel-group 202 mode on
    !
    interface GigabitEthernet11/7
    description ***WiSM_1_WLC1***
    switchport
    switchport trunk encapsulation dot1q
    switchport mode trunk
    no ip address
    no snmp trap link-status
    no cdp enable
    channel-group 202 mode on
    !
    interface GigabitEthernet11/8
    description ***WiSM_1_WLC1***
    switchport
    switchport trunk encapsulation dot1q
    switchport mode trunk
    no ip address
    no snmp trap link-status
    no cdp enable
    channel-group 202 mode on





    That all looks right to me unless I'm mistaken?

    I have noticed we have the following for another VLAN but not for VLAN 202. Do you think we'll need it for 202 too?:

    interface GigabitEthernet11/9
    switchport
    switchport access vlan 201
    switchport mode access
    no ip address
    no snmp trap link-status
    no cdp enable
    Last edited by nLinked; 29th November 2012 at 10:44 AM.

  4. #4

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,714
    Thank Post
    269
    Thanked 1,116 Times in 1,012 Posts
    Rep Power
    345
    I have a feeling with Cisco controller there is two places to set the DHCP server, with one being a global setting which affects all of the ssid's, I may be wrong.

  5. #5

    Join Date
    Dec 2009
    Location
    Woking
    Posts
    94
    Thank Post
    0
    Thanked 17 Times in 17 Posts
    Rep Power
    11
    from the wireless device with the static IP can you ping the DHCP server?

  6. #6

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Quote Originally Posted by paulfinlay View Post
    from the wireless device with the static IP can you ping the DHCP server?
    OK just tried this and although it connects to wifi fine with the static IP, pings are failing to the DHCP server (the DHCP server does accept pings normally and I can ping it from a wired workstation fine).

  7. #7

    Join Date
    Dec 2009
    Location
    Woking
    Posts
    94
    Thank Post
    0
    Thanked 17 Times in 17 Posts
    Rep Power
    11
    sounds like VLAN202 isn't fully connected across the network. You need to try and trace where it's failing, i'd start by pinging 172.16.202.254 from the DHCP server to ensure routing is working, then try pinging the controller interface 172.16.202.1 from both the DHCP server and then the static client.

  8. #8

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Thanks, you're right, none of those pings are successful! None.

  9. #9

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    On the Cisco switch if I do show ip route, I can immediately see all the VLANs in a list but not the 202 one. This must be the problem so it's probably a routing issue as you say. But I thought we did add the VLAN. Going to have to look at commands for getting our 202 vlan into there...

  10. #10

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Thanks all for your replies. We've managed to fix it, it was related to the VLAN not appearing when doing show ip route.

    The solution was to create the VLAN in this way:

    switch# configure terminal
    switch(config)# vlan 202
    switch(config-vlan)# name wirelesstablets
    switch(config-vlan)# state active
    switch(config-vlan)# no shutdown
    show ip route (to confirm)

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 2
    Last Post: 3rd February 2011, 03:42 PM
  2. DHCP not farming out address, randomly
    By synaesthesia in forum Wireless Networks
    Replies: 9
    Last Post: 2nd May 2009, 02:04 PM
  3. DHCP not giving out second DNS to XP
    By ZeroHour in forum Windows Server 2008
    Replies: 9
    Last Post: 28th January 2009, 11:05 AM
  4. DHCP not handing out spare leases
    By stratisphere in forum Wireless Networks
    Replies: 24
    Last Post: 26th January 2009, 04:42 PM
  5. Centrinity FirstClass not working with DHCP IP Address?
    By CM786 in forum Wireless Networks
    Replies: 4
    Last Post: 14th December 2006, 06:14 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •