Something I have struggled with for some time is FTP uploads through ISA Server... hence I thought I would share my solution.

You will no doubt have a firewall rule that should alow FTP. Open the properties of this rule and select the Protocols tab... you will notice a Filtering button at the lower-right of the dialogue. Click this button and select Configure FTP to be presented with a single option... uncheck this and apply the settings.

Easy when you know how