+ Post New Thread
Results 1 to 15 of 15
Wired Networks Thread, Lanschool plus HP Procurve VLAN environment in Technical; I've been smashing my head against my desk over this all morning. HP Procurve environment with a 5412zl at the ...
  1. #1

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74

    Lanschool plus HP Procurve VLAN environment

    I've been smashing my head against my desk over this all morning.

    HP Procurve environment with a 5412zl at the core.

    VLANs... "teacher" PCs are on a different subnet to the "student" PCs.

    I understand that Lanschool should work if you configure it with directed broadcasts - I've done this.

    I've also enabled the following commands on my core switch:

    ip directed-broadcast
    ip udp-bcast-forward

    Yet still it doesn't work.

    Has anyone else got this working in a similar environment?

    Cheers,

    Ant

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,096
    Thank Post
    891
    Thanked 1,742 Times in 1,502 Posts
    Blog Entries
    12
    Rep Power
    456
    Please find the attached hope it helps. These came from LanSchool themselves.
    Attached Files Attached Files

  3. #3

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74
    Thanks @FN-GM, those are the docs I've used as a reference. But I'm still stuck... :-/

  4. #4

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74
    Bumpity bump.

    Anyone else?!

  5. #5

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74
    Sorted it.

    Needed to put in the following command for the originating VLAN:

    ip forward-protocol udp x.x.x.x 1053
    ip forward-protocol udp x.x.x.x 796

    Where x.x.x.x is the broadcast address for the destination VLAN...

    NB. It helps a lot if you use the correct broadcast address. D'oh.

  6. Thanks to pantscat from:

    FN-GM (14th June 2012)

  7. #6

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,096
    Thank Post
    891
    Thanked 1,742 Times in 1,502 Posts
    Blog Entries
    12
    Rep Power
    456
    Quote Originally Posted by pantscat View Post
    Sorted it.

    Needed to put in the following command for the originating VLAN:

    ip forward-protocol udp x.x.x.x 1053
    ip forward-protocol udp x.x.x.x 796

    Where x.x.x.x is the broadcast address for the destination VLAN...

    NB. It helps a lot if you use the correct broadcast address. D'oh.
    Does anyone know the equivalent for Cisco stuff please?

  8. #7

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74
    It should be pretty similar - but ever so subtly different!

    Do you need to get it working for multicast or directed broadcast?

  9. #8

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,096
    Thank Post
    891
    Thanked 1,742 Times in 1,502 Posts
    Blog Entries
    12
    Rep Power
    456
    Quote Originally Posted by pantscat View Post
    It should be pretty similar - but ever so subtly different!

    Do you need to get it working for multicast or directed broadcast?
    @pantscat multicast if we can. Thanks

  10. #9

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74
    I think the "ip pim" command is what you need - but I'm not sure of the exact syntax required.

    This might help though: Cisco IOS IP Multicast Command Reference - ip pgm host through ip pim version* [Support] - Cisco Systems

  11. #10

    Join Date
    Nov 2011
    Location
    Southampton
    Posts
    23
    Thank Post
    4
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I've got the same problem as pantscat but with a differnce of 'it used to work'. I am completely confused as to why it's now not showing anything across the vlans. The only thing I did to possibly affect this was to upgrade the FW of the core over the summer but using Lanschools own tools, I can test the UDP to a pupil machine and it seems to work. Just no show in the main console screen.

    Of course, within the same vlan it is fine, just between them it fails. Ideas? It was so useful too!

  12. #11

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74
    @MrBrow - what's the config on your core switch(es)?

  13. #12

    Join Date
    Nov 2011
    Location
    Southampton
    Posts
    23
    Thank Post
    4
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks @pantscat Config below (i've ripped some of the non-useful parts out - just port settings) As mentioned, the only change I can think I made over the summer was to upgrade the FW on the core and some of the secondary switches (not all). The config will have remained unedited by myself.

    IP Direct Broadcast is allowed so I haven't added any extra ports for this as since it worked before, my theory is that it should work now. I did upgrade to Lanschool 7.7 at some point recently but 7.6 isn't working either.

    I have go around the crux of the issue now by setting up the Lanschool Connection Server which is working but since it doesnt have all the features yet, it isn't the most ideal solution.



    Any thoughts more than welcome



    Running configuration:

    ; J8697A Configuration Editor; Created on release #K.15.07.0008
    ; Ver #02:1b.2f:36

    hostname "SWSvrRm-1"
    module 1 type J8702A
    module 2 type J8702A
    module 3 type J8706A
    interface A1
    no power-over-ethernet
    #
    #
    #
    #
    #
    #
    #
    #
    #
    #
    #
    interface B24
    no power-over-ethernet
    exit
    trunk B22,B24 Trk1 Trunk
    trunk B19,C6 Trk2 Trunk
    trunk C13-C14 Trk3 Trunk
    trunk C3,C7 Trk4 Trunk
    trunk C2,C15 Trk5 Trunk
    trunk B1-B3 Trk6 LACP
    trunk B4-B6 Trk7 LACP
    trunk B21,B23 Trk8 Trunk
    ip default-gateway 10.0.0.1
    ip routing
    ip directed-broadcast
    ip zero-broadcast
    vlan 1
    name "DEFAULT_VLAN"
    untagged A1-A3,A5-A9,A13-A24,B13,B15,B18,C1,C4-C5,C8-C11,C16-C24,Trk1-Trk5,Trk8
    ip helper-address 10.0.2.51
    ip address 10.0.6.1 255.255.0.0
    tagged C12,Trk6-Trk7
    no untagged A4,A10-A12,B7-B12,B14,B16-B17,B20
    exit
    vlan 217
    name "ADM"
    untagged B17,B20
    ip helper-address 10.0.2.51
    ip helper-address 10.0.2.61
    ip address 10.217.123.254 255.255.255.0
    tagged B10,C5,C9,Trk1-Trk8
    exit
    vlan 20
    name "STN"
    ip helper-address 10.0.2.51
    ip helper-address 10.0.2.61
    ip address 10.1.20.254 255.255.255.0
    tagged B15,C1,C4-C5,C16,Trk1-Trk4,Trk6-Trk8
    ip directed-broadcast
    exit
    vlan 21
    name "DFT"
    ip helper-address 10.0.2.51
    ip helper-address 10.0.2.61
    ip address 10.1.21.254 255.255.255.0
    tagged C1,C4-C5,C8-C9,C16,Trk1-Trk8
    exit
    vlan 8
    name "CCTV"
    ip address 10.1.8.254 255.255.255.0
    tagged C1,C4,Trk1,Trk4,Trk6-Trk8
    exit
    vlan 3
    name "NAS"
    qos priority 1
    ip address 10.1.3.254 255.255.255.0
    tagged C9,Trk4
    jumbo
    exit
    vlan 26
    name "LFP_WIRELESS"
    ip helper-address 10.0.2.51
    ip address 10.1.26.254 255.255.255.0
    tagged C1,C10-C11
    exit
    vlan 5
    name "PRN"
    ip helper-address 10.0.2.51
    ip address 10.1.5.254 255.255.255.0
    tagged C1,C4-C5,C8-C9,C16,Trk1-Trk8
    exit
    vlan 100
    name "WIRELESS"
    untagged C12
    ip helper-address 10.0.2.51
    ip address 10.1.100.254 255.255.255.0
    tagged C1,C10-C11,Trk1
    exit
    vlan 40
    name "iSCSI"
    untagged B7-B12,B14,B16
    no ip address
    jumbo
    exit
    vlan 41
    name "HyperVCluster"
    untagged A4,A10
    no ip address
    exit
    vlan 247
    name "Ext"
    untagged A11-A12
    tagged Trk6-Trk7
    no ip address
    exit
    power-over-ethernet pre-std-detect
    timesync sntp
    sntp unicast
    sntp server priority 1 10.0.2.51
    no telnet-server
    web-management ssl
    ip route 0.0.0.0 0.0.0.0 10.0.0.1
    router rip
    redistribute connected
    enable
    exit
    snmp-server community "public" unrestricted
    snmp-server host 10.0.28.70 community "public"
    snmp-server host 10.0.2.31 community "public"
    snmp-server location "Server Room, ROSLA"
    spanning-tree Trk1 priority 4
    spanning-tree Trk2 priority 4
    spanning-tree Trk3 priority 4
    spanning-tree Trk4 priority 4
    spanning-tree Trk5 priority 4
    spanning-tree Trk6 priority 4
    spanning-tree Trk7 priority 4
    spanning-tree Trk8 priority 4
    vlan 20
    ip rip 10.1.20.254
    ip rip 10.1.20.254 receive v1-or-v2
    ip rip 10.1.20.254 send v1-compatible-v2
    exit

  14. #13

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74
    @MrBrow - I'll have a look at this and get back to you! Need more coffee to make sense of it...

  15. #14

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74
    Right - I've had a chance to have a quick look.

    Try using the "ip udp-bcast-forward" command in your config.

    You may also need to tell the switch where to forward the broadcasts, but we'll worry about that if this doesn't work!

  16. #15
    Duke5A's Avatar
    Join Date
    Jul 2010
    Posts
    809
    Thank Post
    83
    Thanked 132 Times in 115 Posts
    Blog Entries
    8
    Rep Power
    32
    If you don't want to mess around with switch configs you can give the Connection Server a try. I loaded it on one of our apps servers and it works great. Didn't want to enable multicast forwarding on our wireless teacher VLAN.

SHARE:
+ Post New Thread

Similar Threads

  1. vlan design issue on HP procurve 5406zl
    By puliramesh in forum Wireless Networks
    Replies: 4
    Last Post: 10th August 2010, 06:23 AM
  2. Routing between VLANs on HP ProCurve 4108GL Switch
    By robknowles in forum Wireless Networks
    Replies: 12
    Last Post: 1st June 2010, 08:12 AM
  3. student VLAN setup HP procurve 2510/24
    By schoolittech in forum Network and Classroom Management
    Replies: 2
    Last Post: 16th October 2009, 10:02 AM
  4. Adding vLAN not working on HP Procurve
    By mrforgetful in forum Wireless Networks
    Replies: 21
    Last Post: 2nd March 2007, 11:53 AM
  5. Changing port vLANs on an HP ProCurve switch
    By MrDylan in forum Hardware
    Replies: 6
    Last Post: 9th March 2006, 03:13 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •