+ Post New Thread
Results 1 to 5 of 5
Wired Networks Thread, static route between procurve core switches in Technical; Hi, I have recently started working woth L3 HP switches and I would like ask for your advice. We have ...
  1. #1

    Join Date
    May 2012
    Location
    London
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    static route between procurve core switches

    Hi,
    I have recently started working woth L3 HP switches and I would like ask for your advice. We have to core switches directly connected which support multiple vlans, routing and ospf. We are planning to set up a 3rd new switch which will support vlans with ip addresses that are a subset of the ip addresses of one of the existing vlans i.e.
    sw1- several vlans
    sw2- vlans with ip addresses 10.32.0.0 255.255.224.0
    sw3- vlans with ip addresses 10.32.160.0 255.255.252.0
    sw2 and sw3 connected to sw1
    how can I create a static route so that sw1 will decide the correct route in each case:
    something is destined to 10.32.160.3 will go to sw3
    something destined to 10.32.0.3 will go to sw2

    thank you in advance

  2. #2

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,800
    Thank Post
    272
    Thanked 1,135 Times in 1,031 Posts
    Rep Power
    349
    If they are connected together and the vlan's are setup correctly it will route it by itself.

  3. #3

    Join Date
    Jul 2010
    Posts
    106
    Thank Post
    0
    Thanked 14 Times in 14 Posts
    Rep Power
    11
    if you are using ospf on all the switches you wouldn't need a static route for this, the switches would work it out on its own

  4. #4

    Join Date
    May 2012
    Location
    London
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi again,
    I've been trying to work this out with ospf and I am doing some tests with spare switches we have but so far the results are not the expected. I cannot ping ip addresses on the 2 switches sharing the same subnets, the main switch does not seem to know the route. Below, I am copying the ospf settings on the 3 switches hoping you will see anything wrong and help me. The main and the second switch they communicate fine already.
    main switch:
    router ospf
    area 10.8.0.0 range 10.8.0.0 255.255.0.0 type summary
    area 10.10.0.0 range 10.10.0.0 255.255.0.0 type summary
    area 10.12.0.0 range 10.12.0.0 255.255.0.0 type summary
    area 10.14.0.0 range 10.14.0.0 255.255.0.0 type summary
    area 10.16.0.0 range 10.16.0.0 255.255.0.0 type summary
    area 10.18.0.0 range 10.18.0.0 255.255.0.0 type summary
    area 172.20.0.0
    area 172.20.12.0 range 172.20.12.0 255.255.255.0 type summary
    area 172.20.14.0 range 172.20.14.0 255.255.255.0 type summary
    area 172.20.16.0 range 172.20.16.0 255.255.255.0 type summary
    area 172.20.18.0 range 172.20.18.0 255.255.255.128 type summary
    area 172.20.20.0 range 172.20.20.0 255.255.255.0 type summary
    area 172.20.21.0
    area 192.168.1.0
    area backbone
    redistribute connected
    redistribute static
    exit
    router pim
    rp-address 192.168.255.254 224.0.0.0 240.0.0.0
    rp-candidate
    rp-candidate source-ip-vlan 901
    rp-candidate group-prefix 224.0.0.0 240.0.0.0
    rp-candidate hold-time 150 priority 200
    exit
    interface loopback 1
    ip address 192.168.255.254
    ip ospf 192.168.255.254 area backbone
    exit

    vlan 80
    ip ospf 10.8.10.1 area 10.8.0.0
    ip pim-sparse
    ip-addr any
    exit
    exit
    vlan 81
    ip pim-sparse
    ip-addr any
    exit
    exit
    vlan 90
    ip pim-sparse
    ip-addr any
    exit
    exit ........
    several vlans
    .....
    vlan 901
    ip ospf 192.168.255.1 area backbone
    ip pim-sparse
    ip-addr any
    exit
    exit
    vlan 902
    ip ospf 192.168.255.5 area backbone
    ip pim-sparse
    ip-addr any
    exit
    exit
    vlan 903
    ip ospf 192.168.255.9 area backbone
    ip pim-sparse
    ip-addr any
    exit
    exit
    vlan 904
    ip ospf 192.168.255.13 area backbone
    ip pim-sparse
    ip-addr any
    exit
    exit
    vlan 905
    ip ospf 192.168.255.17 area backbone
    ip ospf 192.168.255.17 priority 100
    ip pim-sparse
    ip-addr any
    exit
    exit
    vlan 906
    ip ospf 192.168.255.21 area backbone
    ip ospf 192.168.255.21 priority 100
    ip pim-sparse
    ip-addr any
    exit
    exit
    vlan 907
    ip ospf 192.168.255.25 area backbone
    ip ospf 192.168.255.25 priority 100
    ip pim-sparse
    ip-addr any
    exit
    exit
    vlan 908
    ip ospf 192.168.255.29 area backbone
    ip ospf 192.168.255.29 priority 100
    ip pim-sparse
    ip-addr any
    exit
    exit

    second switch:
    router ospf
    area 172.20.32.0
    area backbone
    redistribute connected
    exit
    router pim
    exit
    vlan 905
    ip ospf area backbone
    exit
    vlan 906
    ip ospf area backbone
    exit

    new switch:
    router ospf
    area 172.20.33.0
    area 172.22.18.0
    area backbone
    redistribute connected
    exit
    interface loopback 1
    ip address 192.168.255.252
    ip ospf 192.168.255.252 area backbone
    exit
    vlan 902
    ip ospf 192.168.255.6 area backbone
    exit
    vlan 903
    ip ospf 192.168.255.10 area backbone
    exit

  5. #5

    Join Date
    Jul 2010
    Posts
    106
    Thank Post
    0
    Thanked 14 Times in 14 Posts
    Rep Power
    11
    Hi can i ask why you have so many areas??

    i would only expect to see something like this in the a fairly simple config, just change the router id and ip addresses

    Vlan 10
    name "data"
    untagged a1-a24
    ip helper-address 10.10.1.1
    ip address 10.10.10.254 255.255.255.0
    exit
    Vlan 20
    name "voice"
    tagged a1-a24
    ip helper-address 10.10.1.1
    ip address 10.10.20.254 255.255.255.0
    exit
    ip router-id 1.1.1.1
    router ospf
    area backbone
    redistribute connected
    enable
    exit
    Vlan 10
    ip ospf 10.10.10.254 area backbone
    exit
    Vlan 20
    ip opsf 10.10.20.254 area backbone
    exit
    Last edited by apeman; 17th May 2012 at 10:00 PM.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 0
    Last Post: 29th March 2012, 03:41 PM
  2. Routing between VLANs on HP ProCurve 4108GL Switch
    By robknowles in forum Wireless Networks
    Replies: 12
    Last Post: 1st June 2010, 08:12 AM
  3. WOL between HP Procurve 5406zl switches
    By jj99 in forum Wireless Networks
    Replies: 6
    Last Post: 18th August 2009, 08:30 PM
  4. Static IP's for your switches
    By tosca925 in forum How do you do....it?
    Replies: 2
    Last Post: 21st November 2006, 08:03 PM
  5. Wireless Routing between two wireless routers
    By HodgeHi in forum Wireless Networks
    Replies: 2
    Last Post: 4th August 2006, 05:24 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •