+ Post New Thread
Results 1 to 11 of 11
Wired Networks Thread, 3Com Stacked Switches - Does LACP work accross the stack? in Technical; Hi all, We've got 3x 3Com 5500G's switches stacked running as the core. I'm looking to implement Link Aggregation to ...
  1. #1

    Join Date
    Oct 2007
    Location
    Northamptonshire
    Posts
    310
    Thank Post
    20
    Thanked 80 Times in 68 Posts
    Rep Power
    43

    Question 3Com Stacked Switches - Does LACP work accross the stack?

    Hi all,

    We've got 3x 3Com 5500G's switches stacked running as the core. I'm looking to implement Link Aggregation to the edge switches which are also stacked (3Com 5500 - non G's).

    We're currently running single 1 Gigabit links between the core and edge switches. What I'd like to do is use the extra fibre pairs we have to provide two or more 1 GB links to each of the edge stacks but ideally using different switches in the stack for each link. So for example a link between Unit 1 of the core stack to Unit 1 of an edge stack and then Unit 2 of the core to Unit 2 of the same edge stack. The idea being that we increase throughput as well as provide redundancy if one of the links or one of the switches in the link aggregation group fails.

    Does anyone know if that's a supported configuration or is using a configuration similar to this?

    Thanks,

    Ash

  2. #2


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    Are they in the same location? - you'd be better off with a stacking cable.

    Otherwise my config is below for 2xlink aggregations (with vlans). If you don't need the vlans take out these bits: "" port link-type hybrid" "port hybrid vlan 24 100 tagged" and " port hybrid vlan 1 untagged"
    IIRC you can add upto 8 links in an aggregation group (across the switches)

    Code:
    link-aggregation group 1 mode static						
    link-aggregation group 1 description Link-to-5500-location-X						
    
    
    int g1/0/1
     undo stp edged-port
     undo port access vlan
     jumboframe enable
     description description Link-to-5500-location-X
     port link-type hybrid
     port hybrid vlan 24 100 tagged
     port hybrid vlan 1 untagged
     broadcast-suppression pps 3000
     lacp enable
     port link-aggregation group 1
     apply qos-profile default
    
    int g1/0/2
     undo stp edged-port
     undo port access vlan
     jumboframe enable
     description description Link-to-5500-location-X
     port link-type hybrid
     port hybrid vlan 24 100 tagged
     port hybrid vlan 1 untagged
     broadcast-suppression pps 3000
     lacp enable
     port link-aggregation group 1
     apply qos-profile default
    Last edited by CyberNerd; 11th April 2012 at 10:44 PM.

  3. Thanks to CyberNerd from:

    Ashm (11th April 2012)

  4. #3

    Join Date
    Oct 2007
    Location
    Northamptonshire
    Posts
    310
    Thank Post
    20
    Thanked 80 Times in 68 Posts
    Rep Power
    43
    The 10/100 5500 edge switch stacks are in different locations apart from a stack of 7 which are in the same comms room as the 5500G Core stack. The maximum you can stack is 8 and to be honest I don't know if you can stack 10/100/1000 5500G's and 10/100 5500's together or would want to?

    We do use VLANs, I currently use the trunk option rather than the hybrid one for the links between core and edge. I forget what the major difference is between the two but I remember hybrid being a better fit for tagging the voice vlan for VOIP phones on the standard client ports.

    Thanks for the config - is that from a 5500? or a different 3Com model? I assume from the config you're running aggregation on ports one & two of the same switch? Are you running it anywhere where the aggregation group consists of ports from different switches in the stack?

  5. #4


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    Quote Originally Posted by Ashm View Post

    Thanks for the config - is that from a 5500? or a different 3Com model? I assume from the config you're running aggregation on ports one & two of the same switch? Are you running it anywhere where the aggregation group consists of ports from different switches in the stack?
    It's from a 5500G, which is comware 3. the links are to 4500 switches.
    The 1/0/1 1/0/2 was an example - yes you can do it across 2/x/x 3/x/x as long as the stack is correctly configured.
    You'll need hybrid trunks for vlan tagging.

  6. #5


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    how to test it's working:
    if you run "display link-aggregation verbose" it will display the link status you should see "ACDEF" on both links in the aggregation group to prove the lacp is working.

  7. #6

    Join Date
    Oct 2007
    Location
    Northamptonshire
    Posts
    310
    Thank Post
    20
    Thanked 80 Times in 68 Posts
    Rep Power
    43
    Thanks for all the info. Hopefully I'll get a chance to test it soon!

    You can definitely use the trunk option instead of the hybrid option for VLAN tagging. This is what the 3Com Stackable Switch Family Advanced Configuration Guide says:

    An Ethernet port on an Ethernet switch can operate in one of the three link types:
    • Access: an access port can belong to only one VLAN and is generally used to connect to a PC.
    • Trunk: a trunk port can belong to multiple VLANs. It can receive/send packets of multiple VLANs and is generally used to connect to a switch.
    • Hybrid: a hybrid port can belong to multiple VLANs. It can receive/send packets of multiple VLANs and can be used to connect to either a switch or a PC.

  8. #7

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,829
    Thank Post
    840
    Thanked 1,399 Times in 962 Posts
    Blog Entries
    47
    Rep Power
    603
    I was told by an engineer last week that Hybrid is better because you control exactly what VLANs go across it, whereas Trunk just lets anything tagged through.

    Regarding stacking & teaming, we have exactly that here now with our new switches - I have a stack of 3 A5120's in my office that each have two fibre cables connected back to the 2x A5800s stacked at the core. As a result there's 6Gbps of bandwidth available and we can survive any one switch or fibre run falling over. There's a similar set up with the edge stack of 5120's in the same rack as the core, the only difference being it's connected via front copper ports instead of fibre.

    I can probably dig out the code to set it up if you want. These are comware 5 switches, btw, but I believe the command line stuff will be pretty similar - certainly the comware 3 switches around the network I've got are identical as far as I've mucked about, although none of them have LACP on them.

  9. #8


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    Quote Originally Posted by sonofsanta View Post
    I can probably dig out the code to set it up if you want. These are comware 5 switches, btw, but I believe the command line stuff will be pretty similar - certainly the comware 3 switches around the network I've got are identical as far as I've mucked about, although none of them have LACP on them.
    It is a bit different - in Comware 5 you need to create the brifdge aggregation group, add teh ports to that group and then assign the vlan/hybrid settings to that - and it has to be done in that order.
    With comware 3 you just added the vlan settings to the individual ports.

  10. #9

    Join Date
    Oct 2007
    Location
    Northamptonshire
    Posts
    310
    Thank Post
    20
    Thanked 80 Times in 68 Posts
    Rep Power
    43
    Thanks for the info @sonofsanta. With regards to the trunk option you can define exactly which VLANs are allowed across the the link eg:

    Code:
    interface GigabitEthernet1/0/49
    port link-type trunk
    port trunk permit vlan 10 20 40 60 130 140 150
    It's interesting, I've been monitoring the ports on the core switch stack connected to the single gigabit edge fibre links using Cacti and I don't think the usage is anywhere near as high as I was anticipating. Admittedly it's using the default 5 minute poll time, but even during peak times it's hardly saturating the links.

  11. #10


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    AFAIK you wouldn't be able to send untagged vlan traffic across the trunked port but you can with hybrid ports.

  12. #11

    Join Date
    Oct 2007
    Location
    Northamptonshire
    Posts
    310
    Thank Post
    20
    Thanked 80 Times in 68 Posts
    Rep Power
    43
    That's exactly it, but we have no need to send untagged traffic over the fibre links as they are going to other vlan capable switches. We then use Hybrid type ports for ports that end devices are connected to with untagged traffic going on the default client vlan and tagged traffic for the VOIP vlan.

SHARE:
+ Post New Thread

Similar Threads

  1. Does anybody work for the NWLG?
    By FN-GM in forum North West Learning Grid (NWLG)
    Replies: 0
    Last Post: 20th February 2009, 11:42 AM
  2. How the hell does this work!!
    By Dos_Box in forum Jokes/Interweb Things
    Replies: 18
    Last Post: 21st November 2007, 02:41 PM
  3. How the hell does Vasco work?
    By mrforgetful in forum How do you do....it?
    Replies: 2
    Last Post: 30th October 2007, 04:12 PM
  4. Where does WSUS store all the updates?
    By ChrisH in forum Windows
    Replies: 4
    Last Post: 13th September 2005, 10:55 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •