+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 17
Wired Networks Thread, Help with configuring DHCP with VLAN on procurve switch in Technical; I'm trying to get DHCP to assign ip addresses on my open SSID network using Ubiquiti Unifi AP's (open set ...
  1. #1

    Join Date
    Sep 2007
    Posts
    132
    Thank Post
    14
    Thanked 2 Times in 2 Posts
    Rep Power
    14

    Help with configuring DHCP with VLAN on procurve switch

    I'm trying to get DHCP to assign ip addresses on my open SSID network using Ubiquiti Unifi AP's (open set to VLAN 2), this is how my HP procurve 5406ZL switch is setup with port B13 being my DHCP server bound NIC and port B23 is my unifi, when i try to connect to my open SSID i am not getting a DHCP address, can anyone help?

    Capture1.PNG

  2. #2

    synaesthesia's Avatar
    Join Date
    Jan 2009
    Location
    Northamptonshire
    Posts
    5,883
    Thank Post
    575
    Thanked 1,000 Times in 772 Posts
    Blog Entries
    15
    Rep Power
    461
    ack - you have a positively *ancient* firmware on that switch, I don't even recognise it so can't really advise much :| In the CLI for the switch, do:
    conf
    vlan 2
    dhcp helper-address dhcp.server.ip.here (i.e. dhcp helper-address 192.168.1.1)
    write mem
    exit

  3. #3

    Join Date
    Sep 2007
    Posts
    132
    Thank Post
    14
    Thanked 2 Times in 2 Posts
    Rep Power
    14
    Really? I updated it a few weeks ago
    Capture2.PNG

  4. #4
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    It's K.15.06.0008 now but it shouldn't be a problem.

  5. #5
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    Is B13 direct into the server? If so that needs to be untagged. Also B23 needs to be untagged in your default vlan. You only tag the wifi vlan. You should have this set in the Unifi wireless config.

  6. #6

    Join Date
    Sep 2007
    Posts
    132
    Thank Post
    14
    Thanked 2 Times in 2 Posts
    Rep Power
    14
    yes b13 is direct to server

    in the cli i'm getting invalid input: helper-address

    new config still not picking up DHCP on my open SSID:

    Capture3.PNG

    I have GVRP enhabled this ip range is on a different subnet
    Attached Images Attached Images
    Last edited by chrisjako; 3rd February 2012 at 02:00 PM.

  7. #7
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    Its ip helper-address. Have you typed config t in before to get into the config console? b13 needs to be untagged not auto.


    Andy

  8. #8

    Join Date
    Sep 2007
    Posts
    132
    Thank Post
    14
    Thanked 2 Times in 2 Posts
    Rep Power
    14
    config t worked, if i set it to untagged it sets itself to auto on VLAN 1

    Capture4.PNG

    seems to be assigning DHCP address to any device on my network now

  9. #9
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    Quote Originally Posted by chrisjako View Post

    seems to be assigning DHCP address to any device on my network now
    On the wireless?

  10. #10

    Join Date
    Sep 2007
    Posts
    132
    Thank Post
    14
    Thanked 2 Times in 2 Posts
    Rep Power
    14
    no on the wired, wireless still not picking up a DHCP address

  11. #11
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    You need to set b13 to no on vlan 1. If you type menu in the cli under switch config : vlan menu : vlan port assignment you can do it in there.

  12. #12

    Join Date
    Sep 2007
    Posts
    132
    Thank Post
    14
    Thanked 2 Times in 2 Posts
    Rep Power
    14
    B13 set to forbid on VLAN 1

    my iphone is picking up IP on the secure SSID but still a no go on the open SSID

  13. #13
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    Can you post a pic of your unifi wlan config?

  14. #14

    Join Date
    Sep 2007
    Posts
    132
    Thank Post
    14
    Thanked 2 Times in 2 Posts
    Rep Power
    14
    Capture.PNG

    Thanks for your help btw!

  15. #15
    nicholab's Avatar
    Join Date
    Nov 2006
    Location
    Birmingham
    Posts
    1,466
    Thank Post
    4
    Thanked 97 Times in 93 Posts
    Blog Entries
    1
    Rep Power
    50
    Note the Ip helper allows 8 different protocols between sub-nets including DHCP.

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. VLANs on HP Switches
    By localzuk in forum Wireless Networks
    Replies: 3
    Last Post: 14th July 2009, 11:19 AM
  2. MAC Based vlan allocation with procurve switches (11x)
    By AlexB in forum Wireless Networks
    Replies: 25
    Last Post: 21st September 2008, 05:56 PM
  3. Help with VLANs
    By robbie-w in forum Wireless Networks
    Replies: 20
    Last Post: 17th April 2008, 02:15 PM
  4. Replies: 7
    Last Post: 2nd January 2007, 11:48 PM
  5. Help with setting up a domain on a Donated HP Netserver
    By tickmike in forum Wireless Networks
    Replies: 11
    Last Post: 13th July 2006, 10:28 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •